These are chat archives for fossasia/open-event-server

3rd
Oct 2017
Rahul Tiwari
@invinciblycool
Oct 03 2017 02:39
Actually the error count is 51, so I guess sharing all the logs won't be possible.
And yes I have created the database and while exporting the database URL also I use the admin user in the URL with access to all rights.
Rahul Tiwari
@invinciblycool
Oct 03 2017 13:00
@ananyo2012 Could you please help. Because I am not able to progress further without the tests running fine.
Shubham Padia
@shubham-padia
Oct 03 2017 14:01
If you are having trouble seeing up the tests, for now enable Travis on your fork and let travis run the tests for you until you figure out the problem in the test setup
*setting
Rahul Tiwari
@invinciblycool
Oct 03 2017 14:26
Okay I will enable Travis on my fork then.
That will also include Travis to run the tests, right?
Shubham Padia
@shubham-padia
Oct 03 2017 14:32
Yep
Ananyo Maiti
@ananyo2012
Oct 03 2017 16:20
@invinciblycool The error should be similar for most of them
If you can share even a part of log I may be able to help
Rahul Tiwari
@invinciblycool
Oct 03 2017 16:21
just a sec then
Ananyo Maiti
@ananyo2012
Oct 03 2017 16:21
You can just put the logs in a gist and share the link here
Rahul Tiwari
@invinciblycool
Oct 03 2017 16:22
Yeah, sure
Rahul Tiwari
@invinciblycool
Oct 03 2017 17:20
@ananyo2012 Here you go
Appreciate the help
Saurabh Srivastava
@simsausaurabh
Oct 03 2017 17:36
.bowerrc
I'm unable to find this file in project folder.
please help:-)
Rahul Tiwari
@invinciblycool
Oct 03 2017 17:38
If you are on the nextgen branch.
Just skip the bower step.
Atleast that's what I did.
Saurabh Srivastava
@simsausaurabh
Oct 03 2017 17:38
how should I confirm that whether I am nextgen branch or not @invinciblycool
Rahul Tiwari
@invinciblycool
Oct 03 2017 17:39
git status or git branch -v
Saurabh Srivastava
@simsausaurabh
Oct 03 2017 17:40
Thanks @invinciblycool for help
Ananyo Maiti
@ananyo2012
Oct 03 2017 17:58
@invinciblycool This answer should solve your issue
I faced similar issue and it solved my problem
Rahul Tiwari
@invinciblycool
Oct 03 2017 19:20
I have done that previously. Didn't help.
I tried it again after deleting the database and role and again creating them.
Still the same error :worried:
Rahul Tiwari
@invinciblycool
Oct 03 2017 19:30
Got it working :smile:
Guess what, there was another role called open-event-user which I had created while installation.
I altered its permissions and got the tests running fine, I don't know why it fixed the problem because test_user was the role associated with the test database opev_test