These are chat archives for fossasia/open-event-server

19th
Jan 2018
Garvit Dewan
@dgarvit
Jan 19 2018 18:17
so i cloned and installed open-event-frontend
on opening the link on browser, i get a blank screen
Screenshot from 2018-01-19 23-46-47.png
with a message in the console Uncaught SyntaxError: missing ) after argument list at r ((index):1) at XMLHttpRequest.r.onreadystatechange ((index):1)
how should i proceed?
Saurabh Srivastava
@simsausaurabh
Jan 19 2018 18:36
what is your node and npm version @dgarvit
@nityanandagohain I will get back to you in some time hold on just a bit. I will try to solve your problem :smile:
Garvit Dewan
@dgarvit
Jan 19 2018 18:37
node version 6.0.0
npm version 3.8.6
@simsausaurabh
Saurabh Srivastava
@simsausaurabh
Jan 19 2018 19:27
the requirement is npm v5.2.x
I have node v8.9.4
and npm v5.2.0
use nvm to install node v8.9.4
as: nvm install v8.9.4
and for npm: npm install npm@5.2.0 -g
Anshuman Verma
@anshumanv
Jan 19 2018 19:30
Just goto - https://nodejs.org/en/download/ and install the way you want.
Saurabh Srivastava
@simsausaurabh
Jan 19 2018 19:30
and after installing node and npm install all other pre-requirements mentioned on the website
yeah you can definately use direct download as mentioned by @anshumanv
you will eventually get it working
Anshuman Verma
@anshumanv
Jan 19 2018 19:32
:smile:
Saurabh Srivastava
@simsausaurabh
Jan 19 2018 19:32
:smile:
Garvit Dewan
@dgarvit
Jan 19 2018 19:43
@simsausaurabh now getting error Error: Wanted node version >= 4 <8 (>=4.0.0 <8.0.0) while running npm install
Saurabh Srivastava
@simsausaurabh
Jan 19 2018 19:43
ohh then install node v7.10.1
and rest remains same
firstly install node by this version then npm 5.2.0
you will surely get it working
Garvit Dewan
@dgarvit
Jan 19 2018 19:47
sorry to say but still stuck on the same screen
Saurabh Srivastava
@simsausaurabh
Jan 19 2018 19:48
again node -v ? and npm -v ?
Garvit Dewan
@dgarvit
Jan 19 2018 19:48
old versions again... why is that happening
Saurabh Srivastava
@simsausaurabh
Jan 19 2018 19:49
its because of the node and npm version which is installed and the required ones
do nvm ls-remote
you are getting node v7.10.1?
Garvit Dewan
@dgarvit
Jan 19 2018 19:49
no. 6.0.0
and 3.8 for npm
Saurabh Srivastava
@simsausaurabh
Jan 19 2018 19:50
in the list
Garvit Dewan
@dgarvit
Jan 19 2018 19:50
though i updated by running the commands u said
Saurabh Srivastava
@simsausaurabh
Jan 19 2018 19:50
yeah you will not get both the node and npm by just node installing
it gets changed by the node
npm associated with node
do one thing
delete that folder clone again and
do nvm install v7.10.1
Garvit Dewan
@dgarvit
Jan 19 2018 19:51
the complete repo you mean?
Saurabh Srivastava
@simsausaurabh
Jan 19 2018 19:51
it will install node and nvm with some versions
yeah
Garvit Dewan
@dgarvit
Jan 19 2018 19:52
okay
Saurabh Srivastava
@simsausaurabh
Jan 19 2018 19:52
means from origin to local
Garvit Dewan
@dgarvit
Jan 19 2018 19:52
okay
Saurabh Srivastava
@simsausaurabh
Jan 19 2018 19:53
then do npm install npm@5.3.0
it will work with v7.10.1
node
please don't install npm@5.2.0
I tried with that and not working
but with 5.3.0 its working fine
Garvit Dewan
@dgarvit
Jan 19 2018 19:54
okay. i'll do that. thanks for the support :smile:
Saurabh Srivastava
@simsausaurabh
Jan 19 2018 19:55
yeah, I hope I can resolve the issue really soon next time :smile:
welcome
Garvit Dewan
@dgarvit
Jan 19 2018 20:14
thanks a lot for the help buddy, it really worked now! :smile:
Saurabh Srivastava
@simsausaurabh
Jan 19 2018 20:15
hehe... looking forward to your contribution :smile:
anytime
Garvit Dewan
@dgarvit
Jan 19 2018 20:15
:smile: