These are chat archives for fossasia/open-event-server

5th
May 2018
Siddhant Chhabra
@siddhant-curious
May 05 2018 08:26
is there any support at all for this repo?
Kreijstal
@Kreijstal
May 05 2018 08:40
development is ongoing, but there are many issues which need to be solved
Specially on the set-up of the server.

I get xhtml2pdf 0.2.2 has requirement html5lib>=1.0, but you'll have html5lib 0.9999999 which is incompatible. which installing the requirements, any idea on how to resolve this?
I resolved it.

How did you solve it?

Siddhant Chhabra
@siddhant-curious
May 05 2018 09:46
bleach version was the issue. There was a dependency conflict. I updated the common.txt to have bleach as bleach>=1.5.0 instead of bleach>=1.5.0,<2
Before I report this issue on repo (probably my first issue), I am trying to check if this doesn't break the functionality and hence trying to run the tests
However I get current_app import issue, in setup database file, so I think it has something to do with DB instead of bleach. Once I pass all the tests, I'll report this issue on repo and provide a PR>
bleach>=1.5.0 installs bleach 2
Suneet Srivastava
@codedsun
May 05 2018 14:05
Hello, I am not able to hit the api for authentication
Saurav Tiwary
@srv-twry
May 05 2018 14:06
fossasia/open-event-server#4692
Once it gets resolved you should be able to use it
Saurav Tiwary
@srv-twry
May 05 2018 15:25
@niranjan94 @SaptakS @shubham-padia @iamareebjamal Please review and provide some feedback on fossasia/open-event-server#4679
I haven't received any feedback on it. It's a WIP PR. I have implemented and added the decorator to one model and would like to confirm if it's well implemented or not before applying the decorator to every model. Thank you
Please ignore hound voilations for now. I will fix them.