These are chat archives for fossasia/open-event-server

11th
Feb 2019
Uddeshya Singh
@uds5501
Feb 11 15:38 UTC
@mrsaicharan1 Could you please forward your twitter authentication redirection details? Thanks!
(I mean the Home page url and redirection uri you entered in twitter webapp while testing your twitter OAuth)
Saicharan Reddy
@mrsaicharan1
Feb 11 15:39 UTC
Twitter only has a callback url which I set it to /twitter_login/authorized
Uddeshya Singh
@uds5501
Feb 11 15:40 UTC
alright
Uddeshya Singh
@uds5501
Feb 11 16:00 UTC
Was an error on my side, @mrsaicharan1 Make sure to update the callback URI in the PR for third_party_helper so as to make sure that we are sending updated redirect uri to the user in the queries.
I was sending the wrong redirect uri all this time
*Update redirect URI for twitter
image.png
This piece particularly.
Saicharan Reddy
@mrsaicharan1
Feb 11 16:03 UTC
Where do you want me to update the callback uri exactly?
Uddeshya Singh
@uds5501
Feb 11 16:04 UTC
api/helpers/third_party_auth
IMO this get_redirect_uri should be returning the CallbackURL to be set by the user. Right?
Please do correct me if I am wrong
Saicharan Reddy
@mrsaicharan1
Feb 11 16:05 UTC
Will check it out in a moment. Thanks for the update btw :)
Uddeshya Singh
@uds5501
Feb 11 16:11 UTC
:+1:
Saicharan Reddy
@mrsaicharan1
Feb 11 16:21 UTC
Where are you setting the callback_uri?
Uddeshya Singh
@uds5501
Feb 11 16:22 UTC
image.png
Here
Saicharan Reddy
@mrsaicharan1
Feb 11 16:23 UTC
It's the same thing which I have placed in the twitter app on the dev console :)
Uddeshya Singh
@uds5501
Feb 11 16:24 UTC
Okay, just tell me this. in this file api/helpers/third_party_auth, what exactly is the redirect_uri
Saicharan Reddy
@mrsaicharan1
Feb 11 16:24 UTC
Also, I'm just stalled because of this
sqlalchemy.exc.ProgrammingError: (psycopg2.ProgrammingError) relation "settings" does not exist. twitter oauth Works perfectly on my local system.
Uddeshya Singh
@uds5501
Feb 11 16:24 UTC
Tried migrating?
Saicharan Reddy
@mrsaicharan1
Feb 11 16:24 UTC
Yup No luck
it also says multiple migrations even though I don't have multiple ones.
Uddeshya Singh
@uds5501
Feb 11 16:25 UTC
what was the last migration made in the system?
Saicharan Reddy
@mrsaicharan1
Feb 11 16:25 UTC
lemme check the version id
Uddeshya Singh
@uds5501
Feb 11 16:25 UTC
yeah
Saicharan Reddy
@mrsaicharan1
Feb 11 16:26 UTC
revision = 'e20a821c7c7e'
down_revision = '91ee86a38001'
91ee86a38001 was the most recent one which was merged
Uddeshya Singh
@uds5501
Feb 11 16:27 UTC
yup confirmed that
it's same in my system too
Saicharan Reddy
@mrsaicharan1
Feb 11 16:29 UTC
Also, the redirect uri is basically twitter/authorized. But because we defined the namespace in the blueprint /twitter_login, it's now /twitter_authorized/twitter/login
Uddeshya Singh
@uds5501
Feb 11 16:29 UTC
why do you have two migration files?
Saicharan Reddy
@mrsaicharan1
Feb 11 16:30 UTC
Did you check my PR?
Uddeshya Singh
@uds5501
Feb 11 16:30 UTC
yes
seeing that only
Why do you have 2 migration files?
image.png
Saicharan Reddy
@mrsaicharan1
Feb 11 16:31 UTC
Oh right! I just pushed with another migration. Lemme see what happens if I merge those both.
Was just trying out ways to get rid of the error.
will update
Uddeshya Singh
@uds5501
Feb 11 16:32 UTC
go ahead
Saicharan Reddy
@mrsaicharan1
Feb 11 16:37 UTC
Deleted the empty migration.
Uddeshya Singh
@uds5501
Feb 11 16:37 UTC
Watching the build
lets see how it unfolds
Saicharan Reddy
@mrsaicharan1
Feb 11 17:36 UTC
Hmm still the same error @uds5501
Uddeshya Singh
@uds5501
Feb 11 17:38 UTC
My build is suffering the same fate.
@CosmicCoder96 any guidance?
Saicharan Reddy
@mrsaicharan1
Feb 11 17:41 UTC
Did you get the same error?
Uddeshya Singh
@uds5501
Feb 11 17:41 UTC
Yes
Saicharan Reddy
@mrsaicharan1
Feb 11 17:42 UTC
It might be something related to obtaining the keys from settings.
Uddeshya Singh
@uds5501
Feb 11 17:56 UTC
What's that got to do with multiple heads 😅
Saicharan Reddy
@mrsaicharan1
Feb 11 17:59 UTC
Screenshot from 2019-02-11 11-03-00.png