Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Sep 21 15:56
    ranjsa opened #6459
  • Sep 21 06:24
    kushthedude closed #6455
  • Sep 21 06:24
    kushthedude commented #6455
  • Sep 20 22:19
    shreyanshdwivedi commented #6393
  • Sep 20 19:19
    codecov[bot] commented #6458
  • Sep 20 19:18
    codecov[bot] commented #6457
  • Sep 20 19:08
    codecov[bot] commented #6456
  • Sep 20 19:01
    codecov[bot] commented #6455
  • Sep 20 19:01
    darkthunder007 closed #6457
  • Sep 20 18:58
    darkthunder007 closed #6458
  • Sep 20 18:57
    darkthunder007 closed #6456
  • Sep 20 18:55
    darkthunder007 opened #6458
  • Sep 20 18:52
    darkthunder007 edited #6457
  • Sep 20 18:52
    darkthunder007 edited #6457
  • Sep 20 18:51
    darkthunder007 opened #6457
  • Sep 20 18:48
    darkthunder007 edited #6456
  • Sep 20 18:48
    darkthunder007 edited #6456
  • Sep 20 18:48
    darkthunder007 edited #6456
  • Sep 20 18:48
    darkthunder007 edited #6456
  • Sep 20 18:48
    darkthunder007 edited #6456
Suneet Srivastava
@codedsun
how do i see the initial schema of database ? @prateekj117
Prateek Jain
@prateekj117
@codedsun There are some tables like settings, event_topics, etc. which get filled with some default values when you run python3 create_db.py.
For seeing that, you can maybe connect your db with the IDE you are using, and it will provide you with a UI to view your database. In my case, I use Pycharm, and it provides an awesome UI for it.
Suneet Srivastava
@codedsun
cool, got it. Thanks @prateekj117
Prateek Jain
@prateekj117
@codedsun No problem buddy. Happy contributing !!!
Tushar Gaurabh Jha
@ranjsa
Can anyone please tell me how to get user details from open event server
I was using postman to get user detalis but I got this error "error": "Invalid crypto padding"
Here is the Screenshot
https://drive.google.com/file/d/19mrk5zogfaLUh8LUStJ6GiiZiAQDxId0/view?usp=sharing
Prateek Jain
@prateekj117
@ranjsa You don't need to use {} in url params and <> in JWT param.
Saicharan Reddy
@mrsaicharan1

It only says to create a user and db, no such dump of data available @prateekj117

Use Flask-Admin

Tushar Gaurabh Jha
@ranjsa
@prateekj117
@prateekj117 Thanks for help.... It's working now
Prateek Jain
@prateekj117
@ranjsa Awesome.
Muhammad Arslan
@arslan_mecom_twitter
cannot be able to link stripe account, got 404, is this a known issue?
Ayush Mahajan
@ay2306
Hey Guys,
I am Ayush a pre final year student from India.
I am willing to contribute to open-event-server
Is Issue #6396 still being worked by someone. If not can I start working on it?
Thank you.
Prateek Jain
@prateekj117
@ay2306 You can go ahead with this issue.
Tushar Gaurabh Jha
@ranjsa

@prateekj117 Can you please help when I have favourited only 12 events using android app ,
https://drive.google.com/file/d/1064GyNKVSgljvIWp-G-OvZarW4pAdlhI/view?usp=sharing

then why I am getting 20 favourited events using GET request using postman

https://drive.google.com/file/d/1bcmMJt-U5Xyn0HV2s5DEntjtirqRBlSF/view?usp=sharing
https://drive.google.com/file/d/12f2AzLi1-khFOAP_pXJ0RmftjzGh_Tx-/view?usp=sharing

Prateek Jain
@prateekj117
@ranjsa For starters, always use https://open-event-api-dev.herokuapp.com as it's in sync with the development branch, or on localhost (if you want to contribute to open-event-server). Try with this and see if the problem persists, if it does, report an issue and we can discuss further over this.
Kush Trivedi
@kushthedude
@iamareebjamal Dredd hooks are getting failed again, And I think we should use apiary to log the logs of dredd , Since it is must for the latest dredd version. Should I open relevant issue ?
Shreyansh Dwivedi
@shreyanshdwivedi
@kushthedude if you are referring to the travis failure in your latest PR, it showed an appropriate message - TabError: inconsistent use of tabs and spaces in indentation. Do you expect any other error description?
Saicharan Reddy
@mrsaicharan1
Dredd is working. Reiterate your PR
Areeb Jamal
@iamareebjamal
What is more amazing to me is that in the current state of PR, the server can't even run. So you just made some random edits and sent a PR without testing anything
Saicharan Reddy
@mrsaicharan1
For everyone participating in codeheat, here are a few ideas on what you could work on:
  • Automation of payment reminders and restriction of certain app features due to unpaid invoices
  • Order API recreation
  • Testing modules throughout the app
  • Payment Refund Module
Kush Trivedi
@kushthedude
warn: Compilation warning in '/home/travis/build/fossasia/open-event-server/docs/api/api_blueprint.apib': Ambiguous URI parameter in template: /v1/import-jobs{?page%5bsize%5d,page%5bnumber%5d,sort,filter}
Parameter not defined in API description document: filter (Open Event API Server > Import Jobs > Import Jobs Collection > List All Import Jobs)
 * Serving Flask app "app" (lazy loading)
 * Environment: testing
 * Debug mode: off
/home/travis/virtualenv/python3.6.3/lib/python3.6/site-packages/envparse.py:195: UserWarning: Could not any envfile.
  warnings.warn('Could not any envfile.')
/home/travis/virtualenv/python3.6.3/lib/python3.6/site-packages/flask_limiter/extension.py:113: UserWarning: Use of the default `get_ipaddr` function is discouraged. Please refer to https://flask-limiter.readthedocs.org/#rate-limit-domain for the recommended configuration
  " for the recommended configuration", UserWarning
/home/travis/virtualenv/python3.6.3/lib/python3.6/site-packages/flask_caching/__init__.py:202: UserWarning: Flask-Caching: CACHE_TYPE is set to null, caching is effectively disabled.
  "Flask-Caching: CACHE_TYPE is set to null, "
/home/travis/virtualenv/python3.6.3/lib/python3.6/site-packages/flask_celeryext/app.py:36: UserWarning: Celery v4 installed, but detected Celery v3 configuration CELERY_EAGER_PROPAGATES_EXCEPTIONS (use CELERY_TASK_EAGER_PROPAGATES instead).
  UserWarning
INFO:werkzeug: * Running on http://127.0.0.1:5000/ (Press CTRL+C to quit)
@shreyanshdwivedi @iamareebjamal , Server is running and these are the Travis logs, In which hooks were getting timed out ?
Saicharan Reddy
@mrsaicharan1

@shreyanshdwivedi @iamareebjamal , Server is running and these are the Travis logs, In which hooks were getting timed out ?

What do you mean by that?

The server seems to be running as expected.
Sandipan Dey
@triethyl
Hey I am absolutely new to this, what are the starting steps I need to follow?
Shreyansh Dwivedi
@shreyanshdwivedi
@triethyl please refer to README.md of the project and follow the steps
Mario Behling
@mariobehling
The FOSSASIA Python, Flask, EmberJS job is now also listed on Indeed: https://www.indeedjobs.com/fossasia/jobs/d1c0dba8cf18dba1dd33
Prateek Jain
@prateekj117
@iamareebjamal Can I get some rights in the open-event-server Project? I think I have done a fair amount of work on the project, and would continue to do the same, and have a decent knowledge of that project.
Areeb Jamal
@iamareebjamal
Will provide assigning and labelling rights. Merge rights after some more work
Prateek Jain
@prateekj117
@iamareebjamal Ok, Thank you, Sir.
Jayant Khandelwal
@Jackent2B
what's the problem?
Tushar Gaurabh Jha
@ranjsa
@prateekj117 Can you please help me , I want to fetch event organizer's email address how can can i get that from api ?
Areeb Jamal
@iamareebjamal
Jayant Khandelwal
@Jackent2B
@iamareebjamal thanks
Tushar Gaurabh Jha
@ranjsa
I am working on Contact Event Organizer feature on android app , I want to know is there a feature available in open event server to get Organizers Email address ?
darkthunder007
@darkthunder007
Hi, Im new and i would like to contribute.
Shivansh Bansal
@shivansh10
Hello everyone,
Currently, I'm trying to install open-event-server on docker. And there's a problem I'm facing right now
In the documentation it's saying to change the SERVER_NAME to Localhost
Can anyone tell me in which file I have to amend it.
Areeb Jamal
@iamareebjamal
Skip the step
Sunilkumar T C
@sunilkumar_tca_twitter
Traceback (most recent call last):
File "manage.py", line 3, in <module>
from app.api.helpers.db import save_to_db
File "/home/ubuntu/open-event-server/app/init.py", line 17, in <module>
from flask_rest_jsonapi.errors import jsonapi_errors
File "/home/ubuntu/open-event-server/src/flask-rest-jsonapi/flask_rest_jsonapi/init.py", line 3, in <module>
from flask_rest_jsonapi.api import Api
File "/home/ubuntu/open-event-server/src/flask-rest-jsonapi/flask_rest_jsonapi/api.py", line 6, in <module>
from flask_rest_jsonapi.resource import ResourceList
File "/home/ubuntu/open-event-server/src/flask-rest-jsonapi/flask_rest_jsonapi/resource.py", line 14, in <module>
from marshmallow_jsonapi.exceptions import IncorrectTypeError
File "/usr/local/lib/python3.5/dist-packages/marshmallow_jsonapi/init.py", line 1, in <module>
from .schema import Schema, SchemaOpts
File "/usr/local/lib/python3.5/dist-packages/marshmallow_jsonapi/schema.py", line 105
raise ValueError(f'Unknown field "{local_field}"')
^
SyntaxError: invalid syntax
Traceback (most recent call last):
File "create_db.py", line 7, in <module>
from app import current_app
File "/home/ubuntu/open-event-server/app/init.py", line 17, in <module>
from flask_rest_jsonapi.errors import jsonapi_errors
File "/home/ubuntu/open-event-server/src/flask-rest-jsonapi/flask_rest_jsonapi/init.py", line 3, in <module>
from flask_rest_jsonapi.api import Api
File "/home/ubuntu/open-event-server/src/flask-rest-jsonapi/flask_rest_jsonapi/api.py", line 6, in <module>
from flask_rest_jsonapi.resource import ResourceList
File "/home/ubuntu/open-event-server/src/flask-rest-jsonapi/flask_rest_jsonapi/resource.py", line 14, in <module>
from marshmallow_jsonapi.exceptions import IncorrectTypeError
File "/usr/local/lib/python3.5/dist-packages/marshmallow_jsonapi/init.py", line 1, in <module>
from .schema import Schema, SchemaOpts
File "/usr/local/lib/python3.5/dist-packages/marshmallow_jsonapi/schema.py", line 105
raise ValueError(f'Unknown field "{local_field}"')
I got above error I ran python3 createdb.py
any pointers would be appreciated
Areeb Jamal
@iamareebjamal

Use a virtual environment with python 3.6

You are using 3.5

Even better will be to be on latest python 3.7 because we are going to make it the minimum required version soon. And open-event-server channel is more appropriate for server related questions