Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    ligi
    @ligi
    application-8f7613f90eec18faa40f2b7ddf1584a6b3294f5400eab7b6bf79da8b41bd9ed8.js:124 Uncaught (in promise) TypeError: this.provider.send is not a function
    at a.send (application-8f7613f90eec18faa40f2b7ddf1584a6b3294f5400eab7b6bf79da8b41bd9ed8.js:124)
    at n.accounts (application-8f7613f90eec18faa40f2b7ddf1584a6b3294f5400eab7b6bf79da8b41bd9ed8.js:124)
    at basicWeb3Check (application-8f7613f90eec18faa40f2b7ddf1584a6b3294f5400eab7b6bf79da8b41bd9ed8.js:15)
    at application-8f7613f90eec18faa40f2b7ddf1584a6b3294f5400eab7b6bf79da8b41bd9ed8.js:15
    anyone has an idea what this is?
    ligi
    @ligi
    with foam FRAME crashes: floating/frame#286
    what dapps does frame work with?
    Jordan Muir
    @floating
    @ligi Is the peepeth client open source? I should be able to figure out what's going on pretty quickly if I can take a look. Lots of people use Frame every day with many dapps. I only know of one other dapp that was reported to have issues similar to this peepeth issue.
    ligi
    @ligi
    @floating unfortunately peepeth is not open sourcce
    Jordan Muir
    @floating
    The other app that was hitting this issue was also not open source. Would love to get to the bottom of it.
    The FOAM issue seems to be different
    @ligi One quick solution to it could be resetting all settings and permissions. You can do this by going into the settings (>>>) and mousing over the very bottom.
    And click "reset all settings and data"
    Jordan Muir
    @floating
    I just saw your response in the thread. It could have been a bug with a state transition running form source. We only handle/test migrating state schema changes between released versions so it's possible your state was in a bad place from running a previous, transitory version of Frame.
    ligi
    @ligi
    ah ok
    then feel free to close the issue
    thanks for looking into it
    just using dev to be able to use a hot-wallet
    or is this not needed anymore
    regarding peepeth I asked bevan on discord
    perhaps he answers
    Jordan Muir
    @floating
    This isn't needed, hot wallets are now supported by in the official releases.
    ligi
    @ligi
    cool
    Jordan Muir
    @floating
    Awesome, yes, I'm happy to help debug with the peepeth team.
    ligi
    @ligi
    peepeth seems to be doing something like this:
    window.web3=new Web3(window.web3.currentProvider)
    Jordan Muir
    @floating
    Yeah, that should be ok. Running window.web3.currentProvider.send('eth_accounts').then(console.log) in the console on https://peepeth.com/a/login works fine.
    ligi
    @ligi
    strange - I will try to get bevan here - but he seems to be afk now
    Jordan Muir
    @floating
    @ligi Sounds good. They may be using an older version of web3 and relying on synchronous "async exceptions" https://github.com/MetaMask/faq/blob/master/DEVELOPERS.md#dizzy-all-async---think-of-metamask-as-a-light-client that metamask still supports but are not part of the EIP-1193 spec or web3 > 1.0
    ligi
    @ligi
    dam localethereum also seems to not work
    says "not connected"
    Jordan Muir
    @floating
    @ligi localethereum seems to be working fine for me
    Where is it saying not connected?
    In settings (>>>) make sure you're currently connected to mainnet
    ligi
    @ligi
    Jordan Muir
    @floating
    @ligi It looks like you're running an older version of the browser extension. Try updating to 0.1.5 https://chrome.google.com/webstore/detail/frame/ldcoohedfbjoobcadoglnnmmfbdlmmhf
    ligi
    @ligi
    @floating oh nice - the extension is in the store now - sorry have not following for a while - still need to catch up
    ligi
    @ligi
    unfortunately with this version I cannot switch the provider on
    Jordan Muir
    @floating
    @ligi The provider/extension is always on now, it can be toggled off/disabled in the chrome extensions menu
    ligi
    @ligi
    ah oh nice
    Aaron Foster
    @pythonpete32
    hey guys. Im running into an issue with using frame in a Rinkeby DAO
    so i was able to launch the DAO signing all the required transactions
    but when it comes to interacting with the Apps they are not recognising frame. which is weird because the client still has me connected (in the top right it has my account, network and the green dot)
    Aaron Foster
    @pythonpete32
    Jordan Muir
    @floating
    @pythonpete32 Hey Aaron! Sorry for the delay. Can you explain what you mean by dapps are failing to recognize Frame and which dapps this is occurring with?
    Bowen Sanders
    @bowensanders
    Greetings! :)
    Bowen here. Really excited to use Frame with Giveth and MyCrypto - which I'm currently working on. Quick question - since I was attempting to bounce beetween 0.2.4 and 0.3.0, I realized I seem to have somehow corrupted the local DAO account - it's not asking for a password to use it anymore and even if I delete it and remake it I'm still having issues. So the real big question is how might I completely purge all of Frame's configurations / wallets / etc so I can start fresh again with 0.2.4 (at least for now) ?
    This is on MacOS Catalina
    Jordan Muir
    @floating
    @bowensanders You can do this by going into the settings (>>>), mousing over the very bottom and clicking "reset all settings and data". Note this will reset your added accounts and permission but will not remove any added hot signers.
    Jordan Muir
    @floating
    @bowensanders Let me know if you're still having any problems and I can help sort it out. I also just saw and responded to your other Github issue.
    Bowen Sanders
    @bowensanders
    @floating Thank you so much for your attention! I appreciate the help. I'll give this a shot and I'll let you know if it works.
    Gus
    @sepu85
    hello there! Gus here, I'm totally new to Frame and have I am facing an issue in starting it. I did install the chrome extension and installed it through the packet installer (v16.04 ubuntu), but the connection to frame is not working :(
    any suggested workarround?