Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Aug 15 18:50
    akuskis commented #443
  • Aug 15 18:37
    akuskis synchronize #443
  • Aug 15 18:22
    akuskis opened #443
  • Aug 12 20:42
    jkpubsrc commented #442
  • Aug 03 04:27
    tilkinsc commented #442
  • Aug 01 14:19
    jkpubsrc opened #442
  • Jul 25 14:53
    fengwang commented #346
  • Jul 21 16:15

    wheybags on video

    video specific patches (compare)

  • Jul 21 15:34

    wheybags on video

    video specific patches (compare)

  • Jul 17 06:50

    wheybags on ini_fix

    (compare)

  • Jul 17 06:50

    wheybags on master

    use redirection in ini file ins… (compare)

  • Jul 17 06:50
    wheybags closed #441
  • Jul 17 06:49
    wheybags synchronize #441
  • Jul 17 06:49

    wheybags on ini_fix

    use redirection in ini file ins… (compare)

  • Jul 17 06:47
    wheybags opened #441
  • Jul 17 06:47

    wheybags on ini_fix

    use redirection in ini file ins… (compare)

  • Jul 17 06:43

    wheybags on mp_bug_fixes

    (compare)

  • Jul 17 06:43

    wheybags on master

    don't dump players on top of ea… add hacky temporary method to m… fix out-of-bounds accesses in l… and 10 more (compare)

  • Jul 17 06:43
    wheybags closed #438
  • Jun 12 12:40
    AJenbo commented #397
Tom Mason
@wheybags
@MarcPer maybe try running the steam client? Iirc it uses sdl2 too
Problem is possibly missing/bad video drivers
ni-ku
@ni-ku
OK now i get it. Haven't seen the line with the pastebin, thanks
Marcelo
@MarcPer
@wheybags I ran Steam and a game from Steam as well, and it works fine. Could this be related to my Diablo.exe and DIABDAT.MQP? I've run the gog installer on my Linux using Wine and even though the files are there, there were some error messages during installation.
Tom Mason
@wheybags
It shouldn't cause that error, but maybe?
Try running the launcher, that should be able to run for sure without diablo data
and, just to be sure, this is using a binary built from latest master? And not the old 0.3 binaries?
Marcelo
@MarcPer
I'll try the launcher when I get home. And yes, I'm using the latest master.
Marcelo
@MarcPer
the launcher didn't work either
Marcelo
@MarcPer
is there something else I can try or more information I can provide?
Exairnous
@Exairnous
@MarcPer Does the launcher window show up or does it immediately crash?
Marcelo
@MarcPer
It crashes immediately, with the following response:
Could not create window: No available video device
Segmentation fault (core dumped)
Exairnous
@Exairnous
I think this is a system configuration problem, not a freeablo/diablo problem. I don't know if this helps at all but you could try this in a bash shell from the build directory: DISPLAY=:0; export DISPLAY; ./launcher
Installing xorg-dev may be something you could try as well
Marcelo
@MarcPer
Thanks for the suggestions @Exairnous, but none of these work. Has anyone managed to make freeablo work on Ubuntu 18.04? I have a rather clean OS, since I formatted my HD recently. I only had to install a few packages to make freeablo build work, such as mesa.
Tom Mason
@wheybags
Late response, but maybe try grabbing some example code using sdl2 and opengl, and seeing if that works?
Exairnous
@Exairnous
@MarcPer Sorry this took so long, but I think I have the solution for you. I installed ubuntu 18.04 in a virtual machine to see if I could replicate your error, and I did. Remember how I suggested installing xorg-dev? Well, what I didn't realize is that you also needed to have hunter rebuild freeablo's dependencies after installing xorg-dev. I think this comes from hunter building sdl2 and it needs the xorg development headers (provided by xorg-dev on ubuntu) to build properly.
So, to get freeablo working, I think the easiest thing to do is to:
make sure you have libgl1-mesa-dev and xorg-dev installed
delete everything in /home/USERNAME/.hunter/
rerun cmake .. from the freeablo build folder (hunter should now rebuild all the dependencies)
and recompile freeablo
This works in my virtual machine version of ubuntu 18.04. Fingers crossed it works for you too.
freeablo-irc-bridge
@freeablo-irc-bridge
[Lightkey] just fyi, your first message cut off after "and it needs th"
Exairnous
@Exairnous
Lightkey: Oh, ok. It was supposed to end like this: and it needs the xorg development headers (provided by xorg-dev on ubuntu) to build properly.
Marcelo
@MarcPer
I apologize for taking so long to respond as well. Anyway, good news: it's working! Thank you all for the help, especially to @Exairnous. It really was about rebuilding dependencies.
Exairnous
@Exairnous
Excellent! I'm glad it's working. Looking forward to your contributions.
Tom Mason
@wheybags
@Exairnous nice catch! That should be fixed in the SDL hunter package upstream
Exairnous
@Exairnous
@wheybags Thanks! :smile: Yeah, if it can be fixed upstream that would be good.
Renato Rabelo
@rsr_galo_twitter
is multiplayer working ?
freeablo-irc-bridge
@freeablo-irc-bridge
freeablo-irc-bridge
@freeablo-irc-bridge
Tom Mason
@wheybags
Anyone here that has used hunter: ruslo/hunter#1921
pls donate :v
I really do not want hunter to die
freeablo-irc-bridge
@freeablo-irc-bridge
[gibber] hi
[gibber] i need help
[gibber] i put the files in the freeablo directory but it just ctd
[gibber] PS C:\Users\joshu\Downloads\freeablo-v0.3-win32\freeablo-v0.3-win32> .\freeablo.exe
[gibber] n created yet
[gibber] m resources/fonts/FreeMono/FreeMono.ttf).
Tom Mason
@wheybags
run the launcher
Also, that version is very outdated, but there is no newer release available pre-compiled
just bear in mind, things have moved on a lot :)
freeablo-irc-bridge
@freeablo-irc-bridge
[dsd26] damn
[dsd26] thanks
[dsd26] does hellfire still work
Tom Mason
@wheybags
no hellfire support yet
freeablo-irc-bridge
@freeablo-irc-bridge
[dsd26] im seeing these people play diablo on their switch
qndel
@qndel
they can even play in browsers now ;)