Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 18:06
    eloquence synchronize #4928
  • 18:06

    eloquence on docs-100-to-110-upgrade-guide

    Add "Troubleshooting securedrop… (compare)

  • 17:53

    emkll on backport-4927

    (compare)

  • 17:53

    emkll on 1.1.0

    Fix Tails detection in Python 3… Merge pull request #4931 from f… (compare)

  • 17:53
    emkll closed #4931
  • 17:51
    emkll review_requested #4932
  • 17:51
    emkll review_requested #4932
  • 17:51
    emkll review_requested #4932
  • 17:51
    emkll opened #4932
  • 17:51
    emkll milestoned #4932
  • 17:28
    dependabot[bot] labeled #314
  • 17:28
    dependabot[bot] opened #314
  • 17:28

    dependabot[bot] on pip

    Bump urllib3 from 1.24.1 to 1.2… (compare)

  • 17:14

    emkll on 4929-delete-venv-if-creation-failed

    Delete newly created virtualenv… Add test to ensure envsetup del… (compare)

  • 17:04

    emkll on 4929-delete-venv-if-creation-failed

    Add test to ensure envsetup del… (compare)

  • 16:57
    eloquence synchronize #4928
  • 16:57

    eloquence on docs-100-to-110-upgrade-guide

    Add "Troubleshooting securedrop… (compare)

  • 16:33
    eloquence opened #4931
  • 16:33
    eloquence review_requested #4931
  • 16:33
    eloquence review_requested #4931
Conor Schaefer
@conorsch
ah-ha! so you had a dirty working copy
Kevin O'Gorman
@zenmonkeykstop
one annoying thing - because the securedrop_init.py script always bounces network, you now get the pop-up saying the updater is already running in the tailsconfig part of the process
Conor Schaefer
@conorsch
yeah i've seen that =( not ideal
that one's worth a follow-up issue, not a release blocker though
Kevin O'Gorman
@zenmonkeykstop
running it one more time with clean working copy, then wil lsee if i can recreate failure again
it's also not ideal that it doesn't give a useful message
Conor Schaefer
@conorsch
lgtm: after reboot, i was able to type in admin password in gui updater, and it took it the first time. i did see a failure afterward, during run of the tailsconfig step, but that's because i'd wiped the aths info from persistence out of habit, so tailsconfig couldn't find the necessary files (it did the first several times i ran it during initial migration)
Kevin O'Gorman
@zenmonkeykstop
haha that time it worked for me with the change in place
Conor Schaefer
@conorsch
looking good over here. @emkll, how fare you with graphical updater tests?
mickael e.
@emkll
Ok, that worked, I did indeed have a file that was left over from previous testing
:sweat_smile:
Conor Schaefer
@conorsch
woohoo! we just had the RM tap out due to timezones. what say you, DRM @emkll? (note: DRM = Deputy Release Manager)
mickael e.
@emkll
I'm almost done migrating a mac mini to v3 onion services, once that is complete and if/when @zenmonkeykstop is satisfied, i think we can proceed with the cutover
Conor Schaefer
@conorsch
roger that, standing by for dns cutover
Kevin O'Gorman
@zenmonkeykstop
preflights all working for me
mickael e.
@emkll
ok all preflights successful. Unless anyone has any objections, we can cut over
cc @conorsch
Conor Schaefer
@conorsch
no blockers to report here
proceeding with dns cutover
rmol
@rmol
here either.
Erik Moeller
@eloquence
\o/ :shipit:
Conor Schaefer
@conorsch
Proceeding with Nagios updates...
Erik Moeller
@eloquence
@conorsch I'm assuming docs branch and github release object are next on your list?
Conor Schaefer
@conorsch
thank for the reminder, one sec...
Conor Schaefer
@conorsch
@eloquence refresh my memory on the docs branch update step? i believe some action is required in ReadTheDocs—ensuring that release/1.0.0 maps to "stable", yes?
Erik Moeller
@eloquence
yes
"Make sure that the default branch of documentation is being built off the tip of the release branch."
so I think that's what you just said in different words :)
Conor Schaefer
@conorsch
still working on docs branch changes... i don't see the release/1.0.0 in there, so rebuilding from latest ad-hoc in an attempt to trigger a branch refresh
the webhook is still connected, i see successful deliveries from today
Erik Moeller
@eloquence
roger that, holding off on release announcement until then so we don't have to link to latest
Conor Schaefer
@conorsch
@eloquence should be good to go now, please check docs.securedrop.org and confirm you see 1.0.0
rmol
@rmol
Can confirm.
Erik Moeller
@eloquence
lgtm as well
Conor Schaefer
@conorsch
documented the steps here in the maintainer guide, since i couldn't find any pre-existing docs on updating the docs ("Yo, dawg...")
Erik Moeller
@eloquence
nice
posting release notes ...
nb, upgraded my instance via cron-apt and it seems to have worked fine, did have to shift+reload to clear out old stylesheets from cache
@conorsch could you poke at that backport docs PR?
Conor Schaefer
@conorsch
on it
Erik Moeller
@eloquence
will attempt to switch my longrunning instance over to v3 while bulk announce is running, in case of any issues not caught in QA for which it can serve as a canary
Erik Moeller
@eloquence
graphical updater worked, it did pop up an "updater already running" message briefly
Erik Moeller
@eloquence
getting my old friend "waiting for privilege escalation prompt" on playbook run
one of my personal top candidates for a 1.1.0 priority issue to resolve :)
Kevin O'Gorman
@zenmonkeykstop
was it resolvable by nuking ~/.ansible?
Erik Moeller
@eloquence
yeah, that one went away. had a few more playbook timeouts but ultimately succeeded, now happily running v2 alongside v3 :)
your docs worked perfectly
Erik Moeller
@eloquence
I did get the usual "Are you sure you want to continue connecting" SSH prompt on ssh app and ssh mon after the change to the new v3 address, not sure if that's worth documenting in that part of the docs