These are chat archives for frictionlessdata/chat

6th
Jun 2017
Paul Walsh
@pwalsh
Jun 06 2017 04:50
@rflprr great, thanks.
roll
@roll
Jun 06 2017 06:16
Based on yesterday problem I've create pip issue - pypa/pip#4532 - may be it's not a bug but it's still pretty confusing behavior. tabulator alpha was working good inside our eco-system but problem has arised with dependency of dependency as it was for datadotworld (see pip issue example). That situation is not related to --pre flag because it was ok for datapackage. Just pip version resolution logic.
Paul Walsh
@pwalsh
Jun 06 2017 06:19
@roll I would just suggest you use/rely on --pre less :).
I guess you are doing it because of semver and not wanting to hit v1 when your APIs might change, but, another approach is just to keep bumping versions. doesn't matter much v1, v2, v3 etc. if we are following semver
roll
@roll
Jun 06 2017 06:23
@pwalsh I totally agree. In Python eco-system I suppose we're too much believe in v1. For next package we develop I more prefer to bump to v1 after "we'got a first user" and then to do semver.
Ori Hoch
@OriHoch
Jun 06 2017 08:29
I agree with @pwalsh here - I prefer to just bump versions, rather then planning ahead which version I want to hit..