by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Oct 22 2018 18:48

    fwcd on master

    Added Gitter (compare)

wikoion
@wikoion
Hey, been trying to get this working with the coc.nvim extension for vim/neovim, don't suppose anyone has any experience with this do they?
In my coc-settings.json I have:
{
    "languageserver": { 
        "kotlinLanguageServer": {
            "command": "/Users/wikoion/git/KotlinLanguageServer/server/build/install/server/bin/server",
            "filetypes": ["kotlin"],
            "rootPatterns": [".kt",".kts"],
            "additionalSchemes": ["jar", "zipfile"]
        }  
    }
}
Noah Santschi-Cooney
@Strum355
@fwcd_gitlab loads of progress been made recently i see! Hows the status of the overall project atm?
F. W.
@fwcd_gitlab
It's doing fine, we've finally made some progress adding a formatter, improving the Java-to-Kotlin converter and providing support for more editors!
Noah Santschi-Cooney
@Strum355
I see you did something with an embedded compiler. Did we see improvement in the linter and autocomplete?
F. W.
@fwcd_gitlab
The autocomplete is more accurate and provides completions for keywords now, but there are still some performance issues
kotlin-compiler-embeddable is really the same thing as kotlin-compiler, just that some of the classes are located under different packages (org.jetbrains.kotlin.com.intellij.* instead of com.intellij.*)
Luiz Guilherme D'Abruzzo Pereira
@luiz290788
Hello, is anyone else getting this error Cannot inline bytecode built with JVM target 1.8 into bytecode that is being built with JVM target 1.6. Please specify proper '-jvm-target' optionkotlin(INLINE_FROM_HIGHER_PLATFORM) I'm facing it language server project on Compiler.kt
It seems that it hasn't detected the target jvm version from gradle
Luiz Guilherme D'Abruzzo Pereira
@luiz290788
I was able to fix it by settings "kotlin.compiler.jvm.target": "1.8" on my settings
Noah Santschi-Cooney
@Strum355
image.png
Hey @fwcd_gitlab im getting the following with build from master
Noah Santschi-Cooney
@Strum355
aha i think ive discovered it
the gradle project was in a subfolder of the workspace directory, one level below
this was causing it to crash
Noah Santschi-Cooney
@Strum355
@fwcd_gitlab are master tests currently failing? :thinking:
Noah Santschi-Cooney
@Strum355
server/src/main/kotlin/org/javacs/kt/signaturehelp/SignatureHelp.kt.activeParameter, this is meant to return the index of the "active param". what defines active param? when is this the case?
Noah Santschi-Cooney
@Strum355
ah found it out
Иван Сердюк
@oceanfish81_twitter
Did anyone perform testing, threw Codenvy.com and theia-ide.org ?
Иван Сердюк
@oceanfish81_twitter

I give up, eclipse is terrible

@matthewmcgarvey , and what about https://codenvy.com ?

codenvy/codenvy#1763
eclipse/che#8279

prassee
@prassee
I'm just curious to know about a simple stats. How many users are in this forum are using Kotlin LSP as the daily driver.
Иван Сердюк
@oceanfish81_twitter

I'm just curious to know about a simple stats. How many users are in this forum are using Kotlin LSP as the daily driver.

I was curious if anyone tried to code in Kotlin, for a matter of targeting Kotlin/Native

F. W.
@fwcd_gitlab
Hi everyone, I will be moving this chat to Discord, since it allows for managing multiple channels and makes it easier for me to respond quickly. Also, I think it is more convenient in general :)
Иван Сердюк
@oceanfish81_twitter

Hi everyone, I will be moving this chat to Discord, since it allows for managing multiple channels and makes it easier for me to respond quickly. Also, I think it is more convenient in general :)

Please provide a link, to that Discord room

F. W.
@fwcd_gitlab
Updated, permanent invite: https://discord.gg/cNtppzN