Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Gary Sherman
    @g-sherman
    you have to update spacemacs to get the new layers
    Nathan Woodrow
    @NathanW2
    maybe it's the syntax-checking that I'm missing
    I will try that one
    how are you finding spacemacs, I really like it
    Gary Sherman
    @g-sherman
    i like it, but been a bit of a learning curve. I used emacs a million years ago, but my fingers are permanently bound to the vim key bindings now
    Nathan Woodrow
    @NathanW2
    ahh I was missing flake8 and pylint
    now it seems to be good
    there is also a tool that I found the other day that will auto format
    might try and add that into my setup to auto format
    Gary Sherman
    @g-sherman
    what's the auto format package called?
    Nathan Woodrow
    @NathanW2
    there is no spacemacs package yet, just a Python tool
    I will find it
    Nathan Woodrow
    @NathanW2
    Nathan Woodrow
    @NathanW2
    should be able to call that in Emacs pretty easy
    Nathan Woodrow
    @NathanW2
    created a config layer a yapf function in it
    Gary Sherman
    @g-sherman
    Cool; i created a couple layers---one for snippets and the other for haml mode
    no real code writing though; just defining the name and init function
    Nathan Woodrow
    @NathanW2
    nice
    I'm going to make a qgis layer that has stuff like you pb_tool
    and templates
    Gary Sherman
    @g-sherman
    good idea
    Nathan Woodrow
    @NathanW2
    just a note too: pb_tool zip -q will fail if not run first as pb_tool zip
    gives me
    pb_tool.exe zip -q
    Found zip: C:\OSGeo4W\bin\zip.EXE
        zip warning: name not matched: qgsazimuth
    
    zip error: Nothing to do! (try: zip -r f:\dev\qgis_plugins\qgsazimuth\qgsazimuth.zip . -i qgsazimuth)
    Gary Sherman
    @g-sherman
    hmm, interesting
    Gary Sherman
    @g-sherman
    what version of pb_tool
    ?
    current is:
    pb_tool version 1.8.1, 2015-04-15
    and pb_tool zip -q seems to work
    Nathan Woodrow
    @NathanW2
    ok I have a old version
    upgrading now
    same error
    it's only if the folder isn't already in the plugins folder
    Gary Sherman
    @g-sherman
    you mean if it hasn't been deployed?
    Nathan Woodrow
    @NathanW2
    yeah
    Gary Sherman
    @g-sherman
    ok, is see; i'll take a look
    Nathan Woodrow
    @NathanW2
    cheers
    Nathan Woodrow
    @NathanW2
    if you are looking for features for pb_tool. temple support would be cool
    pb_tool template basic
    Nathan Woodrow
    @NathanW2
    pb_tool template dialog
    that would be very handy indeed
    Gary Sherman
    @g-sherman
    what do you mean by template support?
    Gary Sherman
    @g-sherman
    To create dialog code like plugin builder does?
    Gary Sherman
    @g-sherman
    pb_tool 1.9 fixes the zip -q issue
    Nathan Woodrow
    @NathanW2
    thanks
    yeah like what plugin builder does but just dump a temple project out
    swapnilchauahan
    @swapnilchauahan
    hello Guys,
    Any clue on how many classes,plugins are there in the QGIS