Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Jan 31 2019 17:58
    jorgemachucav starred galaxyproject/tools-iuc
  • Jan 31 2019 17:45
    bebatut opened #2270
  • Jan 31 2019 16:18
    cpreviti synchronize #2267
  • Jan 31 2019 14:15
    cpreviti synchronize #2267
  • Jan 31 2019 12:42
    bernt-matthias review_requested #2269
  • Jan 31 2019 12:42
    bernt-matthias edited #2269
  • Jan 31 2019 12:41
    bernt-matthias edited #2269
  • Jan 31 2019 12:40
    bernt-matthias synchronize #2269
  • Jan 31 2019 12:13
    cpreviti commented #2267
  • Jan 31 2019 12:07
    nsoranzo commented #2267
  • Jan 31 2019 12:01
    cpreviti synchronize #2267
  • Jan 31 2019 11:21
    cpreviti synchronize #2267
  • Jan 31 2019 09:47
    cpreviti synchronize #2267
  • Jan 31 2019 09:27
    cpreviti synchronize #2267
  • Jan 30 2019 20:38
    bernt-matthias commented #2131
  • Jan 30 2019 20:19
    hepcat72 commented #2239
  • Jan 30 2019 19:50
    lparsons commented #2239
  • Jan 30 2019 18:36
    bgruening commented #2268
  • Jan 30 2019 15:23
    nsoranzo commented #2268
  • Jan 30 2019 15:23
    nsoranzo commented #2267
Ghost
@ghost~5772e7e2c2f0db084a206e1b
but ubuntu comes with bash
Brad Langhorst
@bwlang
this might be relevant: http://cfajohnson.com/shell/cus-faq-2.html#Q11 - looks pretty damn nasty to me.
Ghost
@ghost~5772e7e2c2f0db084a206e1b
you mean option d ?
Brad Langhorst
@bwlang
yup
Ghost
@ghost~5772e7e2c2f0db084a206e1b
yeah, I don't know if we can generalize this ... probably not
Brad Langhorst
@bwlang
bash +busybox probably covers all relevant systems right?
Ghost
@ghost~5772e7e2c2f0db084a206e1b
In a sense pipefail is not so bad -- it's an improvement over the current situation, and if you don't have pipefail ... well that's how it is currently
lemme check biocontainers
Brad Langhorst
@bwlang
pipefail is a bit of hammer though… might expose messed up tools that “work” but have an error in the pipe somewhere.
Ghost
@ghost~5772e7e2c2f0db084a206e1b
right, I wouldn't do this for all tools by default
but it could be an option for tools that pipe stuff around
Brad Langhorst
@bwlang
shrug maybe all tools with a galaxy version number specified or > X
i think hidey broken is pretty toxic, maybe worth some poking of users.
Ghost
@ghost~5772e7e2c2f0db084a206e1b
docker run -it biocontainers/bwa:0.7.15 sh
$ set -o pipefail
sh: 1: set: Illegal option -o pipefail
args
though there is bash in this container
Brad Langhorst
@bwlang
what would it take to switch to detect bash and use it if available by default?
Nicola Soranzo
@nsoranzo
I think we are using bash already in the job script, no?
Ghost
@ghost~5772e7e2c2f0db084a206e1b
I think that's configurable IIRC
yep, with default_job_shell
Dave B.
@davebx
my memory is failing me, is passing a list collection to a param multiple="True" supported?
John Chilton
@jmchilton
yes
Dave B.
@davebx
sweet
Brad Langhorst
@bwlang
ran into a trouble with the metaphlan2 downloader… it looks like it has the deps right, but can’t find download_metaphlan2_db.py
do managers set up the conda environment like other tools?
Nicola Soranzo
@nsoranzo
Yep
Brad Langhorst
@bwlang
seems that I have 2 metaphlan2 2.6.0 entries in my dependencies view. /mnt/galaxy/data/galaxy/tool-deps/_conda/envs/__metaphlan2@2.6.0 and
/mnt/galaxy/data/galaxy/tool-deps/_conda/envs/mulled-v1-c5867e29ea0fba532ec8dc4a557d8798445dccb6ecf21f67e09143751a79b65d
is that normal?
oddlly activating __metaphlan2@2.6.0 does not put download_metaphlan2_db.py on the path...
hmm neither of these conda envs list metaphlan2 as a package with conda list. anybody seen that before?
Ghost
@ghost~5772e7e2c2f0db084a206e1b
Maybe the install
Brad Langhorst
@bwlang
strange… metaphlan2 pkg exists in pkgs, but is not in the environment. I’m going to add it manually - maybe there is some dependency issue - though nothing complained until i tried to run the tool.
aha!
Installing conda-forge::click-6.7-py_1 requires a minimum conda version of 4.3.
that should probably cause some kind of error during installation of the tool… galaxy bug i guess.
just have to manually update conda...
Björn Grüning
@bgruening
The biocontainers do come with bash by default. Its a busybox+static bash
Björn Grüning
@bgruening
The biocontainers do come with bash by default. Its a busybox+static bash
Alexander Lenail
@zfrenchee
Is there a guide for building galaxy tools from docker containers somewhere (instead of python / conda packages)?
Alexander Lenail
@zfrenchee
Where the execution of the tool is a docker run ...
Martin Cech
@martenson
Lance Parsons
@lparsons
Sorry for the cross-post, but wasn't sure which channel was best: Does anyone have any advice on tools/methods to plot genome coverage across one sequence id from a BAM file using a "custom" reference in Galaxy? I wasn't able to get Trackster to work at all (problems with datasets in collections, custom reference, etc.)
Brad Langhorst
@bwlang
i just use igv. you might want to have a look at mosdepth https://github.com/brentp/mosdepth
Lance Parsons
@lparsons
Thanks @bwlang , I'll check it out. Is there a Galaxy wrapper by chance?
Brad Langhorst
@bwlang
not sure… have not seen one.
Lance Parsons
@lparsons
ok, thanks.
Anton Nekrutenko
@nekrut
@lparsons DeepTools?
Devon Ryan
@dpryan79
@lparsons You might be able to use either hicPlotTads (from HiCExplorer) or pyGenomeTracks. They're essentially the same tool, but I know the former is definitely available in the toolshed.