Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
Marius van den Beek
@mvdbeek
huh ?
I thought it'd just sit there forever
well OK, that sort of makes sense then, but putting conda on PATH is probably still not a good idea
jhl667
@jhl667
no, the gui showed immediate failure, and the log would just spin off prepare_for_install requests every 3 sec
Marius van den Beek
@mvdbeek
yeah, jumped to conclusions there
jhl667
@jhl667
yea, I agree with you on PATH not being a great idea, what would be your suggestion?
Marius van den Beek
@mvdbeek
put galaxy's virtualenv path on the PATH
jhl667
@jhl667
I don't use a virtualenv
I use conda to manage all of that
Marius van den Beek
@mvdbeek
that is also not a good idea
jhl667
@jhl667
it works quite well for me since otherwise I need to install two virtualenv's
Marius van den Beek
@mvdbeek
right, except for the mercurial issue that would've been avoided, plus X
I mean OK, if it works it works
jhl667
@jhl667
I only tried it after reading about it in the docs, but if you suggest it's not a good idea, I can go back to double virtualenv
Marius van den Beek
@mvdbeek
I don't know, if it's just for dev it's fine
jhl667
@jhl667
I guess I'm trying to figure out some of the reasons you're wary of conda for this purpose
Marius van den Beek
@mvdbeek
but you're not getting the wheels we're testing with, and I don't think that the exact dependency versions match either (case in point mercurial wasn't installed)
jhl667
@jhl667
ahh, ok, well that's a good reason
:-)
selten
@selten
I'm curious, how does https://usegalaxy.org/ handle inode usage? Or is that no issue?
Ieva
@Le_ieva__twitter
Is Galaxy slow today or is there something wrong on my end? :/
Björn Grüning
@bgruening
usegalaxy.org or another server?
pvanheus
@pvanheus
@mvdbeek I'm trying to use the https://github.com/ARTbio/GalaxyKickStart with the standard galaxy.yml and inventory as per https://gist.github.com/pvanheus/24615ececac112937b706d87dfb5b846 - but it seems to not configure supervisor - the supervisor stuff is meant to come from galaxyprojectdotorg.galaxy-os right?
pvanheus
@pvanheus
ah no - supervisor is from galaxyprojectdotorg.galaxy-extras - seems the default galaxy.yml doesn't include that.
Marius van den Beek
@mvdbeek
Right, supervisor setup is in ansible-galaxy-extras
Vahid
@VJalili
@jmchilton raising exceptions such as RequestParameterMissingException in places other than api/controller causes 500 error. Any thoughts?
Marius van den Beek
@mvdbeek
do you have an example ?
I think MessageExceptions are caught in the ErrorMiddleware, so if they don't leave galaxy that makes sense
Marius van den Beek
@mvdbeek
Sure, that makes sense, that's what the ErrorMiddleware does
but if you call this from somewhere where it doesn't pass through the middleware it won't do that
at least that's my understanding
Vahid
@VJalili
Sounds reasonable. Any suggestion for throwing exceptions behind the middleware? (e.g., in the authnz I linked)
Marius van den Beek
@mvdbeek
huh, that depends on who needs to react to the exception I guess
Vahid
@VJalili
I used to return errors to the caller api/controller. However, I think we're moving from that practice.
its the caller of API that needs to react
Marius van den Beek
@mvdbeek
like this is still going through the HTTP API ?
Vahid
@VJalili
correct
Marius van den Beek
@mvdbeek
then it should actually be caught
Vahid
@VJalili
caught in api/controller?
I think
I'm not entirely sure on this, I just recently looked into this for the py3 porting
sorry, gotta run
Vahid
@VJalili
good hint anyway, thanks.
Slugger70
@Slugger70

Hey there! I'm running Galaxy 18.05 on a server, I have a tool that creates some javascript html output which I have whitelisted. I still get

javascript is needed to display data.
If you try to view this data on galaxy please contact your administrator to authorise javascript or download the file to view.

If I donwload the file it displays no problem.. I checked the whitelist config file and the tool that produced it is listed there. FastQC works fine.

Nicola Soranzo
@nsoranzo
Does the tool id have "strange" characters?
Slugger70
@Slugger70
It has Capital letters and an underscore. "-" is in the name