Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
MaralQ
@MaralQ
Never mind. I'm just using hg38, the latest release.
galaxybot
@galaxybot
[unknown]
Version update for Galaxy environment [usegalaxy.org support] error
It is written " * Download and Extract Reads in FASTA/Q* format from NCBI SRA (Galaxy Version 2.10.8+galaxy0) ". But only Galaxy Version (…
galaxybot
@galaxybot
[unknown]
cannot add tools in local Galaxy [Uncategorized]
I installed the local Galaxy in Ubuntu subsystem in my Windows 10 computer. I used “nano galaxy.yml” to enter galaxy yml file and added my e…
galaxybot
@galaxybot

[unknown]
Tool error with STAR aligner [usegalaxy.org support] error, rna-star
STAR aligner encountered following errors in all available versions.

"

tool error

An error occurred with this dataset:

Encountered an un…

tensionhead
@tensionhead
Hello, I am developing a galaxy tool which produces an html report to summarize the results. However when looking at this report within galaxy, all the CSS styles get ignored and hence it looks horrible. However if I download that very same html and open it via file:/// it looks as it should.
Apparently that happened before: https://biostar.galaxyproject.org/p/12025/index.html but there is no solution/answer?!
Björn Grüning
@bgruening
@tensionhead please look at this Galaxy setting https://github.com/galaxyproject/galaxy/blob/dev/lib/galaxy/config/sample/galaxy.yml.sample#L1194 and the following.
HTML can be portnatially harmful, so Galaxy disables the "harful" parts. If you trust the tool you can whitelist the HTML output from a particual tool
tensionhead
@tensionhead
ah, great thx @bgruening !
Björn Grüning
@bgruening
Your welcome!
tensionhead
@tensionhead
little follow up question, on my local testing galaxy instance I see: ./test/unit/config/config_manage/embedded/config/galaxy.yml and
./test/unit/config/config_manage/simple/config/galaxy.yml I could whitelist my tool in one of these?
Björn Grüning
@bgruening
Please look into ./config/galaxy.yml
it might be called ./config/galaxy.yml.sample. In this case copy the file so that you have a galaxy.yml file.
tensionhead
@tensionhead
Got it and it works.. phew, that makes for a good start of the week thanks again!
Björn Grüning
@bgruening
hehe :)
galaxybot
@galaxybot
[fubar] @bgruening: does this kind of "papercut" make a galaxy configuration gui worthwhile? Plenty of help text in the yml - could be a Galaxy tool :)
tensionhead
@tensionhead
Hi, I uploaded a tool to https://testtoolshed.g2.bx.psu.edu/repository?repository_id=0a3480fb2f5eb710&changeset_revision=5e07fe722e0e However in my local galaxy instance, it apparently doesn't get listed/found
Ha, actually nevermind sorry.. it just took like 30min, now it's there :)
Hugo Jiménez Hernández
@HugoJH
Hello folks. I just got slurm backend runner working with two worker nodes (tested with very simple sbatch file ) on my local galaxy. The thing is once I tried to execute a tool from galaxy interface it crashed with the following message: "This job failed for reasons that could not be determined."
Took a peek into the logs and nothing really helpful (at least for me): https://pastebin.com/DQi01C2G
Any suggestions?
Nicola Soranzo
@nsoranzo
@HugoJH You may want to ask this on https://gitter.im/galaxyproject/admins
Hugo Jiménez Hernández
@HugoJH
Thank you @nsoranzo. :D
Dave Clements
@tnabtaf
@olesya749 Just saw your post from 3 days ago. (With apologies). I don't know of anyone who does one on one training. However, there is a wealth of training material here, and there is a dedicated Gitter Channel for the Galaxy Training Network. Those are good places to start.
We also list any trainings we know about here. The next intro training is see is this one, which is free. It will be in your evening (9pm-midnight).
galaxybot
@galaxybot

[unknown]
Data Usage and Job Processing Issues [usegalaxy.org support]
I’m having an issue that I think is related to my disk usage.

I accidentally permanently deleted a huge number of files from the history I’…

galaxybot
@galaxybot
[unknown]
Abundance of OTU's [usegalaxy.org support]
Is Mothur the only metagenomic toolset that provides the number of sequences/OTU? I would love to use map with BWA-MEM/Bowtie2 and get abund…
galaxybot
@galaxybot

[unknown]
Determining the haplotype [usegalaxy.eu support] vcf
Hello everyone,

we just started sequencing bloodgroups by using ngs. We are using the MiSeq from Illumina and our reads are 150 bp long.

I…

galaxybot
@galaxybot

[unknown]
Trinity de novo assembly of RNA-Seq data [usegalaxy.org support] error
Dear Galaxy Admins,

First of all, I would like to thank a lot for this Great Galaxy server. I was used this to perform my RNA-seq analysis …

Violetatil
@Violetatil
Hi everybody! I am trying to create a galaxy workflow for a Genome Data Science course. I have mapped 3 end pair RNA seq using a reference genome, I have run Hisat2 and now Im trying to run cufflinks but, it's an hour ago I have 3 jobs queued and it doesn't work.
What 's the problem?
Nolan Woods
@innovate-invent
@Violetatil assuming you are using usegalaxy.org, the queue can be quite long
galaxybot
@galaxybot

[unknown]
How to restrict VCF variants using a gene list with the set function in SnpSift? [Uncategorized] admin, vcf
Hello,

I am trying to restrict VCF variants using a gene list (text file) with the set function in SnpSift.

After annotating with ANOVAR a…

Andrés Culasso
@DrACulasso_twitter
Hello. I've downloaded galaxy from github and followed the scarce indications to get it running, but when I run the sh run.sh command to start galaxy, the process terminate with error building the client "Install prebuilt node (12.16.3)" and looks like it tries to download something and get a 404 (not found) error. I'm SMP Debian 4.19.152-1 (2020-10-18) i686 GNU/Linux. ¿Any idea on how to solve this? thanks in advance
Nolan Woods
@innovate-invent
@DrACulasso_twitter it builds the web client when you first run it. It is trying to download node as part of that.
Did you disable your wifi while installing?
Andrés Culasso
@DrACulasso_twitter
nope... connection still up, and even some dependencies were installed by PIP without problem
could it be a 32-bit issue?
Nolan Woods
@innovate-invent
404 generally means it failed to fetch the package. I know AWS (and a good chunk of the internet) went down recently. Have you retried?
Sailee
@psy_leee_twitter
Hello, I am processing some pig fastq files and the latest built-in genome is from 2011. Could anyone please let me know the quickest way to get the 2017 genome added here. Thank you.
Nolan Woods
@innovate-invent
Add it to the custom builds under the user menu
Andrés Culasso
@DrACulasso_twitter
Thank you Nolan @innovate-invent . I'll keep trying... I've checked a couple of hours ago, deleted the profile dir, installed conda, and same error when it tries to builds the web client.
Nolan Woods
@innovate-invent
what branch did you check out?
make sure you are on the correct one
galaxybot
@galaxybot

[unknown]
Download bam files [Uncategorized]
Hello

I am not able to download any bam files from my history in https://veupathdb.globusgenomics.org/

Any advice?

Thank you

Tamara

galaxybot
@galaxybot
[unknown]
clustering of unigenes from stringtie assembly [Uncategorized]
hello, I am trying to cluster unigenes with stringtie GTF file. suggest me ant tool in galaxy.
macelik
@macelik

Hello everybody, admire your hard work.

There is a tool called; Centrifuge, I not able to find it on the tools search section, although it appears in the ToolShed. Could someone please check it?

galaxybot
@galaxybot
[unknown]
Can't open run.sh [usegalaxy.org support] admin, tutorial, error
Hello, I’m a newbie to using Galaxy so I’m trying to set up a server through WSL2 with a Ubuntu terminal and python3. As far as I can tell,…
Björn Grüning
@bgruening
@macelik we are working on it ATM
miguensblanco
@miguensblanco
Hi guys, I have purge every possible history, permanently deleted every possible dataset and remove all the files at the FTP server , my actual history is 15.79KB. What I am missing? Maybe the server takes a bit to update? Cheers
Björn Grüning
@bgruening
@miguensblanco please logout and login, this will trigger a quota update
galaxybot
@galaxybot

[unknown]
Over Quota - deleted datasets won't purge [usegalaxy.org support] quota
Hi,

I’m having an issue with reducing my disk usage. I set the Tophat tool to run on a collection of data in my history, however realised s…