Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
gmauro
@gmauro:matrix.org
[m]
@Margot51315358_twitter: send to me your account name with a PM
Margot
@Margot51315358_twitter
HI....I managed to sort out the problem...thanks
gmauro
@gmauro:matrix.org
[m]
Super!
dmayamiles
@dmayamiles
Hi all,
dmayamiles
@dmayamiles
Hi all, I am currently running a RNA-seq analysis using Limma Voom script included in UseGalaxy. I would like to introduce age and sex as co-variates in the analysis. I have created a factor file in which I have introduced the groups that I am interested in comparing in the second column, and sex (coded as a discrete variable using 0 and 1) and age (continuous variable) in the third and fourth column respectively. As age is a continuous variable I am not sure if I can introduce it like this in the script. Could anyone confirm me if I can proceed this way or if there is any alternative to perform it using Galaxy? Many thanks in advance.
scholtalbers
@scholtalbers
hi all. On our instance, 21.05, the rerun of a failed job in a collection (list of pairs) does not work properly. The job gets rerun as a new job (as a new single dataset in the history) and is not part of a collection anymore and the remaining steps of the workflow do not resume after the job successfully finishes. Is this issue known and possibly already fixed?
Marius
@mvdbeek:matrix.org
[m]
Did you have the option to specify Replace elements in collection? and Resume dependencies from this job? on the tool form ?
Just re-running a single job seems like the right thing to do
If you check both, paused jobs should continue to run
nanasipeter
@nanasipeter
Hi all, i have the same problem as others: I am running DeepTools ComputeMatrix and the job keeps waiting to run more than 3 days by now. Nothing happened. The job is not paused. Normally it takes 2 minutes to start it, but right know it looks like it stuck. Maybe the servers are down? Can anyone help please! Thanks in advance!
Marius
@mvdbeek:matrix.org
[m]
@nanasipeter: which server are you using ?
scholtalbers
@scholtalbers
@mvdbeek:matrix.org thanks for the response. So the Replace elements in collection is not present. Only the Resume dep...
Marius
@mvdbeek:matrix.org
[m]
Hmm, yeah, what tool is this ?
scholtalbers
@scholtalbers
trimmomatic
Marius
@mvdbeek:matrix.org
[m]
I think we've got a logic error in there
I think the bug is that the option isn't shown ... can you open an issue to keep track of this ?
scholtalbers
@scholtalbers
ok
Marius
@mvdbeek:matrix.org
[m]
I think that logic here https://github.com/mvdbeek/galaxy/blob/ed3e1ac0ac5d4ebce2bd0c27a1b307a72eef62b5/lib/galaxy/model/__init__.py#L1543-L1548is wrong
1 reply
we probably need to first run the second check
Nadia Holness
@ciara5544_gitlab
Hello , I am trying to search my control genes that should be upregulated in my DESEQ annotated file. However, these established genes are not showing up in my file. I have also searched their alternative names. I used the mm10 as my reference genome, which is a B6 mice, but my RNA was extracted from macrophages from a balb/c background. I aligned both mouse strains fasta files to see sequence similarity in my control genes and they have 99% identity. Could anyone help me trouble shoot where I could be losing my genes?
nanasipeter
@nanasipeter
What do you mean by server? I use usegalaxy.org and for the Job: Job Resource Parameters: Use Default Job Resource Parameters. SO it should send the ComputeMatrix for the default server.
Nate Coraor
@natefoo:matrix.org
[m]
To everyone who reported waiting for jobs to run on usegalaxy.org over the weekend, there was a problem running certain types of jobs that I've just fixed, so these jobs should run as we work through the backlog. If they don't run within the next ~2 hours, DM me or email galaxy-bugs@galaxyproject.org with your username and I can check on your jobs to see if there is anything else holding them up.
nanasipeter
@nanasipeter
Thank you very much! It seems to be working fine now! :)
elenacvet
@elenacvet
Thank you! It works now :)
Steven Shum
@shenweiyan
Docker galaxy failed with relation "galaxy_user" does not exist, does anyone know how to solve this problem? Thank you.
$ docker run -it -p 8090:80 -p 8091:21 -p 8092:22 -v /galaxy-dist/galaxy-store/:/export/ bgruening/galaxy-stable:20.05
Unable to find image 'bgruening/galaxy-stable:20.05' locally
20.05: Pulling from bgruening/galaxy-stable
5d9821c94847: Pull complete
a610eae58dfc: Pull complete
a40e0eb9f140: Pull complete
c22f3d9f90a5: Pull complete
9cd1fa643178: Pull complete
ff6a2a1c50aa: Pull complete
a6ae5ce9fc6c: Pull complete
046482794b25: Pull complete
d7589383c485: Pull complete
2fbe1a09a967: Pull complete
609dee4bd11a: Pull complete
3886f006cc87: Pull complete
a004131862a0: Pull complete
a7fd2cb23184: Pull complete
521623a34944: Pull complete
cca00ea03979: Pull complete
3396c885f0ca: Pull complete
10949b53410d: Pull complete
49d17980fa8a: Pull complete
c1175adabc93: Pull complete
df25b53b7e71: Pull complete
fd05c08ec188: Pull complete
15714e7f1059: Pull complete
418dc856821c: Pull complete
6fa262cc4b17: Pull complete
5b55c4eccd99: Pull complete
72d55fecbe00: Pull complete
4fdde884cea1: Pull complete
Digest: sha256:732c679ae81ed2beb432eab3cb5963961e956e49f17d34a6d046481882e67cae
Status: Downloaded newer image for bgruening/galaxy-stable:20.05
Enable Galaxy reports authentification
Checking /export...
Disable Galaxy Interactive Environments. Start with --privileged to enable IE's.
Starting postgres
postgresql: started
Checking if database is up and running
Traceback (most recent call last):
  File "/galaxy_venv/lib/python3.7/site-packages/sqlalchemy/engine/base.py", line 1248, in _execute_context
    cursor, statement, parameters, context
  File "/galaxy_venv/lib/python3.7/site-packages/sqlalchemy/engine/default.py", line 590, in do_execute
    cursor.execute(statement, parameters)
psycopg2.errors.UndefinedTable: relation "galaxy_user" does not exist
LINE 3: FROM galaxy_user
             ^
4 replies
hipkiss1
@hipkiss1
Hello all, I am new to galaxy and the coding world. After trying to troubleshoot CIRCOS, I found the galaxy tool. I am trying to make a multi-species circular map where I can demonstrate homology between conserved sequences. However, when I upload my FASTA files to the circos tool, I receive errors for the map generation. Could anyone give me some advice?
1 reply
Yuxin-Cui
@Yuxin-Cui
Hello, has anyone got the experience to set up a cloud-based infrastructure platform using Galaxy and cloud providers? Would you like to give any advice?
David Hong
@hong7734_gitlab
Usegalaxy.org is running so slow. I saw the same problem was happened a couple of days ago in this chatting. Do you know there is same problem again?
26 replies
sveinugu
@sveinugu
Does anyone have any info on the current and projected size of the galaxyproject CVMFS reference data servers, in the perspective of the lifetime of a new disk rack for a stratum 1 server? @natefoo? @erasche? @bgruening?
Björn Grüning
@bgruening
mh, if I count well its 16TB already?
Oo
it gets every 6 month substantially bigger -> because of new bioconductor release
2 replies
so maybe every 6 month 3TB more?
sveinugu
@sveinugu
@bgruening Thanks! Exactly what I needed. I suppose one should add a bit on top of that to allow for unplanned extensions?
Oleksandr Moskalenko
@moskalenko

In our instance, the featureCounts tool seems to rely on its built-in references to be inside the dependency (container, conda env)

   ## Export fc path for its built-in annotation
    export FC_PATH=\$(command -v featureCounts | sed 's@/bin/featureCounts$@@') &&

and the annotation directory is present in the directory e.g. database/dependencies/_conda/envs/mulled-v1-39786c1966303ef2ef27f1708fd92087f19ec27505a1cad54a74932345e20ab0/annotation/hg38_RefSeq_exon.txt . However, the tool interface tells the user that no references are available. https://usegalaxy.org has the same issue. Where should I post a bug report? I'm unsure which github repo or support forum would be appropriate.

2 replies
Björn Grüning
@bgruening
@sveinugu probably
github-ic
@github-ic

Hi - I'm running a custom Galaxy v21.01 instance with 7 job handlers. I pasted my job config file below. I noticed that if my job lands on handler0 or handler3 it is placed in the queue but if it goes to any other handler it runs. I know that another user has jobs running on handler0 and handler3. Is there a way to skip handlers that already have two jobs running and move to an empty handler automatically? Right now I kill my paused job and run it again to get on a different handler for it to run.

<job_conf>
<plugins>
<plugin id="local" type="runner" load="galaxy.jobs.runners.local:LocalJobRunner" workers="4"/>
</plugins>
<handlers assign_with="db-skip-locked" max_grab="2" />
<destinations>
<destination id="local" runner="local"/>
</destinations>
<limits>
<limit type="registered_user_concurrent_jobs">4</limit>
<limit type="anonymous_user_concurrent_jobs">1</limit>
</limits>
</job_conf>

Nate Coraor
@natefoo:matrix.org
[m]
No, the handlers aren't designed to be used as a sort of "queue" like this. Even if you are running everything on one server I would recommend installing Slurm, so that you can queue jobs that way. You get some good additional benefits as well like being able to restart Galaxy while jobs are running.
github-ic
@github-ic
Thank you. Can you share a URL with details on how we can do this and configure our job_config.xml.
Nicola Soranzo
@nsoranzo:matrix.org
[m]
Look at "Connecting Galaxy to a compute cluster" slides and tutorial at https://training.galaxyproject.org/training-material/topics/admin/
github-ic
@github-ic
Thank you.
Jessica Conway
@jessicaconway__twitter
Hi, The Galaxy Project's main platform appears to be down. Whenever I go to https://usegalaxy.org/ I get the following error message "This page isn’t working. usegalaxy.org is currently unable to handle this request. HTTP ERROR 500". Does anyone know when the site will be back up and running?
3 replies
Arthur Eschenlauer
@eschen42
Is anyone successfully running MaxQuant with Thermo RAW data on Galaxy?
I'm stuck (it crashes with "file not found" while configuring, without identifying what file is not found).
Thank you (and sorry that the only connection to Galaxy is that I'm trying to run the toolshed tool on Galaxy).
thepineapplepirate
@thepineapplepirate
Does anyone know if the tool "Compound conversion" is still available in galaxy? Or is it under a new name? I'm doing the "protein-ligand docking" tutorial of the computational chemistry training tutorials
thepineapplepirate
@thepineapplepirate
issue resolved - tool is available on european server only, at the moment
Lucille Delisle
@lldelisle
Hi there,
I feel super stupid. I know there is an alternative of the '.ga' workflow format but I forgot which one it is and how to convert '.ga' to it...
Björn Grüning
@bgruening
@lldelisle I think you are searching for https://github.com/galaxyproject/gxformat2
Lucille Delisle
@lldelisle
What is the extension of the gxformat2? It is also ga?
Björn Grüning
@bgruening
its a yaml file
Lucille Delisle
@lldelisle
Is there an example in the repo?