Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
Yusheng
@Yusheng_Tan_twitter
Hello there, I wonder how I can get permission to reuse a screenshot of Galaxy homepage in my thesis literature review section. Thanks!
Björn Grüning
@bgruening
@Yusheng_Tan_twitter afaik you do not need permissions. Use the screenshots as you like, as long as it contains your data and no data, or personal information from someone else
1 reply
mariipia10
@mariipia10
hello everyone, i'm currently trying to set up a local version of galaxy, especifically the training-materials repo. I'm running on Windows 10 with Windows Subsystem for Linux, i got it up and running but can't seem to do so when trying to access the training tutorial. I've cloned the training-materials folder but when clicking the tutorial hat icon "Click to run" is unavailable. Any clues as to what i'm missing? Thanks in advance
bgruening
@bgruening:matrix.org
[m]
@mariipia10: you are probably missing all the tools from the training. Can this be?
You need more than the Galaxy instance, you would also need to tools that are needed for your specific training.
I recommend to use a public instance for your training, which has also the needed computational resources.
mariipia10
@mariipia10
i'm not looking for the training tutorial per se, I've completed in a public instance already! I'm looking to fix some typos and references on already created tutorials
bgruening
@bgruening:matrix.org
[m]
I see for this you do not need Galaxy, you only need the training repo, clone it and run those website.
In the training-material folder, run make serve
(make you need to run make install before to install all dependencies to run the training website)
mariipia10
@mariipia10
thanks a lot for your help, i'll try it and get back to you!
mariipia10
@mariipia10
i've got quite a bit of errors after running make serve, mostly it couldnt install gems and jekyll. i'm running "sudo apt-get install gcc" as it was missing, @bgruening:matrix.org question, if i run "make install" again will it skip those dependencies that it already installed and just install the missing ones? or should i do it manually?
bgruening
@bgruening:matrix.org
[m]
make install-conda && make install
should set you up with everything
Using the conda package manager
mariipia10
@mariipia10
great, thanks again
bgruening
@bgruening:matrix.org
[m]
if its just a small spelling error you don't even need a local instance
mariipia10
@mariipia10
was aware of the second link, hadn't found the first one
I was guided to use gitpod but for some reason references werent showing (which are mostly the typos i needed to fix), it said to run "make serve-full" and I did and they still werent showing i don't know why,
thats why i wanted to do a local instance and also because i'm a bit curious and seemed fun to learn to do
Björn Grüning
@bgruening
:-)
let me know if you need anything else!
mariipia10
@mariipia10
will definetly do! still fighting with dependencies but so far google has the answers to the current errors showing up :P
bgruening
@bgruening:matrix.org
[m]
haha :)
and merged!
Thanks!
mariipia10
@mariipia10
lovely, thanks to you too!
mariipia10
@mariipia10
@bgruening:matrix.org hi Björn! i'm still having some issues. I've reinstalled everything from scratch while following the tutorial and still can't make it work when running make-serve quick
i'm missing two files, Gemfile and Gemfile.lock which i've found in the directory but they both end with ".backups"
image.png
mariipia10
@mariipia10
Here's the error that show up, bibtex is missing . Config files don't seem to be setup correctly, i've investigated on those files but I'm not sure what should i change to make it run properly
bgruening
@bgruening:matrix.org
[m]
@Yusheng_Tan_twitter: use screenshots as you like as long as only your data and personal info is on it :) than you will have no problem
1 reply
@mariipia10: please use make install-conda
For you lockfiles, please do git checkout Gemfile.lock
and git checkout Gemfile
mariipia10
@mariipia10
@bgruening:matrix.org I've found conda had an issue because it was in a folder upstream :P , i've done both git checkout and ran bundle install again but it's still troublesome. I thought it may had to do with the ruby version and/or bundler version could it be? I had ruby-3.0.0 [ x86_64 ], tried with rvm(ruby virtual machine) the version which gitpod seems to be using (ruby-2.7.3 [ x86_64 ]) but still nothing.
4 replies
image.png
Here's the shell screenshot (tried it with ruby 3.0 as the other version gave too much errors on libraries and dependencies versions)
Cynthia
@Cynthia60495080_twitter
Hello everyone, I am currently doing a survey on adaptive user interfaces in scientific workflow management systems. I really need your valuable feedback here to proceed on my research. I have got some of the ideas from galaxy and I want to propose an improved interface idea for all types of users. I would be really grateuful if you could participate in my survey and give me your valuable suggestions. Here is the survey link: https://forms.gle/mZVZ7dRmP4jsVA2S8
stela a
@stvlar
hi! does anyone know where i can find a workflow's id?
Simon Bray
@simonbray:matrix.org
[m]
Hi, if you open the workflow in the editor, you should see a URL ending in something like workflow/editor?id=7e1d3354c72e13c9
7e1d3354c72e13c9 is the workflow ID
stela a
@stvlar
@simonbray:matrix.org aa thank you!!
Simon Bray
@simonbray:matrix.org
[m]
You're welcome!
Simon Bray
@simonbray:matrix.org
[m]
There is no software in Galaxy for homology modelling right? I'm curious if anyone ever started working on wrapping something like promod3: https://openstructure.org/promod3/3.2/
elenacvet
@elenacvet
image.png
Hi, I’m a new to RNASeq data analysis using Galaxy. I have been trying for days to align single-end fastq files to the human reference genome (https://ftp.ensembl.org/pub/release-79/gtf/homo_sapiens/Homo_sapiens.GRCh38.79.gtf.gz ) using RUNSTAR but without success.

I got this message

Oct 16 16:02:30 ..... started STAR run
Oct 16 16:02:40 ..... loading genome
Oct 16 16:18:29 ..... processing annotations GTF
Fatal INPUT FILE error, no valid exon lines in the GTF file: /jetstream/scratch0/main/jobs/38309697/inputs/dataset_cdaf4a54-5b62-
Do you have an idea where I did a mistake? Thank you in advance for your help.

4 replies