Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Björn Grüning
    @bgruening
    also upstream
    sj213
    @sj213:matrix.org
    [m]
    For ..._history_id it is 51227775, 203278, 203001
    So the zeroes are not just zero because no data was collected it would seem
    Nate Coraor
    @natefoo:matrix.org
    [m]
    galaxy_main=> SELECT idx_scan,idx_tup_read,idx_tup_fetch FROM pg_stat_user_indexes WHERE indexrelname='ix_history_annotation_association_annotation';
     idx_scan | idx_tup_read | idx_tup_fetch
    ----------+--------------+---------------
            0 |            0 |             0
    (1 row)
    sj213
    @sj213:matrix.org
    [m]
    Ok, this particular index looks indeed dispensable
    Helena Rasche
    @hexylena:matrix.org
    [m]
    Whoo!
    Björn Grüning
    @bgruening
    here we go, lets get rid of it :)
    is there a way to do this for all indices in a loop @sj213:matrix.org ?
    1 reply
    maybe we can remove more?
    Curtis Ross
    @cross12tamu

    Alright...I can't find where environment variables are declared for Galaxy.

    We're trying to migrate our Apollo services and I cannot make the environment variable change for the life of me. I thought it was in /etc/supervisor/conf.d/<files> but...evidently it isn't picking up. Even after restart.

    Is there another place that environment variables can get declared? Something perhaps that I am missing? At least obvious ones.

    <we don't use ansible atm, we are currently old school/bare metal>

    Nolan Woods
    @innovate-invent
    how is galaxy executed on your server?
    Curtis Ross
    @cross12tamu
    supervisor, but, I think I answered my own question and the env vars in that file are getting picked up, they're just not getting picked up on restart. So, looking into that issue now.
    I should clarify, I didn't answer my question, but, it would appear that the env vars from that file are making their way into galaxy but they're not making it in when modified after restart for some reason. But, I think what I'm trying to figure out now is more of why they don't get picked up on restart compared to is there another place for env vars if that makes sense. Thanks @innovate-invent
    9 replies
    Nolan Woods
    @innovate-invent
    modified after restart?
    how do you mean
    Curtis Ross
    @cross12tamu

    I just meant the modifications to catch after it is restarted.

    supervisorctl restart galaxy: results in the same config as before/after the modifications to the galaxy.conf file. Hopefully that makes sense. Apologies for the confusion.

    Nolan Woods
    @innovate-invent
    do they need to be env variables and not written to the galaxy conf?
    Curtis Ross
    @cross12tamu
    They do. They're variables that the gga/webapollo tools pickup. See the thread above for what ended up working. Supervisor had to be restarted. Aftter that, and relaunching our applications, the modified variables got picked up.
    Nolan Woods
    @innovate-invent
    ah, I missed the thread. Good to see it working for you
    Martin
    @martinwolst:matrix.org
    [m]
    Hello there, does anyone have experience with using NGINX auth_request module to implement single sign on with Azure active directory? NGINX documentation states it is possible but examples are a little vague and I'm far from being an an authentication expert ;-)
    Helena Rasche
    @hexylena:matrix.org
    [m]
    Hey Martin galaxy supports AD out of the box, check config/auth_conf.xml.sample
    1 reply
    there's a section specific to AD there and some tweaks you might need
    but overall it should work and you can avoid the pain of nginx's modules for it.
    Helena Rasche
    @hexylena:matrix.org
    [m]
    for what it's worth I've found debugging that subsystem a bit difficult just due to some of the parameter names, so, I can recommend just inserting a couple print statements if you're struggling to figure out where it gets stuck in authentication. The last time I had my bind credentials wrong and it took a bit to figure out that that's what was happening.
    Martin
    @martinwolst:matrix.org
    [m]
    as far as I can see auth_conf.xml.sample is largely/entirely(?) LDAP based, I'm having to integrate with a SSO system with MFA, so using oauth2 does Galaxy support that as well?
    Helena Rasche
    @hexylena:matrix.org
    [m]
    ah that doesn't work like plain AD? Does it support OIDC?
    Martin
    @martinwolst:matrix.org
    [m]
    I'm familiar with using AD for simple authentication by joining the system to the domain using realmd/sssd/kerberos
    but this is beyond that
    Helena Rasche
    @hexylena:matrix.org
    [m]
    so there's OIDC support in galaxy via python social auth, which seems to support Azure but that's only for Oauth2 (not OIDC) https://python-social-auth.readthedocs.io/en/latest/backends/azuread.html
    but I don't know how the authentication flow would work there, I've only seen OIDC (not oauth2) support on the galaxy side
    Martin
    @martinwolst:matrix.org
    [m]
    OK, I have a meeting with my IT colleagues later this week so should hopefully understand better what they need, some other uni web apps use oauth2, so that should work
    Helena Rasche
    @hexylena:matrix.org
    [m]
    galaxyproject/galaxy#12955 I guess that's relevant to you, so, someone's got it working!
    Add OIDC integration with Azure active directory and restart the Galaxy server.
    soudns like you
    gmauro
    @gmauro:matrix.org
    [m]
    I have this warning in the 21.09 log:
    /opt/galaxy/server/lib/galaxy/jobs/handler.py:360: SAWarning: Coercing Subquery object into a select() for use in IN(); please pass a select() construct explicitly
    any ideas what is?
    1 reply
    slugger70
    @slugger70:matrix.org
    [m]
    Sorry mate, I've never seen it.
    gmauro
    @gmauro:matrix.org
    [m]
    but you didn't migrate yet, no? :)
    slugger70
    @slugger70:matrix.org
    [m]
    yeah we did last week
    gmauro
    @gmauro:matrix.org
    [m]
    ah, super!
    Helena Rasche
    @hexylena:matrix.org
    [m]
    file a bug for the devs to track down I'd sya
    slugger70
    @slugger70:matrix.org
    [m]
    does it effect anything?
    i.e. Is everything still working?
    gmauro
    @gmauro:matrix.org
    [m]
    still looking if everything is ok
    but at least gx processes are running
    slugger70
    @slugger70:matrix.org
    [m]
    cool.
    Helena Rasche
    @hexylena:matrix.org
    [m]
    SAwarnings feel pretty common
    cat-bro
    @cat-bro:matrix.org
    [m]
    I've seen that. I assumed it was a result of changing sqlalchemy version
    Marius
    @mvdbeek:matrix.org
    [m]
    It is, nothing to worry about. In some flavor or another these have always been there. This one we need to address before moving the sqlalchemy 2.0. I think we can turn these warnings off in releases
    I am surprised to see how the installation of postgresql could be that "easy". But, I am stuck in some error in the step that follows the DB setup.