Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Nolan Woods
    @innovate-invent
    do they need to be env variables and not written to the galaxy conf?
    Curtis Ross
    @cross12tamu
    They do. They're variables that the gga/webapollo tools pickup. See the thread above for what ended up working. Supervisor had to be restarted. Aftter that, and relaunching our applications, the modified variables got picked up.
    Nolan Woods
    @innovate-invent
    ah, I missed the thread. Good to see it working for you
    Martin
    @martinwolst:matrix.org
    [m]
    Hello there, does anyone have experience with using NGINX auth_request module to implement single sign on with Azure active directory? NGINX documentation states it is possible but examples are a little vague and I'm far from being an an authentication expert ;-)
    Helena Rasche
    @hexylena:matrix.org
    [m]
    Hey Martin galaxy supports AD out of the box, check config/auth_conf.xml.sample
    1 reply
    there's a section specific to AD there and some tweaks you might need
    but overall it should work and you can avoid the pain of nginx's modules for it.
    Helena Rasche
    @hexylena:matrix.org
    [m]
    for what it's worth I've found debugging that subsystem a bit difficult just due to some of the parameter names, so, I can recommend just inserting a couple print statements if you're struggling to figure out where it gets stuck in authentication. The last time I had my bind credentials wrong and it took a bit to figure out that that's what was happening.
    Martin
    @martinwolst:matrix.org
    [m]
    as far as I can see auth_conf.xml.sample is largely/entirely(?) LDAP based, I'm having to integrate with a SSO system with MFA, so using oauth2 does Galaxy support that as well?
    Helena Rasche
    @hexylena:matrix.org
    [m]
    ah that doesn't work like plain AD? Does it support OIDC?
    Martin
    @martinwolst:matrix.org
    [m]
    I'm familiar with using AD for simple authentication by joining the system to the domain using realmd/sssd/kerberos
    but this is beyond that
    Helena Rasche
    @hexylena:matrix.org
    [m]
    so there's OIDC support in galaxy via python social auth, which seems to support Azure but that's only for Oauth2 (not OIDC) https://python-social-auth.readthedocs.io/en/latest/backends/azuread.html
    but I don't know how the authentication flow would work there, I've only seen OIDC (not oauth2) support on the galaxy side
    Martin
    @martinwolst:matrix.org
    [m]
    OK, I have a meeting with my IT colleagues later this week so should hopefully understand better what they need, some other uni web apps use oauth2, so that should work
    Helena Rasche
    @hexylena:matrix.org
    [m]
    galaxyproject/galaxy#12955 I guess that's relevant to you, so, someone's got it working!
    Add OIDC integration with Azure active directory and restart the Galaxy server.
    soudns like you
    gmauro
    @gmauro:matrix.org
    [m]
    I have this warning in the 21.09 log:
    /opt/galaxy/server/lib/galaxy/jobs/handler.py:360: SAWarning: Coercing Subquery object into a select() for use in IN(); please pass a select() construct explicitly
    any ideas what is?
    1 reply
    slugger70
    @slugger70:matrix.org
    [m]
    Sorry mate, I've never seen it.
    gmauro
    @gmauro:matrix.org
    [m]
    but you didn't migrate yet, no? :)
    slugger70
    @slugger70:matrix.org
    [m]
    yeah we did last week
    gmauro
    @gmauro:matrix.org
    [m]
    ah, super!
    Helena Rasche
    @hexylena:matrix.org
    [m]
    file a bug for the devs to track down I'd sya
    slugger70
    @slugger70:matrix.org
    [m]
    does it effect anything?
    i.e. Is everything still working?
    gmauro
    @gmauro:matrix.org
    [m]
    still looking if everything is ok
    but at least gx processes are running
    slugger70
    @slugger70:matrix.org
    [m]
    cool.
    Helena Rasche
    @hexylena:matrix.org
    [m]
    SAwarnings feel pretty common
    cat-bro
    @cat-bro:matrix.org
    [m]
    I've seen that. I assumed it was a result of changing sqlalchemy version
    Marius
    @mvdbeek:matrix.org
    [m]
    It is, nothing to worry about. In some flavor or another these have always been there. This one we need to address before moving the sqlalchemy 2.0. I think we can turn these warnings off in releases
    I am surprised to see how the installation of postgresql could be that "easy". But, I am stuck in some error in the step that follows the DB setup.
    The error message is too long: the first part is:
    TASK [galaxyproject.galaxy : Install Galaxy base dependencies]

    The last part was like this: WARNING: Discarding https://wheels.galaxyproject.org/simple/futures/futures-3.1.1.tar.gz (from https://wheels.galaxyproject.org/simple/futures/). Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.\nERROR: Could not find a version that satisfies the requirement futures==3.1.1 (from versions: 0.2.python3, 0.1, 0.2, 1.0, 2.0, 2.1, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.1.6, 2.2.0, 3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.0.5, 3.1.0, 3.1.1)\nERROR: No matching distribution found for futures==3.1.1\n"}

    PLAY RECAP **
    vm : ok=53 changed=0 unreachable=0 failed=1 skipped=33 rescued=0 ignored=0

    Sang Chul Choi
    @goshng
    Sorry for the long error message. My question is not to get help about the error that I got. I would appreciate it though. I was wondering where I should ask that kind of question above.
    I have tried to reread the tutorial above to see if there is any point that I could follow.
    But, I do not know where I should ask. First, I have been working in the field of evolutionary sequence analysis. I am working with a student to setup a galaxy instance using Ansible. I will appreciate your help. I am new to galaxy admin although I was a galaxy user for a long time. Thank you.
    Marius
    @mvdbeek:matrix.org
    [m]
    Ah, that version of futures has been yanked from pypi
    Which version of Galaxy are you trying to install ?
    Nicola Soranzo
    @nsoranzo:matrix.org
    [m]
    futures has never been a requirement for Galaxy, as far as I can tell
    Marius
    @mvdbeek:matrix.org
    [m]
    I think the oldest release that required futures 3.1.1 was 20.09, which is not supported anymore
    @goshng: If you switch out galaxy_commit_id to something newer, like release_21.09 this should work
    Nicola Soranzo
    @nsoranzo:matrix.org
    [m]
    Ah, git log -p --follow -- lib/galaxy/dependencies/pinned-requirements.txt lied to me!
    Marius
    @mvdbeek:matrix.org
    [m]
    yeah, the history was interrupted when we moved to poetry
    Nicola Soranzo
    @nsoranzo:matrix.org
    [m]
    It decided to follow the wrong file
    Helena Rasche
    @hexylena:matrix.org
    [m]
    huh, I didn't know about --follow, I wish I'd known that one earlier.