Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Oct 19 14:29
    runengine commented #2718
  • Oct 19 10:43
    runengine commented #2718
  • Oct 19 10:20
    mahagr milestoned #2718
  • Oct 19 10:20
    mahagr commented #2718
  • Oct 19 10:20
    mahagr assigned #2718
  • Oct 19 10:20
    mahagr labeled #2718
  • Oct 19 10:20
    mahagr unlabeled #2718
  • Oct 19 10:19
    mahagr commented #2718
  • Oct 19 10:19
    mahagr labeled #2719
  • Oct 19 10:19
    mahagr commented #2719
  • Oct 19 10:18
    Travis gantry/gantry5 (develop) passed (3152)
  • Oct 19 10:17
    mahagr labeled #2721
  • Oct 19 10:16
    mahagr commented #2721
  • Oct 19 10:16

    mahagr on develop

    Fixed FormFIeld issues with Fab… (compare)

  • Oct 19 10:08
    mahagr labeled #2720
  • Oct 19 10:08
    mahagr labeled #2720
  • Oct 18 17:38
    EdSantos754 commented #2721
  • Oct 18 13:48
    mahagr assigned #2721
  • Oct 18 13:48
    mahagr milestoned #2721
  • Oct 18 13:48
    mahagr labeled #2721
David Wickstead
@Wicko-Design
Ok this is odd as I am able to create 3 column dropdown in another menu ok but first menu item I can create the second column but it will not save any items added to it. When I add to other dropdown it causes an error. Parent dropdown that works is a customer link #. The others are taxonomies links that give errors. I have created my own outline yaml to add a few positions under the main item area
David Wickstead
@Wicko-Design
ok renaming main-menu.yaml in custom > config > menu and letting the site create a new on has worked. Thank you
David Wickstead
@Wicko-Design
ok should I just delete again as first set on menu items moved ok but then whn I tried to move another it is not saving changes. No errors no though
Matias Griese
@mahagr
hmm
try to move the order inside wp menu
and then just add columns (keep the order) in gantry
or.. just edit the file
there's a fix for this coming, but i've been sick (a lot) and it's been a slow progress
David Wickstead
@Wicko-Design
ok added new items to WP menu for another dropdown and was able to configure first time in the Gantry Menu. But original items won't change
Opened the main-menu.yaml file and see names have removed first characture from names
My menus dropdown menus will be the same names as in other dropdowns so not sure if that is the reason as creating ID from name
David Wickstead
@Wicko-Design
It appears to just be linked with any changes to the first dropdown. If I set the others is saves fine but as soon as I touch the first if looses the settings of the 2nd dropdoan. I can reste the 2nd dropdown but not the first.
indieben
@greenlanegreb
Hello, I'm hoping somebody can help me - I'm having an absolute nightmare with Gantry seemingly caching previous YAML layouts. I have about 27 sections, however, I renamed them all from numbers, for example container-one to container-1 and reloaded the YAML but it is not pulling through the updates. I've cleared Gantry's Cache (already in development mode) and I've cleared both of Joomla's caches to no avail.
This has been a bug for some considerable time. I'll log it over there two but in the meantime, it's never a bad idea to have a second pair of eyes on the YAML but, to be honest, if it's not even pulling through the container name updates, I doubt it is my YAML syntax - i've also cleared my browser cache too.
to*
I'm forced into the position of having so many sections because I can't otherwise have overhanging titles that are not subject to sidebar and asides.
indieben
@greenlanegreb
any any hackery would lead to less than responsive code that would defeat the object - I figured i'd add my justification in as it may be said that I have too many sections. It would be halved if I did not have this issue.
indieben
@greenlanegreb
Please see Github issue #2685
erw1988
@erw1988
I tried installing UIKit 3 for Gantry 5 on Wordpress. Went through the process of creating a new particle folder, adding the particle files in there and copying the uikit folder in the root custom folder. Added the Atom to the Base Outline. None of the uikit tags are working; for example, when I add the tag for uk-sticky to the navigation section settings, it doesn't render on the front-end. Has this been an issue before or am I just missing something in the documentation?
dmleeman
@dmleeman
@erw1988 from where did you obtain the UIKIT3 Atom? If it was Joomlead then you will need to replace the 'uk-' with 'jl-'
I use the Joomlead Atom available here as part of their free particles package. https://joomlead.com/gantry-5-particles/
This method definitely works :)
dmleeman
@dmleeman
With a mix of their commercial particles and using the UIKIT3 docs here https://getuikit.com/docs/introduction to create tags for various sections and particles you have a lot of very useful tools to play with. Just remember that any tags in the UIKIT3 docs will require the 'uk-' prefix to be replaced with 'jl-' prefix as Joomlead have changed the prefix so as not to interfere with other UIKIT Atoms.
erw1988
@erw1988
I got mine from inspiretheme.com
I'll check out JL's atom, though
erw1988
@erw1988
@dmleeman Yeah, I'm not sure what's going on. When I Inspect the code, it'll have "jl-sticky" (for example) in the inline HTML but the nav bar doesn't stick.
So, for some reason or another it's not translating into the front end.
erw1988
@erw1988
I figured out the issue. Permissions to the js and css files were set wrong. Don't know htf that happened, but fixed it.
Definitely enjoying JL's particles though!
Thanks for the recommendation.
Matias Griese
@mahagr
@Wicko-Design i've not been able to look into that yet, but it sounds a lot of the issues i've been fixing
for gantry 5.5
@greenlanegreb i also replied to the issue
indieben
@greenlanegreb
@mahagr thank you for this - shall read now.
dmleeman
@dmleeman
@erw1988 I did not know that IT had a UIKIT3 Atom now, so assumed it was JL and that the problem was therefore the prefix, but good to hear that you solved it.
James
@muffindcc
@mahagr do you know if there’s anyway to access block attributes inside a particle? or are they isolated from one another?
David Wickstead
@Wicko-Design
is there an ETA on Gantry 5.5?
David Wickstead
@Wicko-Design
Perhaps might be wort using a Beta as the site is in build stage
@mahagr you can use Overrides to edit particles
Labaris
@Labaris
Hi! Is there a way to block offcanvas menu to show ONLY when the toggle is clicked? I'm having problems with overflow-x in tables: when you slide to see the rest of the table the offcanvas menu shows up. Thanks!
David Wickstead
@Wicko-Design
@Labaris I think you need to fix your site content so nothing is forcing outside the main container and that should fix the issue. You need to find out what is causing objects off the main page.
dmleeman
@dmleeman
@Labaris Hi, have you disabled the swipe gesture function? In the Base Outline > Layout, scroll down to Offcanvas Section then click the Options cog in the section (not the particle) and de-select Swipe gesture.
David Wickstead
@Wicko-Design
Noticed something very confusing today on my own website https://wickodesign.com
The header logo which is an SVG is white out of white when on blog pages it is black out of white. Checked the template settings and all template layouts inherite the header menu and logos etc from the base layout.
Was trying to figute out why some blog articles wree showing modules only assigned to the home page.
David Wickstead
@Wicko-Design
Looks like I am getting svg fill css added.
This is a Gantry 5 Helium template running on Joomla 3.9.20
Slyfox696
@Slyfox696_twitter
I have a question about accessibility. When using a desktop browser, but zoomed in at 300%, the hamburger menu representing the navigation menu appears. However, that menu cannot be accessed using the Tab button on the keyboard, which makes it inaccessible. This behavior can been on Gantry's demo site. Is there anything I can do to make the menu accessible via keyboard when zoomed in all the way?
'Apologies. The above should read: This behavior can "be seen" on Gantry's demo site.
dmleeman
@dmleeman

@Wicko-Design Hi David

I took a look at your site in inspector and the fill type is selected quite a few times so I cannot see which takes precedence.

@media only screen and (min-width: 48rem)
.g-home-particles.g-helium-style #g-navigation .g-logo.g-logo-helium svg {
    /* fill: #fff; */
}

@media only all and (min-width: 48rem)
.g-home-particles.g-helium-style #g-navigation .g-logo.g-logo-helium svg {
    /* fill: #fff; */
}
#g-navigation .g-logo.g-logo-helium svg {
    fill: #333;
}
#g-navigation .g-logo.g-logo-helium svg {
    fill: #333;
}
.g-logo.g-logo-helium svg {
    fill: #fff;
}
.g-logo.g-logo-helium img, .g-logo.g-logo-helium svg {
    max-height: 50px;
}
.g-logo.g-logo-helium svg {
    fill: #fff;
}
.g-logo.g-logo-helium img, .g-logo.g-logo-helium svg {
    max-height: 50px;
So, these two lines are at odds
#g-navigation .g-logo.g-logo-helium svg {
    fill: #333;
}
.g-logo.g-logo-helium svg {
    fill: #fff;
}
Why not try removing the extraneous entries and replacing with this in your custom.css
#g-navigation .g-logo.g-logo-helium svg  {
fill: #333;
max-height: 50px;
}