These are chat archives for gdg-x/hub

10th
May 2015
Friedger Müffke
@friedger
May 10 2015 06:55
would it help if I do a mongoexport from the current system?
Michael Prentice
@Splaktar
May 10 2015 13:43
sure, if i could import that into my local mongo for dev that would be great
Friedger Müffke
@friedger
May 10 2015 14:14
I am trying to login, but the ssh key is wrongo
hm
HELP
Michael Prentice
@Splaktar
May 10 2015 14:16
doh
Friedger Müffke
@friedger
May 10 2015 14:16
I have access, but need configuration
I feel so beginner like
ah found the settings panel
Friedger Müffke
@friedger
May 10 2015 14:33
I am connected but I don’t know which db which collection...
Michael Prentice
@Splaktar
May 10 2015 14:36
yeah, this project is critical, but so much is undocumented or unknown :(
Friedger Müffke
@friedger
May 10 2015 14:37
Michael Prentice
@Splaktar
May 10 2015 15:22
awesome! thank you
those are some short documents :) I will try out the local data instructions
Friedger Müffke
@friedger
May 10 2015 15:33
what would be UI to use and read the data
from mongo
@mauimauer told me something
Michael Prentice
@Splaktar
May 10 2015 15:38
but it doesn’t support the latest version of MongoDB which I have
I’m using MongoDB shell version: 3.0.2 but it apparently only supports up to 2.4.0 shell. maybe it still works tho? giving it a try now
Michael Prentice
@Splaktar
May 10 2015 15:58
ugh app is unsigned, so it won’t run on my computer. Guess I will have to disable that security setting
Michael Prentice
@Splaktar
May 10 2015 18:35
hrm can’t seem to figure out how to get Robomongo to connect to my local mongoDB. not sure if there is a default admin password or if I have to set all that up via the shell
Michael Prentice
@Splaktar
May 10 2015 19:20
Great. I created an admin user in Mongo, but it won’t accept the password that i just defined.
Michael Prentice
@Splaktar
May 10 2015 19:43
OK, even with Authorization off, RoboMongo won’t work with Mongo 3. So I’m done messing with that tool.
Friedger Müffke
@friedger
May 10 2015 19:43
:-/
Michael Prentice
@Splaktar
May 10 2015 19:49
oh cool, hub is pulling in chapter info finally (locally)
Friedger Müffke
@friedger
May 10 2015 19:51
how come
?
Michael Prentice
@Splaktar
May 10 2015 19:52
not sure
Friedger Müffke
@friedger
May 10 2015 19:52
I like that
Michael Prentice
@Splaktar
May 10 2015 19:53
I can’t find any fetchChapters API like mentioned in the doc
Friedger Müffke
@friedger
May 10 2015 19:53
it is in the task
Michael Prentice
@Splaktar
May 10 2015 19:58
OK, so I need to do a POST to /admin/tasks/fetchChapters ?
Friedger Müffke
@friedger
May 10 2015 19:59
it is a cron job
can you do risky.sendTask("fetch_chapters");
Friedger Müffke
@friedger
May 10 2015 20:07
I think you know more than I do
Michael Prentice
@Splaktar
May 10 2015 20:07
i know angular and some node, but not familiar with how this project is setup or mongo
Michael Prentice
@Splaktar
May 10 2015 20:15
ok, i see the cron tasks and the risky.js. How do I get into a mode on the server so that I can run something like risky.sendTask("fetch_chapters”); ?
Friedger Müffke
@friedger
May 10 2015 20:16
I think the post to admin/tasks is the right way
but you have to use the api/v1/admin/tasks url
Michael Prentice
@Splaktar
May 10 2015 20:17
Friedger Müffke
@friedger
May 10 2015 20:18
the body should be something like {task_type=“fetch_chapters”, params={}} ?
Michael Prentice
@Splaktar
May 10 2015 20:18
ok yeah i just saw something like that in the controller
looks pretty close, now how do I send the auth token so that I will be authorized?
Friedger Müffke
@friedger
May 10 2015 20:20
for testing, could you remove the middleware.auth in admin.js?
I mena remove the role
just middleware.auth()
Michael Prentice
@Splaktar
May 10 2015 20:23
possibly, starting it up in the debugger atm
Michael Prentice
@Splaktar
May 10 2015 20:34
removing the role still seems to be trying to authenticate. looks like there is a noauth option.
Friedger Müffke
@friedger
May 10 2015 20:36
maybe just remove it
Michael Prentice
@Splaktar
May 10 2015 20:40
ok, noauth works, now it’s doing the ‘not executing task’ bit due to an error
Michael Prentice
@Splaktar
May 10 2015 21:04
can’t seem to get debugging to work with Grunt. it just hangs on starting concurrent:server forever
Michael Prentice
@Splaktar
May 10 2015 21:19
looks like most of it is going through, but the taskHandler isn’t registered for fetch_chapters via the tasks/index.js
Michael Prentice
@Splaktar
May 10 2015 21:53
ok, taskHandlers are registered, but the lookup is returning undefined
aha!
it has to be sent as:

`Content-Type: application/x-www-form-urlencoded

task_type=fetch_chapters`

Michael Prentice
@Splaktar
May 10 2015 22:11
OK, got a lot of stuff loaded. some API failures, but at least it’s a good start
I’ll take another look next weekend and try to document some of this before then
thanks for your help!