Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Jody Garnett
    @jodygarnett
    and it is done, merged, ... does it need a backport?
    Jody Garnett
    @jodygarnett
    backported PR for 2.16.x, but cannot backport to 2.15.x because of macos "core.precomposeunicode" differences :(
    Jody Garnett
    @jodygarnett
    Made a PR to fix macos trouble with 2.15.x branch geoserver/geoserver#3970
    but it will get stuck on travis build change, so I am going to need someone else to backport your fix @bradh
    Jody Garnett
    @jodygarnett
    https://www.geowebcache.org cert is exipired
    Jody Garnett
    @jodygarnett
    @aaime you asked why I did not cherry pick backports
    This is the reason geoserver/geoserver#3970
    Can I ask you to rebase that branch against 2.15.x and then I should be able to cherry pick back ports
    (although I see plenty of PRs doing backports, perhaps that is more for functional changes rather than build fixes)
    Jody Garnett
    @jodygarnett
    Can I get a review of geoserver/geoserver#3970 anyone?
    Brad Hards
    @bradh
    I don't see any problem, but I'm not sure I understand the problem that well, so you might want a second opinion.
    Jody Garnett
    @jodygarnett
    it is indeed just names
    trouble is files accidentally committed with the path encoded one way cause problems.
    I removed the files (using the bad pathnames), and then readded them (using the good pathnames)
    Brad Hards
    @bradh
    I demurred on a real Approve, but I'll merge it if its blocking you.
    Jody Garnett
    @jodygarnett
    And because the characters look the same when printed the the console, it is very frustrating "conflict"
    Thanks, I can merge - just wanted to explain that your understanding of the "change" is correct.
    Thank your. @bradh (and for fixing travis the other day)
    Brad Hards
    @bradh
    np. Wish I had some capacity to do more.
    Jody Garnett
    @jodygarnett
    so do we all :)
    Jody Garnett
    @jodygarnett
    The web-app packaging is not “addressed” yet, as per email I think I know what to do
    Andrea Aime
    @aaime
    "In the specific case of this implementation (SimpleFeature and SimpleFeatureType) the whole point is the content has the same column order so that getting a value by int, is just as good as explicit looking up value by a string."
    orttak
    @orttak
    Hi,Is there anyway bunch of raster data (ndvi data produced from Landsat-8 and data EPSG:4326) pust to geoserver with geoserver-restconfig library without .zip? I looked many examples and all sample using .zip file. When I check the catalog.py file 'create_imagemosaic' function has ability to push data but its not work.
    shawn
    @sreuland
    Hello, sorry, new here, wondering if anyone may have seen a similar error, we have GeoServer 2.14.1 with querylayer extension installed, am then trying to run a CQL using the new keywords like 'collectGeometries(queryCollection('xx:yy' , 'geom' , 'INCLUDE'))' but always getting an error back from GeoServer and a server stack trace with java.lang.IllegalArgumentException: requirement failed: Type name is required in the query at scala.Predef$.require(Predef.scala:219) at org.locationtech.geomesa.index.geotools.GeoMesaDataStore.getFeatureReader(GeoMesaDataStore.scala:225) at org.locationtech.geomesa.index.geotools.GeoMesaDataStore.getFeatureReader(GeoMesaDataStore.scala:45) at org.locationtech.geomesa.index.geotools.GeoMesaFeatureCollection.reader(GeoMesaFeatureSource.scala:153)
    shawn
    @sreuland
    it appears like when the 'filter' attribute of the CQL 'queryCollection' phrase is parsed into a Query object, it's not populating the 'typeName' parameter on the Query object per https://github.com/locationtech/geomesa/blob/master/geomesa-index-api/src/main/scala/org/locationtech/geomesa/index/geotools/GeoMesaDataStore.scala, it looks like that Query::typeName only gets populated during parsing, I can't specify anything further on the filter text string, I'm not sure what is missing that triggers the Query:typeName to get realized.
    Andrea Aime
    @aaime
    @sreuland most of the datastores work fine without the typename, since Query is used against a FeatureSource, that only serves a single feature type anyways (in other words, the information is redundant)
    Jody Garnett
    @jodygarnett
    So this is something to report to the GeoMesa Data Source implementors ...
    shawn
    @sreuland
    @jodygarnett , is that the 'geomesa' room - https://gitter.im/locationtech/geomesa ? Tnanks, I'll try it.
    Toni
    @t-book

    Hi, I've deployed a geoserver 2.16.2 instance in a tomcat docker container. Further added both geofence plugins (geoserver-2.16.2-geofence-plugin.zip, geoserver-2.16.2-geofence-server-plugin.zip) to WEB-INF/lib.

    Unfortunately, when testing the geofence connection in Geoserver GUI I'm getting a red java.lang.NullPointerException and logs show https://hastebin.com/silopogotu.log

    I might oversee something really obvious with configuration, but from what I read, without an override file, geofence should by default use it's default configuration with h2?

    Bildschirmfoto 2020-02-15 um 19.30.49.png
    mjabari
    @mjabari
    I want to write an extension to accept some rest requests. documents for creating rest and new extention is too old and useless. please help
    Jody Garnett
    @jodygarnett
    We use spring mvc for rest now
    Toni
    @t-book
    From my request above NullPointerException. Just for the record. This was caused as I've added both the geofence server and plugin. deleting the later the test connection works. However I'm curious in what situation to use the plugin? Is it used when geofence is running standalone and not embedded?
    Jody Garnett
    @jodygarnett
    I have not used it myself, consider asking on the user email list.
    Jody Garnett
    @jodygarnett

    I am looking at an error prone failure when I build today:

    geotools/modules/ogc/net.opengis.wmts/src/net/opengis/wmts/v_1/impl/BinaryPayloadTypeImpl.java
    Error:(194, 113) java: [ArrayEquals] Reference equality used to compare arrays
    (see https://errorprone.info/bugpattern/ArrayEquals)
    Did you mean 'return BINARY_CONTENT_EDEFAULT == null ? binaryContent != null : !Arrays.equals(BINARY_CONTENT_EDEFAULT, binaryContent);'?

    Is anyone else seeing this trouble, or have I fallen into a different version of error prone (via InteliJ)
    Jody Garnett
    @jodygarnett
    I figured out how to turn of the errorprone profile in IntelliJ, but it is finding real errors
    Andrea Aime
    @aaime
    @jodygarnett we are running the default config for error prone I believe, there is a lot of checks that are not on in the default setup
    if you want to start enabling one and fixing all the failures, commit, and move on, it would be appreciated
    that's how I did the QA work last time
    (well with PMD and spotbugs at least, errorprone was "default fixes" right from the start)
    if you don't have resources to go after it, there is little point discussing it....
    Jody Garnett
    @jodygarnett
    Thanks, it tripped me up yesterday
    Tom Colley
    @tomjcolley
    Hi all, I am wondering if there's a way to change the Geoserver admin password without going through the UI? I'm deploying as part of Geonode in Kubernetes and need to set the pw on deployment. I see that I could put it in plain text in the users.xml but I'm hoping there's a better way? Thanks very much
    Andrea Aime
    @aaime
    I think the GeoNode team figured out how to do it (probably using the rest api, but they also disabled the ROOT user I think)
    maybe best to ask on the geonode lists
    Tom Colley
    @tomjcolley
    Ah great, thanks Andrea, will do
    mjabari
    @mjabari
    how can i authenticate using rest?
    James Hughes
    @jnh5y
    @mjabari I would recommend reading https://docs.geoserver.org/latest/en/user/security/index.html#security in its entirety.
    That documentation is excellent