Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • 12:07
    dependabot-preview[bot] synchronize #290
  • 12:07

    dependabot-preview[bot] on maven

    Bump javaparser-core from 2.5.1… (compare)

  • 12:07
    dependabot-preview[bot] edited #290
  • 12:07
    dependabot-preview[bot] synchronize #289
  • 12:07

    dependabot-preview[bot] on maven

    Bump guava from 24.0-jre to 28.… (compare)

  • 12:07
    dependabot-preview[bot] synchronize #285
  • 12:07
    dependabot-preview[bot] synchronize #286
  • 12:07

    dependabot-preview[bot] on maven

    Bump maven-gpg-plugin from 1.5 … (compare)

  • 12:07
    dependabot-preview[bot] edited #289
  • 12:07

    dependabot-preview[bot] on maven

    Bump checkstyle from 8.18 to 8.… (compare)

  • 12:07
    dependabot-preview[bot] synchronize #284
  • 12:07

    dependabot-preview[bot] on maven

    Bump protobuf-java from 3.7.0 t… (compare)

  • 12:07
    dependabot-preview[bot] synchronize #272
  • 12:07

    dependabot-preview[bot] on maven

    Bump nexus-staging-maven-plugin… (compare)

  • 12:07
    dependabot-preview[bot] edited #285
  • 12:07
    dependabot-preview[bot] edited #286
  • 12:07
    dependabot-preview[bot] synchronize #283
  • 12:07
    dependabot-preview[bot] edited #284
  • 12:07

    dependabot-preview[bot] on maven

    Bump assertj-core from 3.11.1 t… (compare)

  • 12:07
    dependabot-preview[bot] edited #272
Apoorva-GA
@Apoorva-GA
Sure. Will give it a try.
tristanjclarke
@tristanjclarke
Thank you
tristanjclarke
@tristanjclarke
@Apoorva-GA any luck with this?
Avinash
@PODHUPU
@Apoorva-GA Can not debug or run tests on vs 2017 community
Ankon Chakraborty
@luciferankon
:point_up: August 16, 2019 8:05 PM @tristanjclarke Hey was able to replicate your issue. It happens only on the headless mode. You can create an issue here and track it. Thank you.
Ankon Chakraborty
@luciferankon
@tristanjclarke we will track it with the getgauge/taiko#734
gnk1gsr
@gnk1gsr
Hi all. Can we have csv file in the place of inline table for specification or scenerio? . I understand csv file is supported when we are passing a table to single step and the step takes it as gauge defined datastructure Table. But i do not see if it is possible for inline tables. Can some body help me.
gnk1gsr
@gnk1gsr
hmmm... nevermind. looks like its not supported. i see the below statement in experiemental features column. "CSV files can not be used as table for scenario." Hmmm... But this could be a good feature.
Ankon Chakraborty
@luciferankon
:point_up: August 19, 2019 2:24 PM @gnk1gsr Hey it's not possible currently. This is an experimental feature you can check the constraints here. Thanks for the suggestion.
vasanthdama
@vasanthdama
@all is there any way to integrate gauge html report to #slack
djfbryant
@djfbryant
Good evening, I've followed the quick installation and I keep getting "cannot find module gauge.js" when I run specs
I have run 'gauge install js'
Ankon Chakraborty
@luciferankon
:point_up: August 20, 2019 3:30 AM @djfbryant Could you please run gauge -v and come back with the output. Another thing also what is the full error you are getting there?
Andreas Jöcker
@ajoecker
hi all... I am looking for a Gauge python example without selenium - can someone link something ?
Ankon Chakraborty
@luciferankon
:point_up: August 20, 2019 11:39 AM @ajoecker I think I didn't get you. Let me phrase it. You want a sample gauge python project example right? If yes You can try to do gauge init python that will create a sample gauge python project. Thanks. Correct me if I got you wrong.
:point_up: August 19, 2019 11:44 PM @vasanthdama Hey we don't have a slack integration currently. But you can create one. You can base it out of here
Andreas Jöcker
@ajoecker
ah damn-- you are right. stupid me - or holidays were too long ;-)
thanks
Zabil Cheriya Maliackal
@zabil
@ajoecker are you migrating to python? 😮
jonathangiber
@jonathangiber
Hey guys,
not totally related but maybe someone has experienced this already

I'm getting org.openqa.selenium.TimeoutException: timeout seems when I try to setSize the chromedriver

The problem is I can't reproduce it but happens usually

sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
java.lang.reflect.Constructor.newInstance(Constructor.java:423)
org.openqa.selenium.remote.http.W3CHttpResponseCodec.createException(W3CHttpResponseCodec.java:187)
org.openqa.selenium.remote.http.W3CHttpResponseCodec.decode(W3CHttpResponseCodec.java:122)
org.openqa.selenium.remote.http.W3CHttpResponseCodec.decode(W3CHttpResponseCodec.java:49)
org.openqa.selenium.remote.HttpCommandExecutor.execute(HttpCommandExecutor.java:158)
org.openqa.selenium.remote.service.DriverCommandExecutor.execute(DriverCommandExecutor.java:83)
org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:552)
org.openqa.selenium.remote.RemoteWebDriver$RemoteWebDriverOptions$RemoteWindow.setSize(RemoteWebDriver.java:802)
com.luminate.automation.tests.is.driver.WebDriverHolder.<init>(WebDriverHolder.java:18)
com.luminate.automation.tests.steps.BaseStep.createWebDriverHolder(BaseStep.java:186)
com.luminate.automation.tests.steps.ManagementPortalNavigationSteps.<init>(ManagementPortalNavigationSteps.java:34)
sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
java.lang.reflect.Constructor.newInstance(Constructor.java:423)
java.lang.Class.newInstance(Class.java:442)
com.thoughtworks.gauge.DefaultClassInitializer.initialize(DefaultClassInitializer.java:22)
com.thoughtworks.gauge.ClassInstanceManager.get(ClassInstanceManager.java:39)
com.thoughtworks.gauge.execution.MethodExecutor.execute(MethodExecutor.java:37)
com.thoughtworks.gauge.execution.StepExecutionStage.executeStepMethod(StepExecutionStage.java:76)
com.thoughtworks.gauge.execution.StepExecutionStage.executeStep(StepExecutionStage.java:69)
com.thoughtworks.gauge.execution.StepExecutionStage.execute(StepExecutionStage.java:51)
com.thoughtworks.gauge.execution.AbstractExecutionStage.executeNext(AbstractExecutionStage.java:24)
com.thoughtworks.gauge.execution.HookExecutionStage.execute(HookExecutionStage.java:43)
com.thoughtworks.gauge.execution.ExecutionPipeline.start(ExecutionPipeline.java:29)
com.thoughtworks.gauge.processor.ExecuteStepProcessor.process(ExecuteStepProcessor.java:48)
com.thoughtworks.gauge.connection.MessageDispatcher.dispatchMessages(MessageDispatcher.java:92)
com.thoughtworks.gauge.GaugeRuntime.dispatchMessages(GaugeRuntime.java:98)
com.thoughtworks.gauge.GaugeRuntime.lambda$connectSynchronously$1(GaugeRuntime.java:81)
java.lang.Thread.run(Thread.java:748)
djfbryant
@djfbryant
image.png
@luciferankon Hey, I ran the verbose command and got the following output. I've also included the full error message;
I'm literally just running the example specs
Ankon Chakraborty
@luciferankon
@djfbryant can you please check if the file mentioned there exists or not? or else you can try to uninstall the js plugin using gauge uninstall js and install it again using gauge install js. This kind of problem arise when you install plugin on a different node version and try to use it on different node version. Try checking that also
Zabil Cheriya Maliackal
@zabil
@djfbryant this might be related to the version of node js you are using. Please make sure it is the latest stable version which is 10.16.0
vasanthdama
@vasanthdama
@NivedhaSenthil currently I am doing slack integration using API for that I need to parse the JSON-Report, problem is where I need to put the integration code
if I put integration code in afterSuite, report is not generated and it's taking old report for parsing
could help me on that
vasanthdama
@vasanthdama
@NivedhaSenthil / @Apoorva-GA / @luciferankon I want to call method after generating json-report (I tried afterSuite method but report not generated)
Zabil Cheriya Maliackal
@zabil
The report is generated after the test run and after suite. Please call the slack api in a script outside gauge after the execution.
vasanthdama
@vasanthdama
@Apoorva-GA JSON report was not generated and it's showing below exceptions
2019/08/21 08:10:18 Failed to read proto message: unexpected EOF
2019/08/21 08:10:18 Failed to read proto message: unexpected EOF
2019/08/21 08:10:18 Failed to read proto message: unexpected EOF
2019/08/21 08:10:18 Failed to read proto message: unexpected EOF
2019/08/21 08:10:18 Failed to read proto message: unexpected EOF
2019/08/21 08:10:18 Failed to read proto message: unexpected EOF
2019/08/21 08:10:18 Failed to read proto message: unexpected EOF
2019/08/21 08:10:18 Failed to read proto message: unexpected EOF
Plugin [JSON Report] with pid [9085] did not exit after 4.00 seconds. Forcefully killing it.
2019/08/21 08:10:18 Failed to read proto message: unexpected EOF

Gauge version: 1.0.6
Commit Hash: 2bc49db

Plugins

html-report (4.0.8)
js (2.3.5)
json-report (0.3.0)
screenshot (0.0.1)

Ankon Chakraborty
@luciferankon
:point_up: August 21, 2019 8:43 PM @vasanthdama This is a known issue to us. You can check that here. This happens for large suite of tests when the parsing fails. We will be working on a fix soon.
vasanthdama
@vasanthdama
@luciferankon I downgraded the gauge version from 1.0.6 to 1.0.5 and observed it's started working
Osanda Deshan Nimalarathna
@osandadeshan
Hi All,
Will Gauge stops support for Java 8, 9 and 10?
If so what will be the java version you guys would support?
tristanjclarke
@tristanjclarke
Hi all, I want to connect pupeteer into taiko headless browser. Is this possible?
Is there a websocket endpoint that the taiko headless runs on?
Ankon Chakraborty
@luciferankon
:point_up: August 22, 2019 4:35 PM @osandadeshan We do support java 8,9 and 10.
:point_up: August 22, 2019 4:59 PM @tristanjclarke Why do you wanna do that actually? Could you please elaborate?
tristanjclarke
@tristanjclarke
I want to use there select function for drop downs in my application.
Osanda Deshan Nimalarathna
@osandadeshan
@luciferankon I saw in gauge-java 0.7.1 release it mentioned that the support for java 8,9 and 10 is deprecated
Ankon Chakraborty
@luciferankon
:point_up: August 22, 2019 5:25 PM @osandadeshan Sorry my bad yeah we're dropping support for java 8,9, 10. You should migrate it to java 11 or java 12
tristanjclarke
@tristanjclarke
@luciferankon what do you think?
tristanjclarke
@tristanjclarke
??
tristanjclarke
@tristanjclarke
When I'm running any specs I get an error please help
ErrorEvent {
  target:
   WebSocket {
     _events:
      [Object: null prototype] { open: [Function], error: [Function] },
     _eventsCount: 2,
     _maxListeners: undefined,
     readyState: 3,
     protocol: '',
     _binaryType: 'nodebuffer',
     _closeFrameReceived: false,
     _closeFrameSent: false,
     _closeMessage: '',
     _closeTimer: null,
     _closeCode: 1006,
     _extensions: {},
     _receiver: null,
     _sender: null,
     _socket: null,
     _isServer: false,
     _redirects: 0,
     url: 'ws://127.0.0.1:44631/f1002aaf-478c-40dc-8241-efe8a0904516',
     _req: null },
  type: 'error',
  message: 'connect ECONNREFUSED 127.0.0.1:44631',
  error:
   { Error: connect ECONNREFUSED 127.0.0.1:44631
       at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1106:14)
     errno: 'ECONNREFUSED',
     code: 'ECONNREFUSED',
     syscall: 'connect',
     address: '127.0.0.1',
     port: 44631 } }
Error ----------------------------------
tristanjclarke
@tristanjclarke
Please help resolve this issue, is stopping me from testing... every time I kill the process I get this error.