These are chat archives for getredash/redash

20th
Oct 2015
eschultze
@eschultze
Oct 20 2015 01:33
hi again, after the update my redash hompage, and all the dashboards and queries are not appearing (just a blank page), although the /admin is working ok
I also compared the two settings.py (before and after the update) and it seems everything ok, no change of parameters or so
Arik Fraimovich
@arikfr
Oct 20 2015 03:10
@eschultze do you see any errors in the browser console? What version were you using before the upgrade?
eschultze
@eschultze
Oct 20 2015 11:55
@arikfr it seems to be an issue with my mac (even tested with chrome and firefox). As I got to work, my redash is running fine (testing on a windows machine with chrome)
Arik Fraimovich
@arikfr
Oct 20 2015 11:55
@eschultze might be some kind of browser cache issue.
eschultze
@eschultze
Oct 20 2015 12:13
it's odd, I cleared Firefox cache before testing it and I almost never use Firefox
thanks for your support
glad it's working ;)
Arik Fraimovich
@arikfr
Oct 20 2015 12:27
:+1:
anthony
@Sigma-anthony
Oct 20 2015 14:49
so I have mesos-dns running, and I am using the mesos-dns names for the .env. Also have nginx redis and postgres setup, used the docker init as an entrypoint had to add the redash repo and cd to it to get the dependencies so that manage.py doesn't fail when it tries to import redash. Tried to launch redash on marathon but it hangs saying it can't find file. Nothing jumps our of the Marathon and mesos logs and running the docker container doesn't point to any errors either. Any ideas how I can narrow down what could be the problem? or test redash in some way to make sure that my configs are correct?
Arik Fraimovich
@arikfr
Oct 20 2015 14:57
@Sigma-anthony what file it says that is missing? how do you pass config to it?
anthony
@Sigma-anthony
Oct 20 2015 15:08
@arikfr I am not quite sure what I am missing at this point, I set the .env file to point to redis and postgres using mesos-dns names which I tested with dig
Arik Fraimovich
@arikfr
Oct 20 2015 15:15
@Sigma-anthony you mentioned that , "but it hangs saying it can't find file". what hangs? and what file?
anthony
@Sigma-anthony
Oct 20 2015 15:39
@arikfr apologies, when I try to launch redash on marathon by curling the marathon json. Redash doesn't start or give any errors, however when I run the docker image, it starts up fine, and doesn't report any errors.
on marathon redash hangs between at staging and restarts again
I wish I could post an error but I don't have any
I will go through the steps again and see if I can find you something to work with
this is a bit difficult to describe without being able to show something
will document what I did to run redash
and post back here later on
Arik Fraimovich
@arikfr
Oct 20 2015 16:06
Thanks! I'm not much familiar with marathon so can't help. But you need to get the container running and pass it env variables for configuration (or env file).
Josh Fyne
@jfyne
Oct 20 2015 20:00
hi me again, i'm trying to get the vagrant dev environment working
but typing vagrant up just results in
Bringing machine 'default' up with 'virtualbox' provider...
There are errors in the configuration of this machine. Please fix
the following errors and try again:

vm:
* The box 'redash/dev' could not be found.
Josh Fyne
@jfyne
Oct 20 2015 20:25
trying to add in Oracle support
Arik Fraimovich
@arikfr
Oct 20 2015 20:33
@jfyne the box supposed to be hosted by Vagrant cloud. They changed it into Atlas, but I still see it listed there. Do you have a recent version of Vagrant?
If there is a way to import box files, you can try the direct download link and import it manually: https://dl.dropboxusercontent.com/u/2186704/redash_dev_0.1.0.box
Josh Fyne
@jfyne
Oct 20 2015 20:35
i just installed vagrant so I assume so
Arik Fraimovich
@arikfr
Oct 20 2015 20:35
hmm
Josh Fyne
@jfyne
Oct 20 2015 20:35
i can add a box from that URL though
Arik Fraimovich
@arikfr
Oct 20 2015 20:35
k, let me know what worked for you eventually
Josh Fyne
@jfyne
Oct 20 2015 20:36
aye will do
Josh Fyne
@jfyne
Oct 20 2015 21:04
so i ran vagrant box add redash/dev https://dl.dropboxusercontent.com/u/2186704/redash_dev_0.1.0.box
then vagrant up worked