These are chat archives for getredash/redash

18th
Jan 2016
Tom
@tomkanjam
Jan 18 2016 00:07

The script installs v0.7.1 so I changed REDASH_VERSION=${REDASH_VERSION-0.7.1.b1015} to REDASH_VERSION=${REDASH_VERSION-0.9.0.b1363} but got the following error:
Creating user (admin, Admin)...
Admin: True
Login with Google Auth: False
Creating redash reader postgres user.
CREATE ROLE
GRANT
GRANT
ERROR: relation "activity_log" does not exist

Thought I should ask if I'm doing it right before I start troubleshooting...

Takahiro Mitsumori
@TMit
Jan 18 2016 06:12
@arikfr I found othre "INFO" log but there had no "Executing query:" at under /opt/redash/logs.
Arik Fraimovich
@arikfr
Jan 18 2016 06:37
@nzben were they empty before? if not, than it's not the intended behavior :worried:
@spectr remove activity_log from this line: https://github.com/getredash/redash/blob/master/setup/ubuntu/bootstrap.sh#L148 and run it again. note that the script is not really idempotent, so if you running it again on the same machine, maybe comment out some sections... I will also update the script in the repo.
@TMit can you share celery_error.log privately with me?
Takahiro Mitsumori
@TMit
Jan 18 2016 06:54
@arikfr I sent to you at arik@arikfr.com.
Arik Fraimovich
@arikfr
Jan 18 2016 06:55
@TMit great. I will look at it soon, and reply via email.
Tom
@tomkanjam
Jan 18 2016 12:18
@arikfr Thanks, that seems to have worked.
gseva
@gseva
Jan 18 2016 14:25
@arikfr Is there any way to use query parameters on direct API call?
xiandelife
@xiandelife
Jan 18 2016 15:07
@arikfr Hi, I update the redash to latest version and found that it comes out an error "ValueError: No JSON object could be decoded" for the data resource.
Arik Fraimovich
@arikfr
Jan 18 2016 15:08
@xiandelife where do you get this error? From what version did you upgrade?
xiandelife
@xiandelife
Jan 18 2016 15:10
Screen Shot 2016-01-18 at 16.09.55.jpg
@arikfr to 0.9 version.
Arik Fraimovich
@arikfr
Jan 18 2016 16:21
@xiandelife what version did you have before the upgrade? Anyway looks like one of your data sources has bad settings. You should be able to fix it with psql. I'll be online later and will provide more details
xiandelife
@xiandelife
Jan 18 2016 21:21
@arikfr I have merged from 0.6 and I also tried with cloning the latest redash from github. The metadata resources disappear somehow.
Arik Fraimovich
@arikfr
Jan 18 2016 21:27
@xiandelife are you sure all migrations ran successfully during upgrade? I'm not sure if it happened before or after 0.6 but at some point we changed all data sources to use json for config