These are chat archives for getredash/redash

20th
May 2016
michelecoleman
@michelecoleman
May 20 2016 01:45
Can I save a pivot table visualization and add it to a dashboard?
I don't see any "save" button on the pivot table view, and I only see pivot table when I'm looking at a query. When I go to add anything to my dashboard I do not see a pivot table option
I am using version 0.9.1+b1377
Once I hit "save" on my query the pivot table blanked out
and it is back to square 1
Clicking the "refresh dataset" button also resets the pivot table to starting condition
As if I had done no work at all building the visualization
michelecoleman
@michelecoleman
May 20 2016 02:05
Now I have played around on the demo site and had much greater success saving a pivot table and adding it to a dashboard. So is the answer going to be that we should upgrade our instance to 0.10.0 ?
Teguh Nugraha
@teguhn_twitter
May 20 2016 03:15
I'm about to stop/restart the celery_workers, but I got this message:
Error: .ini file does not include supervisorctl section
sorry, my bad, wrong dir
Arik Fraimovich
@arikfr
May 20 2016 03:22
@mvolpato you can use PayPal. Ping me in private.
@mdwongca currently it doesn't support accepting parameters. I guess we can change that, because we have now the code to merge params with query in the backend. Or you can use the helper function that runs an arbitrary query and construct the query in python
@michelecoleman that's correct, it's a feature from 0.10.
mdwongca
@mdwongca
May 20 2016 03:25
ok. thanks! I'll take a look at that
Arik Fraimovich
@arikfr
May 20 2016 03:25
@teguhn_twitter strange
@teguhn_twitter can you compare /opt/redash/supervisord.conf to https://github.com/getredash/redash/blob/master/setup/ubuntu/files/supervisord.conf and see if there is a difference?
jcborras
@jcborras
May 20 2016 14:16
Hi all, I'm running my own instance over here and having issues with Mail. I turned on all logging and I get a nasty HTTP 500 which I can't troubleshoot. Any hints will be appreciated:
[2016-05-20 14:12:42,962][PID:5525][INFO][metrics] method=POST path=/api/users/3/reset_password endpoint=user_reset_password status=500 content_type=? content_length=-1 duration=22.03 query_count=6 query_duration=4.44
jcborras
@jcborras
May 20 2016 14:58
OK, actually it's not with Mail. Obviously. I think I'll query the db to see what's there....
Arik Fraimovich
@arikfr
May 20 2016 15:45
@jcborras I'm not sure it's a really 500 error. What is the actual issue you experience? Not receiving the email?
jcborras
@jcborras
May 20 2016 20:53
I'll get back to you once I'm done logging everything (first time on the code, you see)