These are chat archives for getredash/redash

11th
Aug 2016
mirrorhanyu
@mirrorhanyu
Aug 11 2016 05:25
Hello everyone! I’m new to redash, and I refer to this doc (http://docs.redash.io/en/latest/dev/vagrant.html) and open localhost:9001 in my browser, after log in there is empty, I don’n know how to add database so that redash can do the query, really appreciate that someone give me a more detailed and simple tutorial, thanks
Arik Fraimovich
@arikfr
Aug 11 2016 07:37
@mirrorhanyu Did it render the UI? If it has, just click on the database icon in the header, and then on "+ New Data Source". If it didn't render the UI, make sure you started the server and that it worked properly.
mirrorhanyu
@mirrorhanyu
Aug 11 2016 07:44
@arikfr Thanks for your time!!! 1. I just follow the steps in the doc ,but it does not render the UI, maybe something wrong with the server. and one of my friend meet the same situation with me now 2. I create a new account in the Re:dash website and after login, I can "New Data Source", I don't get what does the field "JSON Key File" mean, does the doc have said that and I just can find that
Arik Fraimovich
@arikfr
Aug 11 2016 08:19
It's the JSON file you get when generating a service account: https://developers.google.com/identity/protocols/OAuth2ServiceAccount#creatinganaccount
mirrorhanyu
@mirrorhanyu
Aug 11 2016 08:22
@arikfr Thank you very much, I just get to know how to use it, and use it query a database deployed in the remote heroku project successfully, it is cool, thanks again!!!!
Arik Fraimovich
@arikfr
Aug 11 2016 08:23
If you need to query a postgres database, you don't need the JSON file.
mirrorhanyu
@mirrorhanyu
Aug 11 2016 09:49
@arikfr Yes, I Know that, thanks :smile:
Arik Fraimovich
@arikfr
Aug 11 2016 10:30
:+1:
HenroRitchie
@HenroRitchie
Aug 11 2016 11:47
@arikfr Hi. Is the \r\n in the data source results format required or are they just there for readability
Arik Fraimovich
@arikfr
Aug 11 2016 11:55
@HenroRitchie just readability.
HenroRitchie
@HenroRitchie
Aug 11 2016 13:37
@arikfr Eureka - I have it working now... Thank you for the help
Alex Sukstansky
@alexsukstansky
Aug 11 2016 14:49
Hi. I've just deployed a new version and here is what don't understand: when I want to add a user it asks for a login name and email. But no password field present. After user is created I can't login because hey - no password was specified.
I suspect that new user should receive a mail invitation with a link that will lead him to password reset for or something. That's mean that mailing setting is a MUST. Please correct me if I'm wrong. I also don't see an option to delete users. Thank you in advance for your help!
Arik Fraimovich
@arikfr
Aug 11 2016 19:16
@alexsukstansky when you create a new user, it sends him an invite (if you have email configured) but it also shows you the invite link, which you can use to manually send to the new user. And you're right, currently there is no option to delete a user.