Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Shin
@shinsenter
When using docker, I had problems with db migration when updating from 4.34.0 (tag gitbucket/gitbucket:4) to 4.35.3. Reverting back to 4.34.0 working well. Hope to be supported. よろしくお願いします。
6 replies
xogium
@xogium
hi Takezoe ! Was wondering if you or anyone here saw my question about the radio buttons for role of collaborators or group members… is this some kind of bug for everyone or is it just accessibility related ?
the fact that after selecting one for a member then clicking apply changes, the choice I picked doesn't seem to be displayed in any way
all the buttons are unselected when the page comes up the next time
Naoki Takezoe
@takezoe
@xogium Can you confirm whether the selected permission is actually applied?
xogium
@xogium
hello Takezoe :) yes the perms are applied it appears, it's just not visible somehow…
Naoki Takezoe
@takezoe
Hmm, I see. That's weird.
rajeshrocky
@rajeshrocky
Hi There, I have Gitbucket that's running 4.15.0 version and the database which it is using is Psql(9.6) . Can i directly upgrade it to the latest Version ( 4.35.3) ? Is the new version compatible with the Psql(9.6) version ?
Naoki Takezoe
@takezoe
@rajeshrocky Basically, it's possible, but I strongly recommend taking a backup of your data before upgrading.
rajeshrocky
@rajeshrocky
Thanks @takezoe , i would do that.
@takezoe , Are there any database schemas that i need to change during the upgrade process ?
Naoki Takezoe
@takezoe
No, GitBucket will automatically update your database schema if necessary.
rajeshrocky
@rajeshrocky
Got it, Thank you @takezoe
Sahil Sardana
@sahil-sardana
Hello @takezoe hope you are doing well. I was able to fix the LDAP issue and now I am having issue with copying the data.mv.db directory from the backup .gitbucket directory. I copied all other files & directories. As soon as I update the data.mv.db I start getting below error: [localhost-startStop-1] ERROR com.zaxxer.hikari.pool.HikariPool - HikariPool-1 - Exception during pool initialization.
org.h2.jdbc.JdbcSQLSyntaxErrorException: Table "COMMIT_COMMENT" not found; SQL statement:
ALTER TABLE PUBLIC.COMMIT_COMMENT ADD CONSTRAINT PUBLIC.IDX_COMMIT_COMMENT_PK PRIMARY KEY(COMMENT_ID) INDEX PUBLIC.PRIMARY_KEY_699 [42102-199]
at org.h2.message.DbException.getJdbcSQLException(DbException.java:451)
at org.h2.message.DbException.getJdbcSQLException(DbException.java:427)
at org.h2.message.DbException.get(DbException.java:205)
at org.h2.message.DbException.get(DbException.java:181)
at org.h2.command.ddl.AlterTableAddConstraint.tryUpdate(AlterTableAddConstraint.java:108)
at org.h2.command.ddl.AlterTableAddConstraint.update(AlterTableAddConstraint.java:78)
at org.h2.engine.MetaRecord.execute(MetaRecord.java:60)
at org.h2.engine.Database.open(Database.java:842)
3 replies
MrMelon
@MrMelon54
is it possible to have a fully dark theme for each colour?
3 replies
sdbbs
@sdbbs
Just wanted to note, after my Mar 08 2019 13:35 post, that there is a https://github.com/onukura/gitbucket-mathjax-plugin which works fine for Latex-style equations in Markdown on Gitbucket.
1 reply
umair4262
@umair4262
I want a github clone for fb hacking ... Anyone have ???
rajeshrocky
@rajeshrocky
Hi All, I have Ungraded my Gitbucket from 4.15 to the newest version 4.35.3 in my development environment but i am not able to login to the UI using the root credentials, Can anyone let me know where there is any location on the gitbucket server where i can find the admin credentials?
1 reply
dumpaliaravind
@dumpaliaravind
Hi All, I am upgrading the gitbucket 4.15 to 4.35.3. But i did found a document that has scala version 2.13 compatabile for 4.35.3. But when i check for 4.15 the compatbaile version is 2.12. So if i upgrade the gitbucket to the latest 4.35.3 will it a problem ? because i have the scala of 2.12. Or esle do i need to upgrade the Scala first and then upgrade the gitbucket version? if yes can someone help me in upgrading the scala as i don't see a document on scala. Thanks!
image.png
image.png
Naoki Takezoe
@takezoe
@dumpaliaravind You don't need to upgrade your Scala installation. The recent versions of GitBucket is built with Scala 2.13, but it doesn't use your Scala installation at runtime. GitBucket requires only Java installation to run.
1 reply
Naoki Takezoe
@takezoe
Does anyone have options or feedbacks about basic authentication support in GitBucket? Please comment on this pull request if you have anything: gitbucket/gitbucket#2713
Josh Curtiss
@joshuacurtiss
Has anyone tried integrating GitBucket with Sentry (on-premise) using its GitHub Enterprise integration? I just installee Sentry and will be wanting to integrate with GB.
Douglas Jones
@Aeroclassics1_twitter
Hi, I am trying to get GitBucket setup on a Ubuntu 20.02 system. I installed GitBucket, NGINX and MySQL 8. I was able to get the admin web pack of GitBucket, from a remote PC but not from the console on the Linux box. I read somewhere that GitBucket does not work with MySQL 8, so I removed MySQL 8 and installed MySQL 5.7. Somewhere something got crossed up as I cannot reach the GitBucket admin web page from either the console or a remote PC. Can someone tell me what is controlling access to GitBucket?
Sebastian K.
@argosy_ops_twitter
Hey everyone! I'm getting a 404 on the content area (repository listing index) after a fresh install. Network analysis shows me it's thrown by browsing-context.js:1166. Any ideas as to why this is happening or how to trace down the cause?
1 reply
Douglas Jones
@Aeroclassics1_twitter
GitBucket GitBucket GitBucket
Toggle navigation
Find a repository
Pull requests
Issues
Snippets
New repository
New group
@jones_d
Your profile
Account settings
System administration
Sign out
Recently updated repositories
Find a repository
jones_d/sample
Div_8_Devs/RAMON-LOCATE
News feed
Repositories
Pull requests
Issues
activities
1 hour ago
@jones_d jones_d created jones_d/sample
2 days ago
@root root created Div_8_Devs/RAMON-LOCATE
I just just dropped the 4.35.3 version of gitbucket onto my server. Now the admin web p[age is not HTML but looks like just some links? What happened?
Douglas Jones
@Aeroclassics1_twitter

When I look at the web page source I see a lot of messages like this:

GET http://abt33.rsint.net/gitbucket/assets/vendors/bootstrap-datetimepicker-4.17.44/css/bootstrap-datetimepicker.min.css?20210412170827 net::ERR_ABORTED 404 (Not Found)
abt33.rsint.net/:18 GET http://abt33.rsint.net/gitbucket/assets/vendors/bootstrap-3.4.1/css/bootstrap.min.css?20210412170827 net::ERR_ABORTED 404 (Not Found)
abt33.rsint.net/:17 GET http://abt33.rsint.net/gitbucket/assets/vendors/google-fonts/css/source-sans-pro.css?20210412170827 net::ERR_ABORTED 404 (Not Found)
abt33.rsint.net/:22 GET http://abt33.rsint.net/gitbucket/assets/vendors/color-themes-for-google-code-prettify/github-v2.min.css?20210412170827 net::ERR_ABORTED 404 (Not Found)
abt33.rsint.net/:21 GET http://abt33.rsint.net/gitbucket/assets/vendors/colorpicker/css/bootstrap-colorpicker.min.css?20210412170827 net::ERR_ABORTED 404 (Not Found)
abt33.rsint.net/:19 GET http://abt33.rsint.net/gitbucket/assets/vendors/octicons-4.4.0/octicons.min.css?20210412170827 net::ERR_ABORTED 404 (Not Found)
abt33.rsint.net/:24 GET http://abt33.rsint.net/gitbucket/assets/vendors/AdminLTE-2.4.2/css/AdminLTE.min.css?20210412170827 net::ERR_ABORTED 404 (Not Found)
abt33.rsint.net/:28 GET http://abt33.rsint.net/gitbucket/assets/vendors/jquery-ui/jquery-ui.structure.min.css?20210412170827 net::ERR_ABORTED 404 (Not Found)
abt33.rsint.net/:26 GET http://abt33.rsint.net/gitbucket/assets/vendors/font-awesome-4.7.0/css/font-awesome.min.css?20210412170827 net::ERR_ABORTED 404 (Not Found)
abt33.rsint.net/:27 GET http://abt33.rsint.net/gitbucket/assets/vendors/jquery-ui/jquery-ui.min.css?20210412170827 net::ERR_ABORTED 404 (Not Found)
abt33.rsint.net/:23 GET http://abt33.rsint.net/gitbucket/assets/vendors/facebox/facebox.css?20210412170827 net::ERR_ABORTED 404 (Not Found)
abt33.rsint.net/:25 GET http://abt33.rsint.net/gitbucket/assets/vendors/AdminLTE-2.4.2/css/skins/skin-blue.min.css?20210412170827 net::ERR_ABORTED 404 (Not Found)

2 replies
dumpaliaravind
@dumpaliaravind
image.png
Hi All, After upgrading gitbucket to 4.35.3 webhooks are not working. And I see this error. Can someone please help me understand this issue?
dumpaliaravind
@dumpaliaravind
image.png
And this is the error I am seeing in the logs:
Naoki Takezoe
@takezoe
@dumpaliaravind I'm not yet 100% sure though, looks like a bug in 4.35.3. Could you create an issue on GitHub?
2 replies
ziggystar
@ziggystar
There are plugins for viewers. Is it also possible to use a plugin as editor?
xogium
@xogium
is it possible to convert an existing repository into a mirror with the plugin that allows creating mirrors ? I have a project that's moved on github but still would like a mirror on gitbucket, but don't want to recreate the whole thing. I mean, I'll do it if I have to, but I'd prefer not
久野 浩
@hkuno9000_twitter

When I select a project on the gitbucket-web-menu,
I get a WARN message "Usage of the artifact cache2k-all is deprecated, please update your dependencies."
Why, and What to do?

Version: gitbucket-4.35.3

OS: Ubuntu20.04LTS on Windows10 WSL

Console-outputlog:

$ java -jar $HOME/install/gitbucket.war
2021-05-12 12:06:42.281:INFO::main: Logging initialized @483ms to org.eclipse.jetty.util.log.StdErrLog
2021-05-12 12:06:42.391:WARN:oejsh.ContextHandler:main: Empty contextPath
2021-05-12 12:06:42.397:INFO:oejs.Server:main: jetty-9.4.32.v20200930; built: 2020-09-30T16:16:37.804Z; git: de97d26f7bd222a0e16831e353d702a7a422f711; jvm 11.0.10+9-Ubuntu-0ubuntu1.20.04
2021-05-12 12:06:47.289:INFO:oejw.StandardDescriptorProcessor:main: NO JSP Support for /, did not find org.eclipse.jetty.jsp.JettyJspServlet
2021-05-12 12:06:47.524:INFO:oejs.session:main: DefaultSessionIdManager workerName=node0
2021-05-12 12:06:47.525:INFO:oejs.session:main: No SessionScavenger set, using defaults
2021-05-12 12:06:47.528:INFO:oejs.session:main: node0 Scavenging every 600000ms
12:06:47.917 [main] INFO  com.zaxxer.hikari.HikariDataSource - HikariPool-1 - Starting...
12:06:48.186 [main] INFO  com.zaxxer.hikari.HikariDataSource - HikariPool-1 - Start completed.
12:06:48.203 [main] WARN  slick.util.AsyncExecutor - Having maxConnection > maxThreads can result in deadlocks if transactions or database locks are used.
12:06:48.214 [main] INFO  g.core.servlet.InitializeListener - Check version
12:06:48.214 [main] INFO  g.core.servlet.InitializeListener - Start schema update
12:06:48.256 [main] INFO  g.core.servlet.InitializeListener - Extract bundled plugins...
12:06:48.298 [main] INFO  g.core.servlet.InitializeListener - Extract to /home/hkuno/.gitbucket/plugins/gitbucket-notifications-plugin-1.10.0.jar
12:06:48.311 [main] INFO  g.core.servlet.InitializeListener - Extract to /home/hkuno/.gitbucket/plugins/gitbucket-gist-plugin-4.20.0.jar
12:06:48.319 [main] INFO  g.core.servlet.InitializeListener - Extract to /home/hkuno/.gitbucket/plugins/gitbucket-emoji-plugin-4.6.0.jar
12:06:48.335 [main] INFO  g.core.servlet.InitializeListener - Extract to /home/hkuno/.gitbucket/plugins/gitbucket-pages-plugin-1.9.0.jar
12:06:48.337 [main] INFO  g.core.servlet.InitializeListener - Initialize plugins
12:06:48.414 [main] INFO  gitbucket.core.plugin.PluginRegistry - Initialize gitbucket-gist-plugin-4.20.0.jar
12:06:48.699 [main] INFO  gitbucket.core.plugin.PluginRegistry - Initialize gitbucket-emoji-plugin-4.6.0.jar
12:06:48.724 [main] INFO  gitbucket.core.plugin.PluginRegistry - Initialize gitbucket-notifications-plugin-1.10.0.jar
12:06:48.764 [main] INFO  gitbucket.core.plugin.PluginRegistry - Initialize gitbucket-pages-plugin-1.9.0.jar
12:06:48.795 [main] INFO  o.scalatra.servlet.ScalatraListener - The cycle class name from the config: ScalatraBootstrap
12:06:48.796 [Thread-9] INFO  g.core.plugin.PluginWatchThread - Start PluginWatchThread: /home/hkuno/.gitbucket/plugins
12:06:48.800 [main] INFO  o.scalatra.servlet.ScalatraListener - Initializing life cycle class: ScalatraBootstrap
2021-05-12 12:06:49.274:INFO:oejsh.ContextHandler:main: Started o.e.j.w.WebAppContext@4ee5b2d9{/,file:///home/hkuno/.gitbucket/tmp/webapp/,AVAILABLE}{file:/home/hkuno/install/gitbucket.war}
2021-05-12 12:06:49.301:INFO:oejs.AbstractConnector:main: Started ServerConnector@6073f712{HTTP/1.1, (http/1.1)}{0.0.0.0:8080}
2021-05-12 12:06:49.303:INFO:oejs.Server:main: Started @7524ms
12:07:33.194 [qtp2052001577-12] INFO  o.c.core.Cache2kCoreProviderImpl - cache2k starting. version=1.2.4.Final
12:07:33.280 [qtp2052001577-12] WARN  o.c.e.a.WarnAboutCache2kAllUsage - Usage of the artifact cache2k-all is deprecated, please update your dependencies. See: https://cache2k.org/docs/latest/user-guide.html#getting-started
Tech Founder
@questionsatabc_twitter
hi, just checking I installed gitbucket awhile back (4.x.x) and have not upgraded it for quite sometimes. I'm looking for upgrade document. Does anyone know where it is ?
SIkebe
@SIkebe
There's no version-specific guidance. Just stop GitBucket, replace the gitbucket.war, and restart.
https://github.com/gitbucket/gitbucket#installation
Remember you backup your data before upgrade. It's very likely that DB migration will occur.
Please refer these xml files about migration details
https://github.com/gitbucket/gitbucket/tree/master/src/main/resources/update
Lionel B. Dyck
@lbdyck

I just installed gitbucket and now I'm trying to login with the default id/pw (root/root) and getting Sorry, your Username and/or Password is incorrect. Please try again.

Can anyone advise how to fix this?

During the startup I'm seeing these errors - seeking advice/help:

2021-05-14 04:31:27.202:INFO:oejw.StandardDescriptorProcessor:main: NO JSP Support for /, did not find org.eclipse.jetty.jsp.JettyJspServlet
04:33:15.587 [main] WARN l.servicelocator.ServiceLocator - Can not use class liquibase.parser.core.json.JsonChangeLogParser as a Liquibase service because org.yaml.snakeyaml.constructor.BaseConstructor is not in the classpath
04:33:15.607 [main] WARN l.servicelocator.ServiceLocator - Can not use class liquibase.parser.core.yaml.YamlChangeLogParser as a Liquibase service because org.yaml.snakeyaml.constructor.BaseConstructor is not in the classpath

Lionel B. Dyck
@lbdyck
I resolved the snakeyaml by getting the snakeyaml-1.9.jar but still haven't found the jetty jar - even tried downloading the latest jetty zip file that had a lot of jar files :(
SIkebe
@SIkebe
You don't need to put jar files yourself. How did you install GItBucket?
OS and JDK version?
Lionel B. Dyck
@lbdyck

Per https://github.com/gitbucket/gitbucket the installation I just downloaded the war file.

I'm using java: IBM J9 VM (build 2.9, JRE 1.8.0 z/OS s390x-64-Bit Compressed References 20200219_440062 (JIT enabled, AOT enabled)

SIkebe
@SIkebe

I tried this Dockerfile

FROM adoptopenjdk/openjdk8-openj9

LABEL maintainer="Naoki Takezoe <takezoe [at] gmail.com>"

ADD https://github.com/gitbucket/gitbucket/releases/download/4.35.3/gitbucket.war /opt/gitbucket.war

RUN ln -s /gitbucket /root/.gitbucket

VOLUME /gitbucket

# Port for web page and Port for SSH access to git repository (Optional)
EXPOSE 8080 29418

CMD ["sh", "-c", "java -jar /opt/gitbucket.war"]

The output has similar warnings, however I can sign-in without any problem.

2021-05-14 14:56:25.404:INFO::main: Logging initialized @190ms to org.eclipse.jetty.util.log.StdErrLog
2021-05-14 14:56:25.579:WARN:oejsh.ContextHandler:main: Empty contextPath
2021-05-14 14:56:25.589:INFO:oejs.Server:main: jetty-9.4.32.v20200930; built: 2020-09-30T16:16:37.804Z; git: de97d26f7bd222a0e16831e353d702a7a422f711; jvm 1.8.0_292-b10
2021-05-14 14:56:27.808:INFO:oejw.StandardDescriptorProcessor:main: NO JSP Support for /, did not find org.eclipse.jetty.jsp.JettyJspServlet
2021-05-14 14:56:28.116:INFO:oejs.session:main: DefaultSessionIdManager workerName=node0
2021-05-14 14:56:28.116:INFO:oejs.session:main: No SessionScavenger set, using defaults
2021-05-14 14:56:28.119:INFO:oejs.session:main: node0 Scavenging every 600000ms
14:56:28.752 [main] INFO  com.zaxxer.hikari.HikariDataSource - HikariPool-1 - Starting...
14:56:29.078 [main] INFO  com.zaxxer.hikari.HikariDataSource - HikariPool-1 - Start completed.
14:56:29.112 [main] WARN  slick.util.AsyncExecutor - Having maxConnection > maxThreads can result in deadlocks if transactions 
or database locks are used.
14:56:29.160 [main] INFO  g.core.servlet.InitializeListener - Check version
14:56:29.161 [main] INFO  g.core.servlet.InitializeListener - Start schema update
14:56:30.657 [main] WARN  l.servicelocator.ServiceLocator - Can not use class liquibase.parser.core.yaml.YamlChangeLogParser as a Liquibase service because org.yaml.snakeyaml.constructor.BaseConstructor is not in the classpath
14:56:30.662 [main] WARN  l.servicelocator.ServiceLocator - Can not use class liquibase.parser.core.json.JsonChangeLogParser as a Liquibase service because org.yaml.snakeyaml.constructor.BaseConstructor is not in the classpath
14:56:33.634 [main] INFO  g.core.servlet.InitializeListener - Extract bundled plugins...
14:56:33.665 [main] INFO  g.core.servlet.InitializeListener - Extract to /root/.gitbucket/plugins/gitbucket-notifications-plugin-1.10.0.jar
14:56:33.668 [main] INFO  g.core.servlet.InitializeListener - Extract to /root/.gitbucket/plugins/gitbucket-gist-plugin-4.20.0.jar
14:56:33.669 [main] INFO  g.core.servlet.InitializeListener - Extract to /root/.gitbucket/plugins/gitbucket-emoji-plugin-4.6.0.jar
14:56:33.681 [main] INFO  g.core.servlet.InitializeListener - Extract to /root/.gitbucket/plugins/gitbucket-pages-plugin-1.9.0.jar
14:56:33.682 [main] INFO  g.core.servlet.InitializeListener - Initialize plugins
14:56:33.763 [main] INFO  gitbucket.core.plugin.PluginRegistry - Initialize gitbucket-gist-plugin-4.20.0.jar
14:56:34.225 [main] INFO  gitbucket.core.plugin.PluginRegistry - Initialize gitbucket-emoji-plugin-4.6.0.jar
14:56:34.244 [main] INFO  gitbucket.core.plugin.PluginRegistry - Initialize gitbucket-notifications-plugin-1.10.0.jar
14:56:34.458 [main] INFO  gitbucket.core.plugin.PluginRegistry - Initialize gitbucket-pages-plugin-1.9.0.jar
14:56:34.562 [Thread-13] INFO  g.core.plugin.PluginWatchThread - Start PluginWatchThread: /root/.gitbucket/plugins
14:56:34.577 [main] INFO  o.scalatra.servlet.ScalatraListener - The cycle class name from the config: ScalatraBootstrap        
14:56:34.583 [main] INFO  o.scalatra.servlet.ScalatraListener - Initializing life cycle class: ScalatraBootstrap
2021-05-14 14:56:35.614:INFO:oejsh.ContextHandler:main: Started o.e.j.w.WebAppContext@-1fa19c1f{/,file:///gitbucket/tmp/webapp/,AVAILABLE}{file:/opt/gitbucket.war}
2021-05-14 14:56:35.639:INFO:oejs.AbstractConnector:main: Started ServerConnector@97ed655{HTTP/1.1, (http/1.1)}{0.0.0.0:8080}  
2021-05-14 14:56:35.647:INFO:oejs.Server:main: Started @10437ms
@lbdyck Could you post the whole bootstrap logs?
xogium
@xogium
are there ways to make gitbucket not eat a ton of memory without making it impossible to run correctly ? I tried the -Xmx setting of jvm
but it ended up running out of memory in its own jvm instead