Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
Nikita
@o1dnik_gitlab
And I'm sorry if this is not the right place for asking such questions, but I didn't find anything better so far
ronalddavid
@ronalddavid
Hi Everyone.. I am using GitLab CE. While I am trying to push my source code which consists of French characters, GitLab doesn't recognise them as french characters and uses its own encoding which in turn makes my build fail in the Jenkins server. Any idea for work around or how to solve this ?
BANO.notIT
@BANOnotIT
Can somebody give an example of helm deployment job? I've tried to use alpine/helm image, but it isn't usable because of entrypoint and setting "entrypoint" to /bin/sh doesn't help
Sascha Wiegandt
@TheSasch
Hello, does someone have a hint for me where i could configure the automatic bridge between gitlab ci and sonarqube? I want automatically get a visible Sonar scan in each Pull-Request a developer sets up. I know the manual way from .gitlab-ci.yml where i could push as step my results to sonar. but i read something that it would be possible to integrate both systems where i don't need to do this within each pipeline.
David Broin
@davidbro-in_gitlab
Hi @TheSasch you always need some things in .gitlab-ci.yml sonarcloud integration helps you a lot, but they actually give a code to copy/paste in your CI config
6 replies
CodingPenguin
@TheCodingPenguin
Hello, a quite basic question here for anyone using Gitlab CI with sbt/scala. I have my test stage followed by rpm:publish stage and I would like to skip compiling on the second stage and get the compiled files from the first stage. What is the ideal way of doing this ?
David Broin
@davidbro-in_gitlab
You should use cache
CodingPenguin
@TheCodingPenguin
@davidbro-in_gitlab thank you for the response and the reference but the docs say: While the cache could be configured to pass intermediate build results between stages, this should be done with artifacts instead.. However, this doesn't needs to be an artifact that's saved and stored in some place because it is only needed for the consecutive stage. Hence I am confused a little
David Broin
@davidbro-in_gitlab
Yes, if there's nothing to share between stages you could use artifacts. I actually prefer that way because it's simpler to follow the pipeline artifacts, but cache speeds up compilation using previous stages cache.
Joe Phillips
@phillijw
can anyone clarify how I can incorporate allow_failure: true into this manual step?
  rules:
    - if: $CI_COMMIT_BRANCH =~ /^release\/v\d+.\d+.\d+$/
      when: manual
    - when: never
do I need allow_failure: true on the previous step instead?
David Broin
@davidbro-in_gitlab
Hi @phillijw could you share more lines? Last line is wrong, you don't have if, changes neither exists clause before when: never
This message was deleted
Have you try this?
rules:
    - if: $CI_COMMIT_BRANCH =~ /^release\/v\d+.\d+.\d+$/
      when: manual
      allow_failure: true
Jon Ward
@jghward

Hi, wondering if anybody could help me with an issue with using trigger / bridge jobs.

I have Project A which contains global variables in the CI YAML. Project B downstream also contains global variables which I do NOT want to override. I understand upstream variables have precedence over downstream vars, so I want to avoid passing Project A's global vars to Project B.

My .gitlab-ci.yml for Project A looks like:

variables:
  MY_VAR: "set in the upstream job"

downstream_project_b:
  stage: trigger_downstream
  variables: {}
  trigger: myprojects/project_b

In Project B I have:

variables:
  MY_VAR: "set in the downstream job"

test:
  stage: test
  script:
    - echo "$MY_VAR"

As you can see I have attempted to unset the global vars in Project A by using variables: {} in the job, however $MY_VAR is still being passed to Project B and overriding $MY_VAR there. Is there any way I can unset it? Thanks in advance for any tips!

1 reply
Brian Pham
@brianpham
Hi, is anyone here using Gitlab managed terraform state? I am trying to get a sense of how people are using it and if they like it over the other backend methods.
Dominic Watson
@intellix
I'm trying to use AutoDevops inside a single repository hosting an nrwl/nx repository but having issues with only specific environment names getting various magical ENV vars: KUBE_* and CI_ENVIRONMENT_*. Anyone managed to do it?
There's multiple apps/endpoints with different K8S Replicaset requirements. I'm deploying a review app for each of them fine, because I can do something like:
environment:
  name: review/$PROJECT_NAME-$CI_COMMIT_REF_NAME
  url: http://$CI_PROJECT_ID-$CI_ENVIRONMENT_SLUG.$KUBE_INGRESS_BASE_DOMAIN
  on_stop: reviewApiStop

that works because Gitlab respects review/* as part of AutoDevops and provides the magic sauce to let it work, but if I try the same with staging like so:

environment:
  name: staging/$PROJECT_NAME
  url: http://$CI_PROJECT_PATH_SLUG-staging-api.$KUBE_INGRESS_BASE_DOMAIN

It doesn't work cause it only works for staging and not staging/*

so I thought ok no big deal.. I know my cluster details, I'll provide the KUBE_ vars myself..... and I don't even get the CI_ENVIRONMENT_* vars -.-
Dominic Watson
@intellix
Dominic Watson
@intellix
figured it out.... the staging/$PROJECT_NAME didn't work because PROJECT_NAME doesn't exist at the environment:name "step" and ending in a forward slash is invalid
ahsanmir
@ahsansmir
Hi - Having problems with accessing a repository using SSH
Anyone has any ideas
Judy Lipinski
@JudyLipinski_gitlab
A developer suddenly lost the ability to push or pull code. similar to this link, but it has lasted for days with no remedy. gitlab-org/gitlab-foss#1398
image.png
Alec Koumjian
@akoumjian_gitlab
I am trying to pass CI_ENVIRONMENT_NAME to webpack during the auto devops build step. I'm using the automatically detected buildpack and I've set AUTO_DEVOPS_BUILD_IMAGE_FORWARDED_CI_VARIABLES to CI_ENVIRONMENT_NAME,CI_COMMIT_SHA at the organization level. However, when I log out process.env, I can only see CI_COMMIT_SHA present.
Alec Koumjian
@akoumjian_gitlab

It looks like the environment name is set in the review step itself. What would folks recommend as the conventional way to use an environment config to point to other services from a static JS project? A dynamic environment such as an API can pull in environment variables or config files at run time, but I would think the static file project would need those configs built in, at build time.

I'm not afraid to write my own ci/cd scripts, but I'm curious if there is an auto devops convention here.

Dale Magee
@AntiSol
Hi there. Does anybody have any theories as to why I'm seeing no content in the main area on most/all pages on gitlab.com? I see the menus but that's all. I've tried: turning off ad blocker, restarting browser, etc etc. This is only affecting firefox as far as I can tell, doesn't happen in chrome. I'm even seeing it on the github help page.
Dale Magee
@AntiSol
if I had to guess I'd say a stylesheet isn't loading. div#content-body is set to display:none. Setting it to visible gives me content, but it's all messed up and not styled properly
Brian Pham
@brianpham
Does anyone know if gitlab managed terraform state remote store is supported for gitlab.com? I am looking at this doc, https://docs.gitlab.com/ee/administration/terraform_state.html and it only seems to show instructions for omnibus and from source.
Dale Magee
@AntiSol
(I found the answer to my question, if anybody else is having the same issue: gitlab-org/gitlab#239357)
fafifox
@fafifox

Hello,
I'm having trouble while trying to sign-in with my github account.
It says I need to confirm my email, so i click "resend confirmation email" but I got the following error:
Could not authenticate you from GitHub because "Csrf detected".

I've tried on firefox and chrome (with and without incognito mode) same things happens.
Any idea on how I can login ?

3 replies
Alec Koumjian
@akoumjian_gitlab
I am suddenly having a problem with review apps. Whenever my project gets to the review stage I get "This job failed because the necessary resources were not successfully created. More information "
Is it possible there are pods / deployments running in my managed k8s setup that I don't have easy access to? The cluster appears to be nowhere near capacity.
Surprising that the runner doesn't even start the job, there are no logs.
I tried disabling shared runners and only running on the ones in my cluster, but doesn't seem to make a difference.
br3nt
@br3nt
Hi everyone, Is there a setting somewhere I can set to have so that the git commit message body gets word-wrapped when expanding the body of a commit message?
Alec Koumjian
@akoumjian_gitlab
Hm, a bit frustrating here. The AutoDevops just suddenly stops working on me. I can't get any logs, the review stage just seems to not start. Anyone have recommendations of where to look first?
Alec Koumjian
@akoumjian_gitlab
Okay, so after battling with this for a day it seems that clearing the cluster cache in the advanced settings got it working again. How did I end up in this state and how do I avoid it in the future?
Ronald Roe
@ronaldroe

Hello, I'm trying to upload an image to a project - not as part of the repo, but so I can use it in a comment - is it possible to A) do that from a datauri, and B) use fetch or XHR to send it?
I've been beating my head against this for a few hours now. Every example I ever see is with cURL.

I can send the file, but I either get file is missing or file is invalid. I can successfully send via cURL. I've tried sending it with datauri URL escaped and also not. Am I missing something, or is this just not a possibility? I'd have to think there'd be a way, since the comment form turns pasted images into an uploaded file

Ateeb Ahmed
@ateebahmed_gitlab
Hello, I'm having this problem with SSH where my SSH connection hangs after establishing connection and sending the SSH version its using, I searched the problem and it seems Gitlab's SSH server is not responding to my connection. I can do same things with HTTPS fine but SSH hangs and after very long period timeout.
Ateeb Ahmed
@ateebahmed_gitlab
Output of ssh -Tvvv git@gitlab.com
OpenSSH_8.3p1, OpenSSL 1.1.1g FIPS  21 Apr 2020
debug1: Reading configuration data /home/user/.ssh/config
debug1: Reading configuration data /etc/ssh/ssh_config
debug3: /etc/ssh/ssh_config line 54: Including file /etc/ssh/ssh_config.d/50-redhat.conf depth 0
debug1: Reading configuration data /etc/ssh/ssh_config.d/50-redhat.conf
debug2: checking match for 'final all' host gitlab.com originally gitlab.com
debug3: /etc/ssh/ssh_config.d/50-redhat.conf line 3: not matched 'final'
debug2: match not found
debug3: /etc/ssh/ssh_config.d/50-redhat.conf line 5: Including file /etc/crypto-policies/back-ends/openssh.config depth 1 (parse only)
debug1: Reading configuration data /etc/crypto-policies/back-ends/openssh.config
debug3: gss kex names ok: [gss-curve25519-sha256-,gss-nistp256-sha256-,gss-group14-sha256-,gss-group16-sha512-,gss-gex-sha1-,gss-group14-sha1-,gss-group1-sha1-]
debug3: kex names ok: [curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group14-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1]
debug1: configuration requests final Match pass
debug1: re-parsing configuration
debug1: Reading configuration data /home/user/.ssh/config
debug1: Reading configuration data /etc/ssh/ssh_config
debug3: /etc/ssh/ssh_config line 54: Including file /etc/ssh/ssh_config.d/50-redhat.conf depth 0
debug1: Reading configuration data /etc/ssh/ssh_config.d/50-redhat.conf
debug2: checking match for 'final all' host gitlab.com originally gitlab.com
debug3: /etc/ssh/ssh_config.d/50-redhat.conf line 3: matched 'final'
debug2: match found
debug3: /etc/ssh/ssh_config.d/50-redhat.conf line 5: Including file /etc/crypto-policies/back-ends/openssh.config depth 1
debug1: Reading configuration data /etc/crypto-policies/back-ends/openssh.config
debug3: gss kex names ok: [gss-curve25519-sha256-,gss-nistp256-sha256-,gss-group14-sha256-,gss-group16-sha512-,gss-gex-sha1-,gss-group14-sha1-,gss-group1-sha1-]
debug3: kex names ok: [curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group14-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1]
debug2: resolving "gitlab.com" port 22
debug2: ssh_connect_direct
debug1: Connecting to gitlab.com [172.65.251.78] port 22.
debug1: Connection established.
debug1: identity file /home/user/.ssh/id_rsa type -1
debug1: identity file /home/user/.ssh/id_rsa-cert type -1
debug1: identity file /home/user/.ssh/id_dsa type -1
debug1: identity file /home/user/.ssh/id_dsa-cert type -1
debug1: identity file /home/user/.ssh/id_ecdsa type -1
debug1: identity file /home/user/.ssh/id_ecdsa-cert type -1
debug1: identity file /home/user/.ssh/id_ecdsa_sk type -1
debug1: identity file /home/user/.ssh/id_ecdsa_sk-cert type -1
debug1: identity file /home/user/.ssh/id_ed25519 type -1
debug1: identity file /home/user/.ssh/id_ed25519-cert type -1
debug1: identity file /home/user/.ssh/id_ed25519_sk type -1
debug1: identity file /home/user/.ssh/id_ed25519_sk-cert type -1
debug1: identity file /home/user/.ssh/id_xmss type -1
debug1: identity file /home/user/.ssh/id_xmss-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_8.3
Henrik Christian Grove
@hcgrove_gitlab
@ateebahmed_gitlab : What did you expect tto happen here? You've disabled (with the -T' option to ssh) tty allocation, so you won't get a prompt, but I see nothing suggesting that yu don't get the connection you asked for
2 replies
Deshdeepak
@Deshdeepak1
how gitlab is different from github?
1 reply
Ateeb Ahmed
@ateebahmed_gitlab

Seems to be working now

Hello, I'm having this problem with SSH where my SSH connection hangs after establishing connection and sending the SSH version its using, I searched the problem and it seems Gitlab's SSH server is not responding to my connection. I can do same things with HTTPS fine but SSH hangs and after very long period timeout.

Kalyan chakravarthy
@kalyan088_twitter
hello folks,
how to use gitlab jobs to go and fetch secrets from vault?
the underlying instances are configured with vault aws auth method, when running vault login getting * failed to verify as a valid EC2 instance in region
Jannik-143
@Jannik-143
Hello, is it possible to get the git log --numstat information via gitlab api?
Lukas M
@lukasmrtvy
Guys? gitlab-org/gitlab-runner#27026 ( docker-machine switch idea )
Yogesh Bhondekar
@yogesh.bond_gitlab
Hello All, I need help. Today I see all files from my repository are missing even I can't see any history also - strange. In afternoon I did commit, that was successful and now when I go to branch and repo nothing is there.. hos is this possible - also no history ? Anyone had experienced this.. any help is much appreciated.
Leo Palmer Sunmo
@leosunmo
Hello!
Is this a typo or am I misunderstanding?
https://docs.gitlab.com/ee/api/projects.html#transfer-a-project-to-a-new-namespace
Is there supposed to be a namespace slug in that URL or am I supposed to send a JSON payload with this API request?