Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
Ohm0n
@thecyberd3m0n_gitlab

release_job:
  stage: release
  needs:
    - job: build-web
      artifacts: true
  image: registry.gitlab.com/gitlab-org/release-cli:latest
  rules:
    - if: $CI_COMMIT_TAG
    - if: $CI_COMMIT_BRANCH == 'master'
  script:
    - echo "Running the release job."
  release:
    tag_name: '$CI_COMMIT_TAG'
    ref: '$CI_COMMIT_TAG'
    name: 'Release $CI_COMMIT_TAG'
    description: 'Release created using the release-cli.'
$ echo "Running the release job."
Running the release job.
Executing "step_release" stage of the job script
00:01
$ release-cli create --name "Release $CI_COMMIT_TAG" --description "Release created using the release-cli." --tag-name "$CI_COMMIT_TAG" --ref "$CI_COMMIT_TAG"
time="2022-05-07T19:01:08Z" level=info msg="Creating Release..." cli=release-cli command=create name="Release " project-id=32201481 ref= server-url="https://gitlab.com" tag-name= version=0.11.0
time="2022-05-07T19:01:08Z" level=fatal msg="run app" cli=release-cli error="failed to create release: API Error Response status_code: 422 message: Ref is not specified" version=0.11.0
Cleaning up project directory and file based variables
00:01
ERROR: Job failed: exit code 1
what I'm doing wrong?
31 replies
compound radius
@compound.radius_gitlab
I still can't find a solution for the docker login to registry.gitlab.com. Everything was working, now it isn't I have tried specifying docker login registry.gitlab.com:443 and that also did not change the result.
8 replies
Nicolas Goudry
@nicolas-goudry

Hi, I come here because I have a problem with a self-hosted runner and GitLab SaaS (gitlab.com). My runner cant clone our private repositories anymore due to a SSL error.

Here is the error:

fatal: unable to access 'https://gitlab.com/company/group/subgroup/project.git/': SSL certificate problem: unable to get local issuer certificate

Does anyone else have this error ? I can see that the certificate of gitlab.com is expirating in 3 days, but Im not sure its linked

Justin Georgeson (Work)
@jghal
@nicolas-goudry I was seeing the same thing this morning, but only on one of our runners. I restarted the container for that runner and the error went away.
7 replies
eccentricson
@eccentricson:matrix.org
[m]
Hello, we are currently installing Gitlab using the environment toolkit, on AWS, backed with runners in EKS. When a new runner pod is created, it picks up a job. If I pause the runner in the Gitlab UI and resume it, it picks up a new job. However, if I don't touch it and kick off a pipeline job, the runner log says Checking for jobs... nothing. And it never actually picks up the job unless I pause/resume the runner, or delete the pod in K8s so it creates a new runner pod. I'm not finding much about this on the internet, and been debugging it for a few hours. Currently using gitlab-runner:alpine3.15-14.9.2 for the runner
eccentricson
@eccentricson:matrix.org
[m]
:point_up: Edit: Hello, we are currently installing Gitlab using the environment toolkit, on AWS, backed with runners in EKS. When a new runner pod is created, it picks up a job. If I pause the runner in the Gitlab UI and resume it, it picks up a new job. However, if I don't touch it and kick off a pipeline job, the runner log says Checking for jobs... nothing. And it never actually picks up the job unless I pause/resume the runner, or delete the pod in K8s so it creates a new runner pod. I'm not finding much about this on the internet, and been debugging it for a few hours. Currently using gitlab-runner:alpine3.15-14.10.0 for the runner. Gitlab is running 14.10.0 currently
eccentricson
@eccentricson:matrix.org
[m]
I got this fixed, deployed with the Environment Toolkit, Sidekiq was reading from the wrong Redis cluster. After a review of the queues in the "Background Jobs" in the Admin panel it became obvious there was a queuing issue. Latency climbed very high, jobs weren't being completed, etc. I hope my explanation here helps the next person who runs into this issue.
Vignesh Shanmuganathan
@vshanmuganathan_gitlab

Hi,

I added container scanning to my GItlab pipeline, but I dont see this stp in the pipeline nor their is any error.

FYI: My repo is private and weuploade our images to Gitlab COntainer registry.

THough doing this would suffice:
include:

- template: Jobs/Build.gitlab-ci.yml

  • template: Security/Container-Scanning.gitlab-ci.yml

Let me know if i am missing something

Jason Chen
@jason.chen7_gitlab
hey guys, question. is ios shared runners coming with release 15.0?
2 replies
anybody know? or if it has been punted to next release D:
Jordan LEFEBVRE
@lefjor_gitlab
Hi everyone, when I try to remove integration with my AKS cluster I get a 500 error from gitlab.com is there a way to know what's the problem ?
1 reply
remove.PNG
Capture 500.PNG
Mat
@matmicro
Is there a channel like this one on Discord ?
2 replies
Peter Bollen
@pbollen_gitlab
Playing around with gitlab-triage, and would like to configure pipeline-schedules as supported by https://gitlab.com/gitlab-org/quality/triage-ops/-/blob/master/bin/manage_schedules. What would be the better approach to set this up, instead of copy-pasting these file(s) into my own repo?
Travis Newman
@travnewmatic

hey yeall

is downloading release assets from private repos via the API still busted? gitlab-org/gitlab#28978

curious what the right way to do this is

Matt Angell
@mangell_gitlab

Hi all, Im a recruiter at GitLab and wanted to let you know about a new team we are building here called Contributor Success. Our mission is to increase the efficiency, incentive & reward of our contribution process in order to achieve our ambition of supporting & achieving over 1000 community contributors to the Gitlab project!

We're looking for backend engineers today that have experience with contributing to open source projects like GitLab. Youll have an opportunity to grow our community, make it easier to contribute and support various open-source initiatives across the wider ecosystem.

If youre open to discussing a new full-time position with me or have any questions, feel free to drop me a message at mangell@gitlab.com or DM me here in Gitter!

Thank you and have a great day.

2 replies
rhrytskiv
@rhrytskiv_gitlab
Hi all
Anyone knows if GitLab 15 packages are going to release at specific hour today? Or just random time?
rhrytskiv
@rhrytskiv_gitlab
Nvm, dropped 30m ago.
KapitanPL
@KapitanPL

Hi Guys... need a hint.

In a gitlab runner I try to set SSH_COMMAND. for win machine (no docker)
If I set it in beforescript part as
${env:GIT_SSH_COMMAND} = 'ssh -vvv -i "C:\\Users\\te\\.ssh\\id_rsa" -o UserKnownHostsFile=C:/Users/te/.ssh/known_hosts'
it works.

however I would like to set it in variables (as we do for linux pipelines)
env:GIT_SSH_COMMAND : 'ssh -vvv -o UserKnownHostsFile=c:/Users/te/.ssh/known_hosts -i "c:\Users\te\.ssh\id_rsa"'

It works only partially. UserKnownHostFile is just ignored. Everything else works.

What happens?

By trial and error I discovered that it might depend on how I pass the paths ( \ vs / vs \\, what quation marks I use...)

But I am unable to figure out how to make it work.

Nicolas Goudry
@nicolas-goudry

Hi there, I come here because we just experienced a severe issue regarding GitLab SaaS issues (free tier).

We created a project 4 days ago, along with an issue that was given the id 1. Today, we couldnt find the issue on the project at all.
One of our developer had the issue page still opened in his browser, so he shared the link with us, but it gave us a 404 page when trying to open it.
The same developer just hit the refresh button and also got a 404.

In order to narrow down the problem and see if we deleted the issue by error, we created a new issue, which was also given the id 1 (weird).
We intentionnaly deleted this issue, and created a new one, which was given the id 2 (better).
This behavior strongly suggests that the problem is on GitLab and not on us. There isnt any issue reported on status.gitlab.com.
I see that GitLab 15.0 was released recently, could it be the source of the issue ?

Also, we found another weird thing: there is no activity log when deleting an issue, and the issue creation log is also deleted ! This behavior seems off, why purposefuly rewrite activity logs rather than append to it ?

Nick Veenhof
@nick_vh.gitlab_gitlab
@nicolas-goudry All production issues are handled here https://gitlab.com/gitlab-com/gl-infra/production/-/issues but I don't see any indication of issues like you mentioned. I would suggest to send the information to our support staff with as much data as you can provide!
lvaro Linares Cabr矇
@alvaro.linares1_gitlab
Hi
I have GitLab EE on k8s
Implement with Helm Chart
My upload are on GCP
BUT
When I try to do the migration it don't works
I do a check and I received this message: ArgumentError (Missing required arguments: google_project)
Can anyone have the same or was thhis problem?
Thanks a lot :D
David Ellis
@david_ellis_gitlab
I've been fighting with a weird issue for the past couple of days. In my pipeline I've told gitlab to include the entire repository in the artifact. I then add an exclude and tell it to not include the .git directory, and a few other files. But no matter what I put in the exclude, the pipeline always includes the .git directory. The other files I've put in the exclude are properly excluded, but .git is not.
artifacts:
  paths:
    - ./
  exclude:
    - ./.git
    - ./.git/
    - ./.git/*
    - ./.git/**
    - ./**/.git
Marek Alexa
@coding_hedgehog_gitlab
Can you advise on issue with local gitlab runner not being able to connect to docker daemon ? https://stackoverflow.com/questions/72426717/why-local-gitlab-runner-cant-connect-to-docker-daemon
mfilipe
@mfilipe:matrix.org
[m]
hi! I have a kubernetes secrets and I want to use the keys/values inside of kubernetes secrets as environment variables into the pipeline. do you know anyway to do this?
4 replies
the secret is a template file into CI/CD Variables
Basile Chandesris
@good92
Hi, Does anyone know how to create a markdown badge for IaC Terraform Infrastructure/Terraform/State file to retrieve the pipeline status per state file name?
context: monorepo case
Anshul Riyal
@anshulriyal_gitlab
Screenshot 2022-05-31 at 9.04.41 PM.png
1 reply
Golide
@tshumaed_twitter
hello @all I am stuck on an issue where I am generating Dockerfile for projects on the fly (if not already existing). I am using Kaniko for Docker build but as it is the Dockerfile is not being discovered by the pipeline : https://forum.gitlab.com/t/where-is-the-dockerfile-located-when-its-configured-to-generate-dynamically/70457
Hoang Tran
@hoangduytranuk_gitlab
I kept getting pipeline #number has failed. This is my first time with gitlab. Could someone please explain what do I have to do to create a success 'Pull Request'. I forked the Inkscape git repository, then do git checkout on my local machine, created a branch for changes, switch to that branch, done some editing to a file, the commit changes, push the changes to the online forked git repository and I got 'Pipeline ... has failed'. Can someone explain as to what I have to do next?
mfilipe
@mfilipe:matrix.org
[m]
it worked! :D
I didn't want to set many variables in ci/cd because I will need to set many variables like STAGING_* and PRODUCTION_*
Joost Evertse
@joustie:matrix.org
[m]
Hi all! Is there anyone here with the same situation: We have a big GitLab installation and are creating a 1st line support team. They need access to all kinds of settings (all settings for a project is one example)but we don't want to give them ownership or admin rights. I used to handle this by creating a bot or web page and an admin token. But maybe this is not needed anymore. Has anyone found a new way to tackle this ?
8 replies
Brad Vrabete
@allwayswithyou_gitlab
Hi there, I am building my apps through Microsoft App Center. I have been doing that for the last couple of years and it works fine. In the last week I am getting intermittent errors in that pipeline
Git fetch failed with exit code 128, back off <whatever> seconds before retry.
I start thinking there must be something on GitLab's side: is my account not allowed to do such an integration? What else can I look for?
3 replies
Alejandra Diaz Rojas
@alejadzr
Hello!. Im trying to access to the analytics section but Im getting the message "Only Reporter roles and above on tiers Premium / Silver and above can see Productivity Analytics." I have a Reporter role.
4 replies
Balaganesh MURUGAN
@bala_ganesh_gitlab
Hello Team
AM facing some errorrs in gitlab pipeline
image.png
1 reply