Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
Basile Chandesris
@good92
context: monorepo case
Anshul Riyal
@anshulriyal_gitlab
Screenshot 2022-05-31 at 9.04.41 PM.png
1 reply
Golide
@tshumaed_twitter
hello @all I am stuck on an issue where I am generating Dockerfile for projects on the fly (if not already existing). I am using Kaniko for Docker build but as it is the Dockerfile is not being discovered by the pipeline : https://forum.gitlab.com/t/where-is-the-dockerfile-located-when-its-configured-to-generate-dynamically/70457
Hoang Tran
@hoangduytranuk_gitlab
I kept getting pipeline #number has failed. This is my first time with gitlab. Could someone please explain what do I have to do to create a success 'Pull Request'. I forked the Inkscape git repository, then do git checkout on my local machine, created a branch for changes, switch to that branch, done some editing to a file, the commit changes, push the changes to the online forked git repository and I got 'Pipeline ... has failed'. Can someone explain as to what I have to do next?
mfilipe
@mfilipe:matrix.org
[m]
it worked! :D
I didn't want to set many variables in ci/cd because I will need to set many variables like STAGING_* and PRODUCTION_*
Joost Evertse
@joustie:matrix.org
[m]
Hi all! Is there anyone here with the same situation: We have a big GitLab installation and are creating a 1st line support team. They need access to all kinds of settings (all settings for a project is one example)but we don't want to give them ownership or admin rights. I used to handle this by creating a bot or web page and an admin token. But maybe this is not needed anymore. Has anyone found a new way to tackle this ?
8 replies
Brad Vrabete
@allwayswithyou_gitlab
Hi there, I am building my apps through Microsoft App Center. I have been doing that for the last couple of years and it works fine. In the last week I am getting intermittent errors in that pipeline
Git fetch failed with exit code 128, back off <whatever> seconds before retry.
I start thinking there must be something on GitLab's side: is my account not allowed to do such an integration? What else can I look for?
3 replies
Alejandra Diaz Rojas
@alejadzr
Hello!. Im trying to access to the analytics section but Im getting the message "Only Reporter roles and above on tiers Premium / Silver and above can see Productivity Analytics." I have a Reporter role.
4 replies
Balaganesh MURUGAN
@bala_ganesh_gitlab
Hello Team
AM facing some errorrs in gitlab pipeline
image.png
1 reply
Olga
@osmolyar

Hi, I'm trying to set up selenium tests with GitLab CI, but the tests fail without creating any artifacts or console logging from inside the steps or describes (though there is some logging from inside a file imported by the config file). The job output looks like this

npm run confidence-check --host=selenium__standalone-chrome
    wdio testConfig/conf.js --cucumberOpts.tagExpression @testlogin
    Execution of 3 workers started at 2022-06-07T18:52:19.086Z
    [0-0] RUNNING in chrome - /features/Login.feature
    [0-0] FAILED in chrome - /features/Login.feature
    Spec Files: 0 passed, 1 failed, 2 skipped, 3 total (100% completed) in 00:00:02
    Uploading artifacts for failed job
    Uploading artifacts...
    e2e/errorShots: found 1 matching files and directories (these directories are all empty)
    e2e/testResults: found 1 matching files and directories
    e2e/allure-report: found 1 matching files and directories
    Uploading artifacts as "archive" to coordinator... 201 Created id=400 responseStatus=201 Created token=K2Lx3dVt
    Cleaning up project directory and file based variables
    ERROR: Job failed: exit code 1

And the pipeline stage looks like this:

e2e:chrome:
  image: node:lts-alpine3.14
  stage: confidence-check
  services:
    - selenium/standalone-chrome
  script:
    - echo "====== Change to test directory ======"
    - cd e2e
    - echo "====== Install python ======"
    - apk add --update --no-cache py-pip
    - echo "====== Set up python build envt ======"
    - apk add python3 make g++
    - echo "====== Install dependencies ======"
    - npm install --legacy-peer-deps
    - echo "====== Create directories ======"
    - mkdir testResults
    - mkdir errorShots
    - mkdir allure-results
    - mkdir allure-report
    - echo "====== Run tests ======"
    - npm run confidence-check --host=selenium__standalone-chrome
    - allure generate -c ./allure-results -o ./allure-report

  artifacts:
    when: always
    paths:
      - e2e/errorShots
      - e2e/testResults
      - e2e/allure-report

(Ref. https://stackoverflow.com/questions/72545171/gitlab-ci-pipeline-not-producing-test-artifacts-from-webdriverio-tests)

tkreuder
@tkreuder

Hi! I am trying to migrate from S3 terraform state to gitlab terraform state and get:

POST https://gitlab.com/api/v4/projects/XXX/terraform/state/qm-environment-cluster/lock Acquiring state lock. This may take a few moments... Error: Error acquiring the state lock Error message: HTTP remote state endpoint invalid auth

So the state is not locked, as the UI allows me to lock it. What is the reason for HTTP remote state endpoint invalid auth
tkreuder
@tkreuder
Found the reason: The gitlab token did not have enough rights.
1 reply
berjan b
@berjanb_gitlab
Hi, Folks
is there any on you using Gitlab SelfHosted + EKS with AUto Devops feature?
Mrinal Purohit
@bemrinal_gitlab
Hi all, Need some help: How do we force the pipeline to build the artifacts "FROM" specific branch?
Constantinos Symeonides
@con.symeonides_gitlab

Is there an issue currently with the Dependency Proxy? I've been getting intermittent CI job failures with errors like this:

ERROR: Job failed: failed to pull image "gitlab.com:443/<redacted>/dependency_proxy/containers/docker:20.10.7-dind" with specified policies [always]: Error response from daemon: received unexpected HTTP status: 500 Internal Server Error (manager.go:203:0s)

I've also had failures when trying to build an image that uses the dependency proxy in its FROM.

2 replies
Russell Jacobs
@russell51_gitlab
image.png
Hi folks,
Is there an API documented or not which allows us to modify the new General pipeline settings introduced in v15. As an example I want to programmatically change the above option in screenshot.
1 reply
guyzmo
@guyzmo
Hello, it's been a few days I've been trying to buy CI minutes, and it's failing. I opened a support ticket, but I cannot make the payment. I tried with different working cards.
1 reply
is anybody aware of the issue?
Cosmi
@cosmi310599
Hi everyone, why can't I add a group to a repository? In the dropdown list that appears when you want to invite a group on a specific repository I have 'group/subgroup' but not te group onlly.... https://imgur.com/a/uoH09Zs I mean, my group name is 'joifilabs' and inside I have more subgroups...a few months ago I could add 'joifilabs' only to any repository but now I can't....appears 'joifilabs/subgroup' only
Could it be something related with group settings or user permissions? because I also have tried to change the max role from maintainer to owner and it remains the same...
Constantinos Symeonides
@con.symeonides_gitlab

Is there a way to customise the schedule of the Container Registry Cleanup job?

For context, we use the Docker Registry HTTP API to create a new tag for an existing image without having to pull and push the image.

This morning an image that was tagged in this way disappeared mysteriously from the registry, and it was at about the same time that the Cleanup job ran.

This might be a bug with the cleanup job, but I'm not sure how to give you a reproducible bug report if I can't control when the job runs! (and also if I can ensure the job runs during the night, it won't be a problem anymore)

Leo
@leonidas-o
Hello guys, when starting up gitlab using docker (docker-compose), is it possible to set some of the gitlab.rb variables via environment variables from the host? So let's say, I define a ROOT_PASSWORD=foo on the host system, now in the docker-compose I would like to use that env var so its value is used for gitlab_rails['initial_root_password']. This is defined in: https://docs.docker.com/compose/environment-variables/#pass-environment-variables-to-containers
so you can pass env vars into the containers. The question is, how is it for GITLAB_OMNIBUS_CONFIG as this is a multiline string. Tried the following, but without success. The root password was not set, instead I had to lookup and use the generated initial_root_password file.
version: '3.6'
services:
  web:
    image: 'my-registry/dh/gitlab/gitlab-ee:15.0.3-ee.0'
    restart: always
    hostname: 'gitlab.example.com'
    environment:
      SMTP_PASSWORD:
      ROOT_PASSWORD:
      GITLAB_OMNIBUS_CONFIG: |
        external_url 'https://gitlab.my-domain.com'
        ...
        gitlab_rails['smtp_password'] = ENV['SMTP_PASSWORD']
        gitlab_rails['initial_root_password'] = ENV['ROOT_PASSWORD']
        ...
Leo
@leonidas-o
looks like you have to set them, leaving empty will not pass them, which is strange. Using ROOT_PASSWORD: ${ROOT_PASSWORD:} works.
mconstant
@mconstant:matrix.org
[m]
how can I immediately delete a subgroup using the API?
I do not want the delete to be deferred... I am sure I do not want to restore the subgroup
tangtangli
@tangtangli
I have a question,when i use command to set global webhook,how can i set webhook's trigger,it default is push event.help,please,that's command [gitlab-rake gitlab:web_hook:add URL="http://example.com/hook"]
mconstant
@mconstant:matrix.org
[m]
Tomislav Simnett
@simmerz
How can I get the review app for a given merge request in the API?
lfvjimisola
@lfvjimisola
Is it possible to approve and merge a MR without having it close automatically?
1 reply
stdedos
@stdedos:matrix.org
[m]
Hello there!
Can I somehow run the pages job (https://docs.gitlab.com/ee/ci/yaml/#pages) on every branch and MR, and have them accessible somewhere "quickly", and never clobber the master pages?
1 reply
sgfgdf
@sgfgdf_twitter
hello, if i use the image property in my ci/cd pipeline to denote specific image how the docker container will get access to the current project codebase?
9 replies
mconstant
@mconstant:matrix.org
[m]
how can I immediately delete a subgroup using the API?
4 replies
Golide
@tshumaed_twitter
hello @all I need to setup Gitlab-Vault integration. as step 1 i need to exec into the vault pod and setup JWT auth but Im not sure the values to use for my gitlab instance:
command to run in vault pod is :
vault write auth/jwt/config \
jwks_url="https://gitlab.example.com/-/jwks" \
bound_issuer="gitlab.example.com"
Not really sure what to use but I can access one of my project files at this url : https://swdfbc.zw.fbcholdings.com/microplan/devops/labs
What is the recommended scheme actually ? Is it :
vault write auth/jwt/config jwks_url="https://gitlab.<base_domain>:<port>/-/jwks" bound_issuer="gitlab.<base_domain>"
Golide
@tshumaed_twitter
or the one that is here https://docs.gitlab.com/ee/ci/secrets/
mconstant
@mconstant:matrix.org
[m]
@marshmn:
Yes. I asked earlier. There was no response earlier. It holds the deletion for later.
I need it to be removed immediately as part of other automation I am doing. With the UI you can force immediate deletion. It is not intuitive, but you can delete twice or do it a handful of other ways. I have a hunch you can immediately delete through the API in an undocumented manner.
4 replies
J矇r繫me Reybert
@jreybert_gitlab

hello, I have an issue with submodules and gitlab-runner.
I have a project with submodules, and recursive submodules, like:
top/sub-a/subsub-a
top/sub-b/subsub-a

This project runs CI since few month, without any issue. but today, I want to remove top/sub-b/subsub-a. and I get this error during repo intialization in CI:

fatal: No url found for submodule path 'top/sub-b/subsub-a' in .gitmodules
fatal: run_command returned non-zero status while recursing in the nested submodules of top/sub-b

Initially, GIT_STRATEGY is set to fetch. If I set GIT_STRATEGY to clone, it fixes the issue for this particular runner. But I have several runners, and I can't force the choice of the runner.

So:

  • it seems to be a gitlab issue around submodules
  • is there any way to wipe already cloned project for this specific project on all the runners?
4 replies
mconstant
@mconstant:matrix.org
[m]
I certainly dont
Was sure I wanted them deleted and felt the API should allow you to have that kind of shoot-your-self-in-the-foot power. At least as an option.
1 reply
robertoamoreno
@robertoamoreno
Anybody migrated from clickup to Gitlab ?
3 replies