Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
mconstant
@mconstant:matrix.org
[m]
how can I immediately delete a subgroup using the API?
4 replies
Golide
@tshumaed_twitter
hello @all I need to setup Gitlab-Vault integration. as step 1 i need to exec into the vault pod and setup JWT auth but Im not sure the values to use for my gitlab instance:
command to run in vault pod is :
vault write auth/jwt/config \
jwks_url="https://gitlab.example.com/-/jwks" \
bound_issuer="gitlab.example.com"
Not really sure what to use but I can access one of my project files at this url : https://swdfbc.zw.fbcholdings.com/microplan/devops/labs
What is the recommended scheme actually ? Is it :
vault write auth/jwt/config jwks_url="https://gitlab.<base_domain>:<port>/-/jwks" bound_issuer="gitlab.<base_domain>"
Golide
@tshumaed_twitter
or the one that is here https://docs.gitlab.com/ee/ci/secrets/
mconstant
@mconstant:matrix.org
[m]
@marshmn:
Yes. I asked earlier. There was no response earlier. It holds the deletion for later.
I need it to be removed immediately as part of other automation I am doing. With the UI you can force immediate deletion. It is not intuitive, but you can delete twice or do it a handful of other ways. I have a hunch you can immediately delete through the API in an undocumented manner.
4 replies
JΓ©rΓ΄me Reybert
@jreybert_gitlab

hello, I have an issue with submodules and gitlab-runner.
I have a project with submodules, and recursive submodules, like:
top/sub-a/subsub-a
top/sub-b/subsub-a

This project runs CI since few month, without any issue. but today, I want to remove top/sub-b/subsub-a. and I get this error during repo intialization in CI:

fatal: No url found for submodule path 'top/sub-b/subsub-a' in .gitmodules
fatal: run_command returned non-zero status while recursing in the nested submodules of top/sub-b

Initially, GIT_STRATEGY is set to fetch. If I set GIT_STRATEGY to clone, it fixes the issue for this particular runner. But I have several runners, and I can't force the choice of the runner.

So:

  • it seems to be a gitlab issue around submodules
  • is there any way to wipe already cloned project for this specific project on all the runners?
4 replies
mconstant
@mconstant:matrix.org
[m]
I certainly don’t
Was sure I wanted them deleted and felt the API should allow you to have that kind of shoot-your-self-in-the-foot power. At least as an option.
1 reply
robertoamoreno
@robertoamoreno
Anybody migrated from clickup to Gitlab ?
3 replies
James Robb
@jamesrobb
Basic question, but I was wondering about timeouts per-stage or per-pipeline. Everything I read seems to suggest it is only possible to set times on a per-job basis. Is it at all possible to set a timeout at the pipeline level? That is, irrespective of how many jobs or stages there are in the pipeline, I'd like the pipeline to terminate if it hasn't completed in an hour.
Jonathan Mercier
@jmercier:matrix.org
[m]
hi gitlab users and team, I encounter a problem with a kubernetes gitlab-runner. I do not unerstand why the error below occurs
it is strange as this error come from only on one of the two tasks
those 2 tasks match the same gilab-runner as they are tagged
Jonathan Mercier
@jmercier:matrix.org
[m]
gitlabUrl: "https://gitlab.foo.fr/"
imagePullPolicy: IfNotPresent
unregisterRunners: true
concurrent: 2
checkInterval: 10


## Configure integrated Prometheus metrics exporter
## ref: https://docs.gitlab.com/runner/monitoring/#configuration-of-the-metrics-http-server
metrics:
  enabled: true
  service:
    enabled: true
  serviceMonitor:
    enabled: true

## Configuration for the Pods that that the runner launches for each new job
##
runners:
  ## Default container image to use for builds when none is specified
  ##
  image: rockylinux:8.5

  privileged: true
  tags: "privileged,large"
  runUntagged: false

  ## Configure environment variables that will be injected to the pods that are created while
  ## the build is running. These variables are passed as parameters, i.e. ,
  ## to  command.
  ##
  ## Note that  (see below) are only present in the runner pod, not the pods that are
  ## created for each build.
  ##
  ## ref: https://docs.gexport NAMESPACE="gitlab"itlab.com/runner/commands/#gitlab-runner-register
  ##
  env:
    HOME: /tmp

  config: |
    [[runners]]
      [runners.kubernetes]
        privileged = true
        # build container
        cpu_limit = "2"
        memory_limit = "5Gi"
        # service containers
        service_cpu_limit = "1"
        service_memory_limit = "1Gi"
        # helper container
        helper_cpu_limit = "1"
        helper_memory_limit = "1Gi"
      [runners.kubernetes.volumes]
        [[runners.kubernetes.volumes.host_path]]
          name = "var-dbus"
          host_path = "/var/run/dbus"
          mount_path = "/var/run/dbus"
          read_only = false
        [[runners.kubernetes.volumes.host_path]]
          name = "run-dbus"
          host_path = "/run/dbus"
          mount_path = "/run/dbus"
          read_only = false


## Configure environment variables that will be present when the registration command runs
## This provides further control over the registration process and the config.toml file
## ref: 
## ref: https://docs.gitlab.com/runner/configuration/advanced-configuration.html
##
envVars:
  - name: HOME
    value: /home/gitlab-runner
Jonathan Mercier
@jmercier:matrix.org
[m]
I think I found, itwas fail2ban which though that k8 gitlab-runner was bots
West Farmer
@guogangfan_gitlab
hello, gitlab show wrong diffs when create merge request, how can I debug this problem ?
1 reply
Brendan Miller-Young
@Prazon_gitlab
hey, I just upgraded my groups gitlab plan but its not updating, how long does it usually take
Gabriel
@Gabriel_Ziaja_gitlab
Hey! My ticket is stuck in gitlab support and I have pretty urgent matter - I'm using a free plan, but want to upgrade storage for my repository. The thing is - I can't pay. After submitting the payment I get a generic "error with payment step" information, and no idea what to do. The CC data is correct, all fields are filled, captcha is correct - does anyone know what could be the matter here? I have four people working on the project and currently no one can push :/
zillemarco
@zeb994:matrix.org
[m]
@cbacharakis_gitlab: @Gabriel_Ziaja_gitlab just posted this question over on the discord server but I asked him to post is again in here to get better visibility from the GitLab team. Could you please ping the right people to help him out? πŸ™‡πŸ™‚
Christos Bacharakis
@cbacharakis_gitlab
@Gabriel_Ziaja_gitlab Sorry to hear that, do you have a link/ticket number?
Gabriel
@Gabriel_Ziaja_gitlab
Hi Christos, here you go - #304441
Christos Bacharakis
@cbacharakis_gitlab
@Gabriel_Ziaja_gitlab this is a link to GitHub
2 replies
Filipe Abrahao
@luiz-filipe
Quick question, is there any way to lock an environment variable, so other pipelines that inherit templates can't disable some jobs?
1 reply
Dmitriy Panasyuk
@dajest:matrix.org
[m]
Good morrning. Can you tell me please - is there any other way to get in to my gitlab account if I've lost 2 factor auth app and all recovery codes? I just have access to my Email. Can do password change fe, but this is not enought to get in to account.
espadav8
@espadav8:matrix.org
[m]
You will need to open a support request. There is a process but I can take some time
1 reply
Dmitriy Panasyuk
@dajest:matrix.org
[m]
Many Thanks )
Screenshot 2022-07-11 at 17.25.18.png
unit test report should be available, but it doesn't work for me
and about coverage report problem with .gitlab-ci.yml
zillemarco
@zeb994:matrix.org
[m]

Hi @alex.grigurko_gitlab πŸ‘‹

The first feature (unit tests reports) should be avaiable but behing a Feature Flag as of 13.0
About code coverage history, it is available as .csv in 13.0 but the graph was introduced only in 13.1
Test coverage visualization should also be behing a feature flag in 13.0 as the flag was removed only in 13.5

Those are mentioned under the "Version history" toggle just under the the title πŸ™‚
Alex Grigurko
@alex.grigurko_gitlab
@zeb994:matrix.org Thanks for the reply :)
1 reply
mfilipe
@mfilipe:matrix.org
[m]
Hey! I have a .gitlab-ci.yml with tree jobs: storybook, coverage and pages. The jobs storybook and coverage create a static web page and save as an artifact. In the pages job, the static web pages generated are moved to public/ (ex.: storybook/ moves public/<branch-name>/storybook). The problem is when the pipeline runs in main, just public/main/ is in the artifact but when it runs in another branch I can see many branches like public/<branch-name>/. I have no idea why this behavior is happening.
1 reply
mfilipe
@mfilipe:matrix.org
[m]
basically if you use gitlab-15, there is an option to overcome this problem
Ellis Percival
@flyte_gitlab
sometimes you get garbage like on that page, and sometimes you get a content encoding error like here https://docs.gitlab.com/ee/ci/testing/unit_test_reports.html#view-unit-test-reports-on-gitlab
zillemarco
@zeb994:matrix.org
[m]
Yup, I see them broken too
Ellis Percival
@flyte_gitlab
I'm intrigued to know how that's happened. Quite a bizarre issue
zillemarco
@zeb994:matrix.org
[m]
Though looks like they are already investigating some errors from the group runner page
Maybe this is related
stdedos
@stdedos:matrix.org
[m]
Hello there! Is it possible to move the "reporter" of an https://gitlab.com/gitlab-org/gitlab/-/issues/ issue to another account? (both mine, but I'd like to move the issue on my "permanent" personal account)
stdedos
@stdedos:matrix.org
[m]
Can someone explain to me how does this https://docs.gitlab.com/ee/ci/environments/#stop-an-environment-when-a-merge-request-is-merged-or-closed work? I understand auto_stop_in: 1 week, but I don't get how the Merged trigger works πŸ˜•
3 replies