Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Philip Arndt
@parndt
thank you very much
Andrea Dal Ponte
@dalpo
thanks to you..
David Cortés
@davebcn87
Hello, I just installed globalize and the locale is ignored. When I access an attribute of my model y get this SQL:
SELECT "recipe_translations".* FROM "recipe_translations" WHERE "recipe_translations"."recipe_id" = $1 [["recipe_id", 74]]
there is no filter for specific locale, what can I do?
David Cortés
@davebcn87
I think that when I have a model translated work ok, but I don't receive nil objects when a model is not translated in specific language. I have tried to set fallbacks to false but that does not work...
Andrea Dal Ponte
@dalpo
Andrea Dal Ponte
@dalpo
@parndt I started to work on the test coverage for mysql and postgres. I hope to fix all specs soon on the CI.
In the meanwhile any reviews/suggestions are welcome :smile:
Philip Arndt
@parndt
@dalpo thank you :D unfortunately I'm lacking time to suggest!
Andrea Dal Ponte
@dalpo
@parndt no problem :wink:
folivi
@FoliviFooFou_twitter
This message was deleted
This message was deleted
Andrea Dal Ponte
@dalpo
@parndt The next week I'm going to work on the test suite ;)
Philip Arndt
@parndt
:+1:
Hervé Leroy
@Ecdys
Hello thee
I would like to know if Globalize can handle field that is hash (with serialize :field, Hash) ?
Is there anybody here ?
Jakub Kuchar
@kjakub
Does anybody know how can i check if all attributes of record is translated under specific locale ?
Andrea Dal Ponte
@dalpo
@kjakub you could try count the records with something like this:
MyModel.count == MyModel.with_locale(:it).count
Jakub Kuchar
@kjakub
@dalpo thanks for response, but i mean - indicator if all listed attributes translates :name, :desc for record are translated ..something like not nils, not blank strings
Chris Salzberg
@shioyama
Hey @/all would be great to get some input on this change: globalize/globalize#560
Nicolai Seerup
@casiodk
I´m getting this error
ruby-2.3.1: (develop)$ bin/rspec
DEPRECATION WARNING: alias_method_chain is deprecated. Please, use Module#prepend instead. From module, you can access the original method using super. (called from <top (required)> at /Users/nicolaiseerup/Sites/Soundtracktor/soundtracktor-api/config/environment.rb:5)
DEPRECATION WARNING: before_filter is deprecated and will be removed in Rails 5.1. Use before_action instead. (called from <top (required)> at /Users/nicolaiseerup/Sites/Soundtracktor/soundtracktor-api/spec/rails_helper.rb:9)
DEPRECATION WARNING: before_filter is deprecated and will be removed in Rails 5.1. Use before_action instead. (called from <top (required)> at /Users/nicolaiseerup/Sites/Soundtracktor/soundtracktor-api/app/controllers/application_controller.rb:2)
Run options: include {:focus=>true}

Randomized with seed 27854
Daemon has started successfully

An error occurred in a `before(:suite)` hook.
Failure/Error: DatabaseCleaner.clean_with(:truncation)

ActiveRecord::StatementInvalid:
  PG::ConnectionBad: PQsocket() can't get socket descriptor:           SELECT schemaname || '.' || tablename
            FROM pg_tables
            WHERE
              tablename !~ '_prt_' AND
              tablename <> 'schema_migrations' AND
              schemaname = ANY (current_schemas(false))
# /Users/nicolaiseerup/.rvm/gems/ruby-2.3.1/gems/activerecord-5.0.0.1/lib/active_record/connection_adapters/postgresql_adapter.rb:598:in `async_exec’
Is there any trouble with using database_cleaner and globalize
Piotr Pawlik
@papiozo_twitter
Hey, I am trying to implement uniqueness validation. Using latest globalize version and my app in on Rails 5.
I tried validates :label, uniqueness: true
this should work
tried suggested answers from Internet as well, like:
translate_class.class_eval do
   validates :label, uniqueness: true
end
any ideas how to do that?
Noel Worden
@noelworden
Hello! Im trying to create custom URLs and in that process I need to eliminate the en/ that is created with the globalization gem. Ive dug around, but havent come up with any solutions yet...
Sajeetharan
@sajeetharan
console.log(Globalize.translate('Hi my name is sajeetharan'));
why above does not work?
VIVEK DABHI
@vivekdabhi
how to set language forum..?
i have used the globalize gem file in rails 5 but how to set language module..?
Alberto Priore
@albertopriore
I'm trying to update multiple translated fields for multiple nested attributes in one only form. But, only when I update the default language with a new changed text, it will update also the other languages. If I update other language than the default it do not save the content. What could be wrong in my config?
Philip Arndt
@parndt
@shioyama exciting times
Simon Knoll
@simonknoll
Hello, is it save to use globalize on a rails5 project?
Anson Hoyt
@ansonhoyt
@simonknoll we've been using it on Rails 5 just fine, but were tracking master until 5.1.0.beta1 was released. There were some issues with the latest stable for us.
Philip Arndt
@parndt
@ansonhoyt how is the latest beta?
Anson Hoyt
@ansonhoyt
@parndt the latest beta has been working fine as far as I've noticed. No issues.
mariamelm2
@mariamelm2
This message was deleted
Belibaste
@Belibaste_twitter
Hi guys, having trouble with Globalize and Friendly ID: when I restart my app, everything is fine, but after a few minutes, urls are back to the classic id, I don't understand why
Rails 4 on Heroku, everything up to date, including gem 'friendly_id-globalize'
Chris Salzberg
@shioyama
Globalize is no longer compatible with FriendlyId using the friendly_id-globalize gem, see: https://github.com/globalize/globalize/issues/543#issuecomment-268115937
The gem and FriendlyId itself do not seem to be maintained, and maintaining support on Globalize side would be painful.
Belibaste
@Belibaste_twitter
I did not realize that. What is weird is it work at start everywhere, but stop working after a while just for one model... I am willing to contribute to open source project, but pretty new at this so do you think it is worth it to try to fix the gem ? Edit: thanks for your time :-)
Andy Chung
@gehsekky
hey all
is this lib compatible with webpack?
nvm, just found this thread