Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
  • Sep 08 19:14
    quentinlesceller closed #3657
  • Sep 08 19:14
    quentinlesceller closed #3656
  • Sep 08 14:58
    953075867 opened #3657
  • Sep 08 14:57
    953075867 opened #3656
  • Sep 07 08:12
    CRY0NE3 commented #1135
  • Aug 19 08:53
    quentinlesceller opened #3655
  • Aug 19 08:53
    quentinlesceller labeled #3655
  • Aug 19 07:06

    quentinlesceller on master

    bump to 5.2.0-alpha.1 on master… (compare)

  • Aug 19 07:06
    quentinlesceller closed #3652
  • Aug 19 06:49
    quentinlesceller synchronize #3652
  • Aug 18 13:46

    quentinlesceller on v5.1.1


  • Aug 18 13:45

    quentinlesceller on master

    Change connection name for CI R… (compare)

  • Aug 18 13:45
    quentinlesceller closed #3653
  • Aug 18 13:41

    quentinlesceller on v5.1.1


  • Aug 18 12:53
    quentinlesceller edited #3653
  • Aug 18 12:53
    quentinlesceller opened #3653
  • Aug 17 20:49
    quentinlesceller opened #3652
  • Aug 17 20:45

    quentinlesceller on v5.1.1


  • Aug 17 18:57

    quentinlesceller on master

    Tagging v5.1.1 release (#3651) (compare)

  • Aug 17 18:57
    quentinlesceller closed #3651

I agree @bladedoyle there are many teams and channels. The intention when we set it up was to allow wallet dev and node dev work to proceed more independently, possibly with different people engaging where they were more interested.

Now after it’s been running for a while we can ask ourselves whether it’s really necessary at this stage and whether it would be more beneficial for development work to have a single team with different channels instead?

Dunno, I can see merit to both approaches tbh. At least now that we’ll try to migrate gradually away from gitter we’ll have one place less to check!

John Tromp
Floonet HF latest estimation: a few minutes ago
it forked?
John Tromp
sure did
sorry to bother you up : grin-wallet3.0beta2 init_send_tx what is the token?
i send ""token":null" but the responce is ""message": "ExtraNamedParameter token""
curl --user grin:supersecretpw -i http://localhost:3413/v2/owner/get_status
HTTP/1.1 404 Not Found
What am I missing? I'm assuming I have to create .api_secretwhere the binary is?
the api.md says that the password is in .api_secret
the subcommands on grin client work though. Btw, is it expected that out of 20 peers I'm connected to, 9 of them are on 2.X version?
just to update, I've found the .api_secret and I use it but I'm still getting 404
Blade Doyle
@phyro the V2 API uses JSON RPC so you have to pass the query as JSON data.
ex: curl -ugrin:$secret -s -d '{"jsonrpc":"2.0","method":"get_status","params": [], "id": 1 }' http://localhost:3413/v2/owner
@bladedoyle my bad, thought it was REST, thanks!
I've banned 11 peers due to FraudHeight today. Is this expected?
@quentinlesceller how to access grin_wallet owner_api from another PC?
i found it only support local
@phyro same with me, all day every day. I rebuilt from latest master and get the same result
then i often find it suggesting it isnt fully sync'd
I've been told that the bans are not something to be very concerned about, especially during initial sync (but I rebuilt 6 days ago or so and everything persisted)
(it has said that it was running and fully sync'd multiple times and this status reappears)
Blade Doyle
@1971192997 Loopback address is hard coded and no confirmation option exists. You will have to edit the source code and rebuild to get it to listen on the public interface.
yeah got it thanks @bladedoyle
Hey, just wanted to check back if there is already a date when v3 will be released - since we only got 15 days to go until the fork :)

Hey guys, 2 questions regarding grin-wallet 3.0 - hoping I could get some help/feedback on them:

1). Having this issue when sending a grin transaction via RPC

"id": 1,
"jsonrpc": "2.0",
"result": {
"Err": {
"GenericError": "Wallet Communication Error: Tor Configuration required"

The curl command is:

curl -0 -XPOST -u grin:password --data '{ "jsonrpc": "2.0", "method": "init_send_tx", "params": {"args":{"src_acct_name":null, "amount":"500000000", "minimum_confirmations":10, "max_ouputs":500, "num_change_outputs":1, "selection_strategy_is_use_all":true, "message":null, "target_slate_version":null, "estimate_only":null,"payment_proof_recipient_address":null, "ttl_blocks":null, "send_args": {"method":"http", "dest":"http://xxxxxxx.onion", "finalize":true, "post_tx":true, "fluff":false}}}, "id": 1}'

Tor is running, I have a listener and a owner_api process running and have successfully received my tor receiving address when launching 'grin-wallet -e listener'

2). Is there a way to direct the tor process grin-wallet controls to a directory? For example, packing grin-wallet into an application with a tor executable and specifying that directory instead of checking the system path

@mattt21 this not work without tor too
they change owner api init_send_tx
lol if I read correct

In 2 hours from now (3PM UTC) we're having the first dev meeting of 2020.

We’re conducting the meeting on Keybase rather in this channel.

Instructions for how to join:

  1. Install Keybase (https://keybase.io) and create an account.
  2. Join the grin community:

    • From the app: Select “Teams” » “Join a team” and then type “grincoin”
    • From the command line: keybase team request-access grincoin
  3. Join the #dev channel:
    • From the app: Select “Chat” » “grincoin”, then press the cog wheel » ”Manage chat channels" and tap "#dev"
    • From the command line: keybase chat join-channel grincoin '#dev'

Keybase supports tor and command line access. More instructions and information available here:

@tromp I'm having the same issue that @phyro had, I'm trying to build latest grin-miner and I get
-- Build files have been written to: /root/Developement/grin-miner/target/debug/build/cuckoo_miner-5c210461fdbc31a2/out/build
running: "cmake" "--build" "." "--target" "" "--config" "Debug" "--"
[  1%] Building NVCC (Device) object CMakeFiles/cuckaroom_cuda_29.dir/cuckoo/src/cuckaroom/cuckaroom_cuda_29_generated_mean.cu.o

--- stderr
/root/Developement/grin-miner/cuckoo-miner/src/cuckoo_sys/plugins/cuckoo/src/cuckaroom/mean.cu(534): error: expected a comma (the one-argument version of static_assert is not enabled in this mode)

/root/Developement/grin-miner/cuckoo-miner/src/cuckoo_sys/plugins/cuckoo/src/cuckaroom/mean.cu(535): error: expected a comma (the one-argument version of static_assert is not enabled in this mode)

/root/Developement/grin-miner/cuckoo-miner/src/cuckoo_sys/plugins/cuckoo/src/cuckaroom/mean.cu(536): error: expected a comma (the one-argument version of static_assert is not enabled in this mode)

/root/Developement/grin-miner/cuckoo-miner/src/cuckoo_sys/plugins/cuckoo/src/cuckaroom/mean.cu(537): error: expected a comma (the one-argument version of static_assert is not enabled in this mode)

4 errors detected in the compilation of "/tmp/tmpxft_00001efc_00000000-14_mean.compute_75.cpp1.ii".
CMake Error at cuckaroom_cuda_29_generated_mean.cu.o.Debug.cmake:279 (message):
  Error generating file

gmake[2]: *** [CMakeFiles/cuckaroom_cuda_29.dir/build.make:72: CMakeFiles/cuckaroom_cuda_29.dir/cuckoo/src/cuckaroom/cuckaroom_cuda_29_generated_mean.cu.o] Error 1
gmake[1]: *** [CMakeFiles/Makefile2:72: CMakeFiles/cuckaroom_cuda_29.dir/all] Error 2
gmake: *** [Makefile:84: all] Error 2
thread 'main' panicked at '
command did not execute successfully, got: exit code: 2

build script failed, must exit now', /root/.cargo/registry/src/github.com-1ecc6299db9ec823/cmake-0.1.42/src/lib.rs:861:5
note: run with `RUST_BACKTRACE=1` environment variable to display a backtrace.

warning: build failed, waiting for other jobs to finish...
error: build failed
John Tromp
you can pull it into grin-miner with something like git submodule update --remote --recursive
@tromp This helped, but now I get another
Scanning dependencies of target cuckarood_cuda_29
[ 41%] Building C object CMakeFiles/cuckarood_cuda_29.dir/cuckoo/src/crypto/blake2b-ref.c.o
[ 42%] Linking CXX shared library plugins/cuckarood_cuda_29.cuckooplugin
[ 44%] Built target cuckarood_cuda_29

--- stderr
/root/Developement/grin-miner/cuckoo-miner/src/cuckoo_sys/plugins/cuckoo/src/cuckatoo/mean.cu(209): error: static assertion failed with "TRIM0_TPB must divide BITMAPWORDS"

/root/Developement/grin-miner/cuckoo-miner/src/cuckoo_sys/plugins/cuckoo/src/cuckatoo/mean.cu(211): warning: pointless comparison of unsigned integer with zero

/root/Developement/grin-miner/cuckoo-miner/src/cuckoo_sys/plugins/cuckoo/src/cuckatoo/mean.cu(262): error: static assertion failed with "TRIM1_TPB must divide BITMAPWORDS"

/root/Developement/grin-miner/cuckoo-miner/src/cuckoo_sys/plugins/cuckoo/src/cuckatoo/mean.cu(264): warning: pointless comparison of unsigned integer with zero

/root/Developement/grin-miner/cuckoo-miner/src/cuckoo_sys/plugins/cuckoo/src/cuckatoo/mean.cu(313): error: static assertion failed with "TRIM_TPB must divide BITMAPWORDS"

/root/Developement/grin-miner/cuckoo-miner/src/cuckoo_sys/plugins/cuckoo/src/cuckatoo/mean.cu(315): warning: pointless comparison of unsigned integer with zero

3 errors detected in the compilation of "/tmp/tmpxft_00003e25_00000000-14_mean.compute_75.cpp1.ii".
CMake Error at cuckatoo_mean_cuda_19_generated_mean.cu.o.Debug.cmake:279 (message):
  Error generating file

gmake[2]: *** [CMakeFiles/cuckatoo_mean_cuda_19.dir/build.make:65: CMakeFiles/cuckatoo_mean_cuda_19.dir/cuckoo/src/cuckatoo/cuckatoo_mean_cuda_19_generated_mean.cu.o] Error 1
gmake[1]: *** [CMakeFiles/Makefile2:442: CMakeFiles/cuckatoo_mean_cuda_19.dir/all] Error 2
gmake[1]: *** Waiting for unfinished jobs....
gmake: *** [Makefile:84: all] Error 2
thread 'main' panicked at '
command did not execute successfully, got: exit code: 2

build script failed, must exit now', /root/.cargo/registry/src/github.com-1ecc6299db9ec823/cmake-0.1.42/src/lib.rs:861:5
note: run with `RUST_BACKTRACE=1` environment variable to display a backtrace.
I'm using
/usr/local/cuda-10.2/bin/nvcc --version
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2019 NVIDIA Corporation
Built on Wed_Oct_23_19:24:38_PDT_2019
Cuda compilation tools, release 10.2, V10.2.89

cat /etc/redhat-release
CentOS Linux release 7.7.1908 (Core)

uname -a
Linux localhost.localdomain 3.10.0-1062.9.1.el7.x86_64 #1 SMP Fri Dec 6 15:49:49 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
John Tromp
ok, pondering a fix
John Tromp
in cuckoo-miner/src/cuckoo_sys/plugins/CMakeLists.txt, can you comment out line 104 for building cuckatoo_mean_cuda_19 ?
and let me know if that causes problems?
@tromp This solved the compilation problem. Thank you! Now I have runtime problem
[root@localhost grin-miner]# ./target/debug/grin-miner
Starting Grin-Miner from config file at: /root/Developement/grin-miner/grin-miner.toml
Jan 10 23:32:28.048 INFO This is Grin-Miner version 3.0.0-beta.1 (git v3.0.0-beta.1), built for x86_64-unknown-linux-gnu by rustc 1.40.0.
Jan 10 23:32:28.354 ERRO
thread 'unnamed' panicked at 'called `Option::unwrap()` on a `None` value': src/libcore/option.rs:378stack backtrace:
   0: grin_miner_util::logger::send_panic_to_log::{{closure}}
             at util/src/logger.rs:120
   1: std::panicking::rust_panic_with_hook
             at src/libstd/panicking.rs:468
   2: std::panicking::continue_panic_fmt
             at src/libstd/panicking.rs:373
   3: rust_begin_unwind
             at src/libstd/panicking.rs:302
   4: core::panicking::panic_fmt
             at src/libcore/panicking.rs:139
   5: core::panicking::panic
             at src/libcore/panicking.rs:70
   6: core::option::Option<T>::unwrap
             at /builddir/build/BUILD/rustc-1.40.0-src/src/libcore/macros.rs:41
   7: cuckoo_miner::miner::miner::CuckooMiner::solver_thread
             at cuckoo-miner/src/miner/miner.rs:95
   8: cuckoo_miner::miner::miner::CuckooMiner::start_solvers::{{closure}}
             at cuckoo-miner/src/miner/miner.rs:228
   9: std::sys_common::backtrace::__rust_begin_short_backtrace
             at /builddir/build/BUILD/rustc-1.40.0-src/src/libstd/sys_common/backtrace.rs:129
  10: std::thread::Builder::spawn_unchecked::{{closure}}::{{closure}}
             at /builddir/build/BUILD/rustc-1.40.0-src/src/libstd/thread/mod.rs:469
  11: <std::panic::AssertUnwindSafe<F> as core::ops::function::FnOnce<()>>::call_once
             at /builddir/build/BUILD/rustc-1.40.0-src/src/libstd/panic.rs:317
  12: std::panicking::try::do_call
             at /builddir/build/BUILD/rustc-1.40.0-src/src/libstd/panicking.rs:287
  13: __rust_maybe_catch_panic
             at src/libpanic_unwind/lib.rs:78
  14: std::panicking::try
             at /builddir/build/BUILD/rustc-1.40.0-src/src/libstd/panicking.rs:265
  15: std::panic::catch_unwind
             at /builddir/build/BUILD/rustc-1.40.0-src/src/libstd/panic.rs:396
  16: std::thread::Builder::spawn_unchecked::{{closure}}
             at /builddir/build/BUILD/rustc-1.40.0-src/src/libstd/thread/mod.rs:468
  17: core::ops::function::FnOnce::call_once{{vtable.shim}}
             at /builddir/build/BUILD/rustc-1.40.0-src/src/libcore/ops/function.rs:227
  18: <alloc::boxed::Box<F> as core::ops::function::FnOnce<A>>::call_once
             at /builddir/build/BUILD/rustc-1.40.0-src/src/liballoc/boxed.rs:942
  19: <alloc::boxed::Box<F> as core::ops::function::FnOnce<A>>::call_once
             at /builddir/build/BUILD/rustc-1.40.0-src/src/liballoc/boxed.rs:942
             at src/libstd/sys_common/thread.rs:13
             at src/libstd/sys/unix/thread.rs:79
  20: start_thread
  21: clone

Thread 'unnamed' panicked with message:
"called `Option::unwrap()` on a `None` value"
See grin.log for further details.
Jan 10 23:32:29.238 WARN Connection Status: Connected to Grin server at floonet-stratum.grinmint.com:13416.
Jan 10 23:32:30.010 INFO Got a job at height 320801 and difficulty 4
Jan 10 23:32:31.062 INFO Mining: Cucka*oo* at 0 gps (graphs per second)
Jan 10 23:32:32.003 INFO Got a new job: JobTemplate { height: 320801, job_id: 11, difficulty: 4, pre_pow: "0003000000000004e521000000005e18fb7e30d1db9bb92d3292ee0d8117b21e680200922b7de30a0a87d05aba2592699829e82d09d41b05beabf18f1456be7c7e4d2ac8ce48105a6bde63af1222f6082a8dd402118737bcb53a87e6bf9bee9c50d61a0030b8b7a4d0a348669a561419812280f2986b2b01775a5461c749547f6f60e5ad5ce5360363002ba279e6b0dad60096809fa98f4d7625c0711317ac9bfa499b8b6dd1a615fd9d8b564d6caa484050bcd38d9698f4f8cfbe7e3f643ddf6db159ce69da8c9646270b0c02a5bd37ae4c00000000000c97aa00000000000a9ada000000fe14829e330000000d" }
John Tromp
i'm afraid i can't help with that
it somehow failed to create a solver context
John Tromp
perhaps you can file an issue at https://github.com/mimblewimble/grin-miner/issues

Thank you @tromp You helped me a lot. Maybe somebody else will be able to help me with this one. I have these graphics cards

[root@localhost grin-miner]# nvidia-smi
Fri Jan 10 23:37:32 2020
| NVIDIA-SMI 435.21       Driver Version: 435.21       CUDA Version: 10.1     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  GeForce GTX 106...  Off  | 00000000:0A:00.0  On |                  N/A |
| 33%   30C    P8     6W / 130W |     23MiB /  3016MiB |      0%      Default |
|   1  GeForce RTX 2080    Off  | 00000000:0B:00.0 Off |                  N/A |
|  0%   35C    P8     1W / 225W |      1MiB /  7982MiB |      0%      Default |

| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|    0      1835      G   /usr/bin/X                                    21MiB |

and this miner configuration

# currently requires 6GB GPU memory
plugin_name = "cuckaroom_cuda_29"
#plugin_name = "cuckarood_cuda_29"
# or, prior to 2nd hardfork: plugin_name = "cuckarood_cuda_29"
device = 1
cpuload = 1
ntrims = 399
#ntrims = 31
# or, prior to 2nd hardfork: ntrims = 31
genablocks = 1024
recoverblocks = 2048
recovertpb = 256
I am trying to mine with cuckaroom pow on
# whether to run the tui
run_tui = false

# listening grin stratum server url
#stratum_server_addr = ""
#stratum_server_addr = "eu-west-stratum.grinmint.com:3416"
stratum_server_addr = "floonet-stratum.grinmint.com:13416"

# login for the stratum server (if required)
stratum_server_login = "5647+test@gmail.com/rig1"

# password for the stratum server (if required)
#stratum_server_password = "x"
I'm trying to prepare for the upcoming Grin fork in 2 days for the cuckaroom algorithm. I'm not able to make grin-miner work and I have not managed to get any closed sourced miner that support cuckaroom algo. None of the recommended miners on https://floonet.grinmint.com/help.html support it currently. What miner will people use when the fork actually happen? Does anybody know any miner that currently support cuckaroom algorithm and is able to communicate with stratum pool protocol?
Quentin Le Sceller
@rostfrei currently there is:
Hello guys, I need some help. What is the "token" param in the Grin wallet API v3?
(https://docs.rs/grin_wallet_api/3.0.0/grin_wallet_api/trait.OwnerRpcS.html#) I succeeded in generating the shared public key as well as encrypting the request and decrypting the response, but could not figure out where to find the "token".