These are chat archives for gwtbootstrap3/gwtbootstrap3

25th
Sep 2017
Emre Küçük
@EKUCUKE_twitter
Sep 25 2017 09:21
Hi, how can i resolve the error:
Error: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) : $wnd.jQuery.notify is not a function
<!-- GWT Bootstrap -->
<dependency>
  <groupId>org.gwtbootstrap3</groupId>
  <artifactId>gwtbootstrap3</artifactId>
  <version>0.9.4</version>
  <scope>provided</scope>
</dependency>

 <!-- GWT Bootstrap-extras -->
<dependency>
  <groupId>org.gwtbootstrap3</groupId>
  <artifactId>gwtbootstrap3-extras</artifactId>
  <version>0.9.4</version>
  <scope>provided</scope>
</dependency>

<!doctype html>

<html>
<head>
<title>Phi Software</title>
<script type="text/javascript">
var language = window.navigator.userLanguage || window.navigator.language;
var meta = document.createElement('meta');
meta.name = "gwt:property";
meta.content = "locale="+language;
document.getElementsByTagName('head')[0].appendChild(meta);
</script>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta http-equiv="content-type" content="text/html; charset=UTF-8">
<link type="text/css" rel="stylesheet" href="PhiSoftwareBootstrap.css">
<script type="text/javascript" language="javascript" src="PhiSoftwareBootstrap/PhiSoftwareBootstrap.nocache.js"></script>
</head>

<body>
<iframe src="javascript:''" id="__gwt_historyFrame" tabIndex='-1' style="position:absolute;width:0;height:0;border:0"></iframe>
<noscript>
<div style="width: 22em; position: absolute; left: 50%; margin-left: -11em; color: red; background-color: white; border: 1px solid red; padding: 4px; font-family: sans-serif">
Your web browser must have JavaScript enabled
in order for this application to display correctly.
</div>
</noscript>
</body>
</html>

<!-- GWT Bootstrap -->

<inherits name="org.gwtbootstrap3.GwtBootstrap3"/>
<inherits name="org.gwtbootstrap3.extras.respond.Respond"/>
<inherits name="org.gwtbootstrap3.extras.notify.Notify"/>

Emre Küçük
@EKUCUKE_twitter
Sep 25 2017 11:44
* I use 0.9.3 instead of 0.9.4 and the error gone
Steven Jardine
@sjardine
Sep 25 2017 20:01
Its impossible to debug using glitter....please fork the gwtboostrap3-seed project and modify to show the problem.