These are chat archives for gwydirsam/DickGrayson

21st
Apr 2015
Martin Fracker, Jr.
@Towerism
Apr 21 2015 19:46
In file included from /usr/include/x86_64-linux-gnu/gmp.h:51:0,
                 from /usr/include/gmpxx.h:33,
                 from /home/mfracker/csce/315-15/DickGrayson/lib/rsa-attack-lib/rsa-attack-lib.hh:7,
                 from /home/mfracker/csce/315-15/DickGrayson/bin/rsa-attack/main.cc:9:
/usr/include/c++/4.9/cstddef:51:11: error: ‘::max_align_t’ has not been declared
   using ::max_align_t;
           ^
make[3]: *** [bin/CMakeFiles/rsa-attack.dir/rsa-attack/main.cc.o] Error 1
make[3]: Leaving directory `/home/mfracker/csce/315-15/DickGrayson/build'
make[2]: *** [bin/CMakeFiles/rsa-attack.dir/all] Error 2
make[2]: *** Waiting for unfinished jobs....
In file included from /usr/include/x86_64-linux-gnu/gmp.h:51:0,
                 from /usr/include/gmpxx.h:33,
                 from /home/mfracker/csce/315-15/DickGrayson/lib/dgcrypto/dgrandominteger.hh:3,
                 from /home/mfracker/csce/315-15/DickGrayson/lib/dgcrypto/dgrandominteger.cc:1:
/usr/include/c++/4.9/cstddef:51:11: error: ‘::max_align_t’ has not been declared
   using ::max_align_t;
           ^
In file included from /usr/include/x86_64-linux-gnu/gmp.h:51:0,
                 from /usr/include/gmpxx.h:33,
                 from /home/mfracker/csce/315-15/DickGrayson/lib/rsa-attack-lib/rsa-attack-lib.hh:7,
                 from /home/mfracker/csce/315-15/DickGrayson/lib/rsa-attack-lib/rsa-attack-lib.cc:1:
/usr/include/c++/4.9/cstddef:51:11: error: ‘::max_align_t’ has not been declared
   using ::max_align_t;
           ^
In file included from /usr/include/x86_64-linux-gnu/gmp.h:51:0,
                 from /usr/include/gmpxx.h:33,
                 from /home/mfracker/csce/315-15/DickGrayson/lib/rsa-crypt-lib/rsa-crypt-lib.hh:3,
                 from /home/mfracker/csce/315-15/DickGrayson/lib/rsa-crypt-lib/rsa-crypt-lib.cc:1:
/usr/include/c++/4.9/cstddef:51:11: error: ‘::max_align_t’ has not been declared
   using ::max_align_t;
           ^
In file included from /usr/include/x86_64-linux-gnu/gmp.h:51:0,
                 from /usr/include/gmpxx.h:33,
                 from /home/mfracker/csce/315-15/DickGrayson/lib/dgcrypto/dginteger.hh:3,
                 from /home/mfracker/csce/315-15/DickGrayson/lib/dgcrypto/dginteger.cc:1:
/usr/include/c++/4.9/cstddef:51:11: error: ‘::max_align_t’ has not been declared
   using ::max_align_t;
           ^
In file included from /usr/include/x86_64-linux-gnu/gmp.h:51:0,
                 from /usr/include/gmpxx.h:33,
                 from /home/mfracker/csce/315-15/DickGrayson/lib/dgcrypto/dgrandomprime.hh:3,
                 from /home/mfracker/csce/315-15/DickGrayson/lib/dgcrypto/dgrandomprime.cc:1:
/usr/include/c++/4.9/cstddef:51:11: error: ‘::max_align_t’ has not been declared
   using ::max_align_t;
           ^
In file included from /usr/include/x86_64-linux-gnu/gmp.h:51:0,
                 from /usr/include/gmpxx.h:33,
                 from /home/mfracker/csce/315-15/DickGrayson/bin/rsa-crypt/main.cc:3:
/usr/include/c++/4.9/cstddef:51:11: error: ‘::max_align_t’ has not been declared
   using ::max_align_t;
           ^
make[3]: *** [lib/CMakeFiles/dgcrypto.dir/dgcrypto/dgrandominteger.cc.o] Error 1
make[3]: *** Waiting for unfinished jobs....
/home/mfracker/csce/315-15/DickGrayson/bin/rsa-crypt/main.cc:5:14: warning: unused parameter ‘argc’ [-Wunused-parameter]
 int main(int argc, char *argv[]) {
              ^
/home/mfracker/csce/315-15/DickGrayson/bin/rsa-crypt/main.cc:5:31: warning: unused parameter ‘argv’ [-Wunused-parameter]
 int main(int argc, char *argv[]) {
                               ^
/home/mfracker/csce/315-15/DickGrayson/lib/rsa-attack-lib/rsa-attack-lib.cc: In function ‘mpz_class getNthPrime(mpz_class)’:
/home/mfracker/csce/315-15/DickGrayson/lib/rsa-attack-lib/rsa-attack-lib.cc:99:1: warning: no return statement in function returning non-void [-Wreturn-type]
 }
 ^
/home/mfracker/csce/315-15/DickGrayson/lib/rsa-attack-lib/rsa-attack-lib.cc: At global scope:
/home/mfracker/csce/315-15/DickGrayson/lib/rsa-attack-lib/rsa-attack-lib.cc:103:56: warning: unused parameter ‘n’ [-Wunused-par
Do I have the wrong version of gmp installed or something?
Sam Gwydir
@gwydirsam
Apr 21 2015 19:47
when did you start getting this?
Martin Fracker, Jr.
@Towerism
Apr 21 2015 19:48
Last night. I'm on ubuntu, I had just installed everything via apt-get
Sam Gwydir
@gwydirsam
Apr 21 2015 19:48
hmm
it worked before on the same install?
Martin Fracker, Jr.
@Towerism
Apr 21 2015 19:49
It worked before on korora. I merged with develop last night. But that was after I got this error.
Sam Gwydir
@gwydirsam
Apr 21 2015 19:49
My first bet would be it didn't install gmp with --enable-cxx
Martin Fracker, Jr.
@Towerism
Apr 21 2015 19:49
Ah.
Sam Gwydir
@gwydirsam
Apr 21 2015 19:49
checkout how to package is defined
Martin Fracker, Jr.
@Towerism
Apr 21 2015 19:49
See I believe I had installed gmp via the makefile when i was on korora
I'm just gonna uninstall gmp and build it myself
Sam Gwydir
@gwydirsam
Apr 21 2015 19:50
what version of ubuntu are you using?
and why the switch back?
Martin Fracker, Jr.
@Towerism
Apr 21 2015 19:50
I switched back to ubuntu on my desktop for the better support from amd. I'm still on korora on my laptop
14.04
Sam Gwydir
@gwydirsam
Apr 21 2015 19:51
you probably want something like libgmpxx
Martin Fracker, Jr.
@Towerism
Apr 21 2015 19:51
Ah okay I'll search for it
Sam Gwydir
@gwydirsam
Apr 21 2015 19:51
this one: libgmpxx4ldbl
Martin Fracker, Jr.
@Towerism
Apr 21 2015 19:52
Oh that one was installed. It was automatically installed when I installed gmp
Sam Gwydir
@gwydirsam
Apr 21 2015 19:52
no idea then
go for the makefile if you can't fix the package
Martin Fracker, Jr.
@Towerism
Apr 21 2015 19:52
ALright
Sam Gwydir
@gwydirsam
Apr 21 2015 19:55
I'm ready on skype whenever
btw