Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Oct 04 2018 18:07
    hhff commented #93
  • Oct 04 2018 17:36
    LemonAndroid opened #93
  • May 14 2018 01:18
    edgward closed #32
  • May 14 2018 01:17
    edgward opened #32
  • Mar 29 2017 09:27
    nghiapdx commented #31
  • Mar 29 2017 09:26
    nghiapdx closed #31
  • Mar 29 2017 09:22
    nghiapdx opened #31
  • Jun 29 2016 13:39
    dilpreet92 synchronize #30
  • Jun 29 2016 06:15
    dilpreet92 synchronize #30
  • Jun 27 2016 12:38
    dilpreet92 opened #30
  • Mar 07 2016 20:25
    felixbuenemann commented #11
  • Mar 07 2016 20:22
    felixbuenemann opened #29
  • Mar 07 2016 17:05
    hhff commented #11
  • Mar 07 2016 17:04
    hhff commented #67
  • Mar 07 2016 01:46
    cellis commented #67
  • Mar 05 2016 23:36
    cellis commented #67
  • Mar 04 2016 19:59
    felixbuenemann commented #11
  • Mar 04 2016 19:52
    felixbuenemann commented #11
  • Jan 06 2016 14:29
    hhff commented #88
  • Jan 06 2016 05:23
    baraka2000 commented #88
chris-aeviator
@chris-aeviator
yes
äh
no
wait
Hugh Francis
@hhff
I don't believe you need the active-model-adapter addon if you're using the above version of ember-data
pretty sure it's included
chris-aeviator
@chris-aeviator
found it in my bash history...i've had an error with ember 2.x with that before, I'll try to uninstall it
Hugh Francis
@hhff
is this a brand new application?
like did you just do an ember new
chris-aeviator
@chris-aeviator
yes, I followed the steps on the spree ember site
Hugh Francis
@hhff
ok
so what you should do
is to start again
chris-aeviator
@chris-aeviator
ja, good idea
Hugh Francis
@hhff
but this time, get the ember & ember-data versions working before installing spree-ember
chris-aeviator
@chris-aeviator
ok
Hugh Francis
@hhff
that way you know there's nothing wacky going on
should only take an extra 20~ mins
chris-aeviator
@chris-aeviator
can i specify a version on ember new or do I downgrade after this ?
Hugh Francis
@hhff
downgrade after
chris-aeviator
@chris-aeviator
:+1:
chris-aeviator
@chris-aeviator
feels like I'm almost there…next thing:
This message was deleted
The Broccoli Plugin: [SourceMapConcat: Concat: Vendor /assets/vendor.js] failed with:Error: ENOENT: no such file or directory, stat '/Users/xxx/Development/xxx/xxx/frontend/tmp/source_map_concat-input_base_path-odDSJVot.tmp/0/bower_components/ember-data/ember-data.js'
cleared the bower cache and the tmp folder
Hugh Francis
@hhff
wild
chris-aeviator
@chris-aeviator
^^
i'll maybe try a different ember data version?
if i add ember-data to bower.json (has not been there actually) i get Error: Could not find module `ember-data` imported from `spree-ember-core/serializers/spree
Hugh Francis
@hhff
yup ! ember data has to be in bower.json
i think u need to change ember-cli-shims version too
one sec
yup @chris-aeviator u want "ember-cli-shims": "ember-cli/ember-cli-shims#0.0.3",
in bower.json
I'd slowly go through and downgrade the default versions of all these packages until everything is working
chris-aeviator
@chris-aeviator
alright, I'll try that
shims did it…awesome! thanks alot for your amazing work & support :+1:
Hugh Francis
@hhff
haha no problem
happy 2 help :)
SegeyKutsko
@SergeyKutsko
any news
?
SegeyKutsko
@SergeyKutsko
Is project dead?
Hugh Francis
@hhff
@SergeyKutsko project isn't dead, it's stable but I'm not currently maintaining it
still accepting pull requests
SegeyKutsko
@SergeyKutsko
Could you tell last supported EmberJs version?
Hugh Francis
@hhff
@SergeyKutsko
    "ember": "1.12.0",
    "ember-data": "1.0.0-beta.18",
same as the ember versions that are in the 4x package.jsons
have a read of the most recent comments here for downgrading ember-cli to those versions @SergeyKutsko