These are chat archives for highfidelity/hifi

24th
Mar 2014
Stephen Birarda
@birarda
Mar 24 2014 16:31
@ddobrev around?
Dimitar Dobrev
@ddobrev
Mar 24 2014 16:34
@birarda Yes.
Stephen Birarda
@birarda
Mar 24 2014 16:34
can you take a look at this stack trace + @ZappoMan’s comments
Dimitar Dobrev
@ddobrev
Mar 24 2014 16:36
I don't think I'll be able to today. However, when I first saw it about a week ago, I did have a thought about it.
This could happen when mixing debug and release.
QXmpp in debug and the build in release or the other way around.
Windows, MS VC++ in particular, seems to have a problem with it.
I mean, in general.
Stephen Birarda
@birarda
Mar 24 2014 16:37
ahhh
gotcha
@ZappoMan is it possible that was with a release build of qxmpp?
FearghusMcMahon
@FearghusMcMahon
Mar 24 2014 19:54
hi all, silly question perhaps....but how would i turn on the building of voxels on a self run domain server? On alpha i get a white selection square...but locally not.
Andrew Meadows
@AndrewMeadows
Mar 24 2014 20:40
@FearghusMcMahon, you say you're running a local domain-server. You're also running some assignment clients? How many?
FearghusMcMahon
@FearghusMcMahon
Mar 24 2014 21:04
i did the -n 5 for that one
maybe i need to add with another parameter?
Andrew Meadows
@AndrewMeadows
Mar 24 2014 21:24
no, that looks correct
you have "stats" visible in the interface? How many servers are there when you connect? (upper left)
FearghusMcMahon
@FearghusMcMahon
Mar 24 2014 21:27
the weird thing is on root.highfidelity.io and alpha.highfidelity.io i get the white rectangle and you can put down voxels...on the domain running on my macbook i don't get that white rectangle/square
it says 5 servers when i connect
Andrew Meadows
@AndrewMeadows
Mar 24 2014 21:27
hrm... 5 servers is correct
Stephen Birarda
@birarda
Mar 24 2014 21:28
can you add any voxels to the local environment @FearghusMcMahon
you shouldn’t expect it to be prepopulated with any content
but you should be allowed to add to the local server
Andrew Meadows
@AndrewMeadows
Mar 24 2014 21:28
you're running some sort of "edit voxels" JS script right? I forget the name of the script that enables voxel editing
FearghusMcMahon
@FearghusMcMahon
Mar 24 2014 21:28
yeah it's the adding what i am trying to do
i run the editvoxels.js yeah
Andrew Meadows
@AndrewMeadows
Mar 24 2014 21:30
As I understand it: he doesn't see the box outline that shows where the voxel would go if he were to actually try to create one. It is a UI helper.
FearghusMcMahon
@FearghusMcMahon
Mar 24 2014 21:30
exactly and clicking "in world" doesn't add anything
Andrew Meadows
@AndrewMeadows
Mar 24 2014 21:31
I dunno what is going wrong.
FearghusMcMahon
@FearghusMcMahon
Mar 24 2014 21:31
This message was deleted
Stephen Birarda
@birarda
Mar 24 2014 21:31
if you go to localhost:8080 in your browser
do you have a voxel-server
FearghusMcMahon
@FearghusMcMahon
Mar 24 2014 21:32
yes i do
btw as side node...the ports that i see in the list at localhost:8080 are those also the ones i should forward in my router to let others in?
Stephen Birarda
@birarda
Mar 24 2014 21:33
the assignment-clients attempt to hole punch to other people
so theoretically the only thing you should have to open is 40102
the domain-server port
then you’ll use highfidelity’s stun server to punch holes to other people
if you want, you could open 40102 and tell me your ip and I could try and connect in
FearghusMcMahon
@FearghusMcMahon
Mar 24 2014 21:34
ok thanks thats good to know
well 40102 is open at the moment
77.175.41.111 should do the trick
Stephen Birarda
@birarda
Mar 24 2014 21:36
let me try
can’t seem to connect - if you watch your domain-server log do you see me connect?
you could also see on http://localhost:8080/ if there is a new agent
FearghusMcMahon
@FearghusMcMahon
Mar 24 2014 21:37
hmm no...let me check
gaah...one moment.....
ah i see you now
Stephen Birarda
@birarda
Mar 24 2014 21:40
so it works
at least sort of
I see the server count jumping around
that could be ping though
FearghusMcMahon
@FearghusMcMahon
Mar 24 2014 21:43
hmmm my internet has been a bit unstable this evening. I did have a friend over earlier though
FearghusMcMahon
@FearghusMcMahon
Mar 24 2014 21:54
ok I restarted it all and used a cable instead of wifi on the laptop......somehow a blue voxel was there....and to that i can add other voxels
in thin air no luck yet.....but progress :)
Andrew Meadows
@AndrewMeadows
Mar 24 2014 22:35
@ZappoMan, is there some ray-tracing going at the VoxelServer that determines where the voxel editor UI shows up? (I'm wondering why FearghusMcMahon is having trouble creating voxels). ^^^
FearghusMcMahon
@FearghusMcMahon
Mar 24 2014 22:39
As long as there is an existing voxel i can add to that one Andrew. After running the fountain.js i had a blue voxel...and i could add voxels to that.
ok Emily explained that one to me. in thin air I can use the "0" and it will add one in front of me :)
Brad Hefta-Gaub
@ZappoMan
Mar 24 2014 22:53
@AndrewMeadows - no
@FearghusMcMahon - the edit voxel UI uses the "0" button to add a new voxel in front of you
or you can point to a voxel and add a voxel to the side of another voxel
this is the expected behavior of editVoxels.js...
@AndrewMeadows - there is "ray casting" in the client that determines where the add voxel will show up
this is all in the client - not the server
FearghusMcMahon
@FearghusMcMahon
Mar 24 2014 22:55
Yeah thats working great now thanks ZappoMan, the "0" button was the missing link for me.