These are chat archives for highfidelity/hifi

29th
Apr 2014
Mika Impola
@polac
Apr 29 2014 07:56
@AndrewMeadows I think I made some questions few weeks back about building hifi on linux. I used linuxmint 15 which has Qt 4 as default. If I remember correctly(I tried to search gitter history but its giving me 505) the mistake I made was that I used a library(sorry, do not remember which one) from the linuxmint repo that was a correct version but was actually build against the Qt4. I needed to build from the source against the Qt5 and everything was fine.
Thijs Wenker
@thoys
Apr 29 2014 09:20
@polac nice, there was also someone asking about Fedora a week back or so IIRC
or it was Centos
Mika Impola
@polac
Apr 29 2014 09:21
Nouh! And this thing doesn't support deleting msg.
Thijs Wenker
@thoys
Apr 29 2014 09:22
hehe, @polac IIRC = If i recall correctly, <--iirc .
Mika Impola
@polac
Apr 29 2014 09:24
Douh!
Thijs Wenker
@thoys
Apr 29 2014 09:50
@polac but i visit IRC sometimes, freenode ( #awg , #opensim-dev , #opensl , #radegast )
Konstantin
@SydoxX
Apr 29 2014 16:09
Hey, has anyone already used the "VoxelDetail getVoxelAt(float x, float y, float z, float scale)" function?
Konstantin
@SydoxX
Apr 29 2014 16:22
Or simple: How does it work?
Leonardo Murillo
@murillodigital
Apr 29 2014 16:30
it’s download/ webdood
webdood
@webdood
Apr 29 2014 16:31
Note the handle.
Someone has hijacked the route
Leonardo Murillo
@murillodigital
Apr 29 2014 16:32
thats cause of a busted 404
I’ll fix that
downloads/ doesnt exist
and its returning a 404 for an older project of ours
i’ll fix
webdood
@webdood
Apr 29 2014 16:32
busted 404!
yay
Judas
@judasshuffle
Apr 29 2014 18:54
I cant paste an uploaded model in the windows version.On the mac command v puts them down. ctrl v doesn't do it etc.
Clément Brisset
@Atlante45
Apr 29 2014 18:59
Must be a pb with grabbing the key event
Konstantin
@SydoxX
Apr 29 2014 19:12
getVoxelAt(x,y,z,s) just returns [object Object]. It there something wrong or am I doing something wrong?
Clément Brisset
@Atlante45
Apr 29 2014 19:13
When there is nothing there, it’ll return a null value
I guess it’s an empty object in that case.
Konstantin
@SydoxX
Apr 29 2014 19:16
But for example when I set a voxel at 0,0,0 with the R Y B 0 0 0 and I "scan" it afterwards, it still gives me the same error.
Clément Brisset
@Atlante45
Apr 29 2014 19:16
Did you see it appear in world>
?
Konstantin
@SydoxX
Apr 29 2014 19:17
Yep
Clément Brisset
@Atlante45
Apr 29 2014 19:19
The object you get back should contain the parameters x, y, z, s, red, green and blue.
Did you try a debug print ?
Konstantin
@SydoxX
Apr 29 2014 19:19
function TEST()
{
 Voxels.setVoxel(6274,323,6800,1.0,0,0,0);
print(Voxels.getVoxelAt(6274,323,6800,1.0));
}
TEST();
Only prints out " [object Object] "
Clément Brisset
@Atlante45
Apr 29 2014 19:20
try that
function TEST()
{
 Voxels.setVoxel(6274,323,6800,1.0,0,0,0);
print(Voxels.getVoxelAt(6274,323,6800,1.0).red);
}
TEST();
you need to specify what parameter you want to print.
Konstantin
@SydoxX
Apr 29 2014 19:21
That works! Thanks!
Clément Brisset
@Atlante45
Apr 29 2014 19:21
No problem.
Konstantin
@SydoxX
Apr 29 2014 19:22
Ok, I will write it down in the wiki for other scripters ;)
Clément Brisset
@Atlante45
Apr 29 2014 19:23
Thanks, at some point I’m really gonna to take some time for that.