These are chat archives for highfidelity/hifi

7th
May 2014
Judas
@judasshuffle
May 07 2014 07:40
http://grabilla.com/04507-7c4b5212-d45f-41c7-99b7-65fa0d964adc.png I get this error on all the windows installers up2 520 (win7) , I click ignore and it seems to run fine
Thijs Wenker
@thoys
May 07 2014 11:18
@murillodigital > #2808
Konstantin
@SydoxX
May 07 2014 14:49
@judasshuffle Restarting solves the problem
Jeremiah Biard
@kzzch
May 07 2014 17:53
hey @thoys are you here?
Thijs Wenker
@thoys
May 07 2014 17:54
Hey Yes
Jeremiah Biard
@kzzch
May 07 2014 17:54
sorry to bother you again, i'm still having trouble getting things to compile...
Thijs Wenker
@thoys
May 07 2014 17:55
ah whatsup?
Jeremiah Biard
@kzzch
May 07 2014 17:56
i had it getting to 13% or so before it gave up so i decided to try going back to gmplig 4.2 and now i can't get gnutls to compile because it can't find nettle 2.7, even though i just built and installed that :/
it's not finding it even if i pass in the lib directory with CFLAGs
Thijs Wenker
@thoys
May 07 2014 17:57
13% what?
building?
Jeremiah Biard
@kzzch
May 07 2014 17:58
um, building the hifi source? like i used git to clone the hifi repository and got it to configure and build but it would fail on the gnutls part of the build
i figured it was because i was using gmplib 6.0.0
Thijs Wenker
@thoys
May 07 2014 17:58
aha
hmm, I need to try an ubuntu build sometimes
Jeremiah Biard
@kzzch
May 07 2014 17:58
so i'm trying to rebuild everything using the suggested version from the build page
Thijs Wenker
@thoys
May 07 2014 17:59
I got it running on centos
Jeremiah Biard
@kzzch
May 07 2014 17:59
lol i wouldn't suggest it :P
if i get it working i plan on writing a guide
Thijs Wenker
@thoys
May 07 2014 17:59
hehe good
Jeremiah Biard
@kzzch
May 07 2014 18:00
but like i said, gnutls isn't finding nettle for some reason, even though the nettle and hogweed libs are building and installing correctly
do you know if anyone else has successfully built it under ubuntu?
Thijs Wenker
@thoys
May 07 2014 18:04
the test linux builds go with ubuntu i gues
guess
Ryan Huffman
@huffman
May 07 2014 18:05
I've built under ubuntu before, but it's been awhile
  • Linux Mint
that should have been a + :P
Clément Brisset
@Atlante45
May 07 2014 18:07
Yeah Ubuntu is probably the best right now since there is 2 Devs under ubuntu here. I used to work on Mint and it was working fine, also if you use lmde there will probably some depedancies conflict to take care of.
Jeremiah Biard
@kzzch
May 07 2014 18:07
mlde?
er lmde?
Clément Brisset
@Atlante45
May 07 2014 18:07
Linux Mint Debian Edition
It’s mint with a slightly modified Debian kernel.
Jeremiah Biard
@kzzch
May 07 2014 18:08
got it, googled it after i asked
heh
Clément Brisset
@Atlante45
May 07 2014 18:08
Probably my favourite Linux distribution.
Jeremiah Biard
@kzzch
May 07 2014 18:08
did you run into any of the issues i'm having?
nettle installed into /usr/lib64 so i don't know if i need to change where it installs it?
Clément Brisset
@Atlante45
May 07 2014 18:11
I work on mac now so I haven’t build on linux since we added GnuTLS.
Did you install it with your packet manager ?
Jeremiah Biard
@kzzch
May 07 2014 18:12
nope, most of the package versions hifi needs aren't in the package manager
Clément Brisset
@Atlante45
May 07 2014 18:19
Uh, let me ask around.
Andrew Meadows
@AndrewMeadows
May 07 2014 18:21
kzzch, I currently build on kubuntu
I solved the libnettle dependency with this:
sudo apt-get install nettle-dev
Jeremiah Biard
@kzzch
May 07 2014 18:23
see, now i tried that yesterday and it worked, but the hifi code still wouldn't build, but let me try again
that's the error i was getting when i tried to build hifi
Andrew Meadows
@AndrewMeadows
May 07 2014 18:28
@kzzch how did you install gnutls? via apt-get? or did you build/install from source?
Jeremiah Biard
@kzzch
May 07 2014 18:29
i'm building it from source
as we speak actually
Andrew Meadows
@AndrewMeadows
May 07 2014 18:30
ah ok. the hifi camake step will probably get farther along once you've installed gnutls
Jeremiah Biard
@kzzch
May 07 2014 18:30
actually, that was after i build it after install nettle-dev
Andrew Meadows
@AndrewMeadows
May 07 2014 18:30
a couple weeks ago I tried to build on a fresh linuxmint install... I didn't quite complete it. I put my notes up on a patebin page... lemme see if I can find it.
Jeremiah Biard
@kzzch
May 07 2014 18:30
it's why i went back and tried to build everything from scratch instead of using nettle-dev
Stephen Birarda
@birarda
May 07 2014 18:30
apologize for all the gnutls problems
it will be replaced in the next month or so with openssl
I suppose I could remove the dependency since we’re not using it right now if that would make building easier
Andrew Meadows
@AndrewMeadows
May 07 2014 18:31
@kzzch, here are my notes from my last attempt to setup a linux dev machine: http://pastebin.com/HWQvHD48
Stephen Birarda
@birarda
May 07 2014 18:31
give me 30 minutes @kzzch
Jeremiah Biard
@kzzch
May 07 2014 18:32
oh, ok!
sure no problem
thanks Andrew
Jeremiah Biard
@kzzch
May 07 2014 18:40
welp, i guess whatever my issue was is resolved, i decided to try again, pulled the current source and it's up to 70%
Stephen Birarda
@birarda
May 07 2014 18:41
let me know if that works and I’ll hold off on ripping it out
Andrew Meadows
@AndrewMeadows
May 07 2014 18:45
yeah, the gnutls dependency is solvable, so no need to prioritize its removal yet.
Jeremiah Biard
@kzzch
May 07 2014 18:45
looks like it built
Jeremiah Biard
@kzzch
May 07 2014 18:51
\o/
Stephen Birarda
@birarda
May 07 2014 18:51
victory?
Jeremiah Biard
@kzzch
May 07 2014 18:51
yeah
guess i can't join the server until i get accepted into the alpha?
Thijs Wenker
@thoys
May 07 2014 18:56
you can go to thoys.nl
Chris Collins
@cozza13
May 07 2014 18:58
@kzzch send me an email and I can get you into the Alpha. Chris at highfidelity.io
Jeremiah Biard
@kzzch
May 07 2014 18:58
awesome, thanks
sent
Chris Collins
@cozza13
May 07 2014 19:02
sent back to you
Jeremiah Biard
@kzzch
May 07 2014 19:02
got it, thanks again

excited

Jeremiah Biard
@kzzch
May 07 2014 19:16
okay, so i can get in world but i can't seem to login to chat using the bar at the top of the window
Thijs Wenker
@thoys
May 07 2014 19:27
did you use the release version of qxmpp with a debug build of hifi?
Jeremiah Biard
@kzzch
May 07 2014 19:28
probably?
Thijs Wenker
@thoys
May 07 2014 19:29
to get qxmpp working you need to use the debug, if you're debugging, and the release on a release
not sure if that also counts for other OS's then windows tho
Jeremiah Biard
@kzzch
May 07 2014 19:29
i basically just built whatever the defaults are
i built qxmpp from source too
Jeremiah Biard
@kzzch
May 07 2014 19:54
[2014-05-07T15:51:39] AccountManager requestError - 299
[2014-05-07T15:51:39] AccountManager requestError - 299
[2014-05-07T15:51:39] Received a response for password grant that is missing one or more expected values.
rebuilt interface with: cmake -DCMAKE_BUILD_TYPE=Release ..
Jeremiah Biard
@kzzch
May 07 2014 20:01
Also, does anyone know the xyz coordinates of the strip? I can't seem to teleport either
Thijs Wenker
@thoys
May 07 2014 20:02
@ (Shift-F2) #thestrip
Chris Collins
@cozza13
May 07 2014 20:02
type in thestrip
what thoys said.
I can not see you in chat
Thijs Wenker
@thoys
May 07 2014 20:02
he cannot login somehow
Jeremiah Biard
@kzzch
May 07 2014 20:03
tried that already
Thijs Wenker
@thoys
May 07 2014 20:03
but do you see any voxels in alpha?
Jeremiah Biard
@kzzch
May 07 2014 20:03
yeah, i can see a great big hello world written in voxels
Thijs Wenker
@thoys
May 07 2014 20:03
ah oke
yes, i remember that lol
Jeremiah Biard
@kzzch
May 07 2014 20:06
I'm assuming qxmpp defaulted to a release build if i didn't tell it to build debug so i rebuilt hifi as a Release, guess I'll try Debug? does it default to Debug? Also if there is any way for me to check that without bothering you guys
I'm afraid i'm going to make a nuisance of myself :worried:
Thijs Wenker
@thoys
May 07 2014 20:18
don't worry, i'm sure you'll learn
not sure how to check
Chris Collins
@cozza13
May 07 2014 20:58
also @kzzch not that you are in the Alpha you could try and download the release build
the link is in the email I sent you
Jeremiah Biard
@kzzch
May 07 2014 21:09
ok, thanks
Jeremiah Biard
@kzzch
May 07 2014 21:20
ok that's weird, it wouldn't let me login to the download either, using my username or my email address
Thijs Wenker
@thoys
May 07 2014 21:22
username
do you have a space in your username?
Jeremiah Biard
@kzzch
May 07 2014 21:26
nope
ooook. i cloned the repo into my home directory and rebuild it and now i get a core dump when i try to run interface
David Rowe
@ctrlaltdavid
May 07 2014 21:31
@thoys I managed to visit your world at thoys.nl - without any login. OK to do so?
Jeremiah Biard
@kzzch
May 07 2014 21:31
are there any characters i shouldn't use in my password?
Thijs Wenker
@thoys
May 07 2014 21:31
yes @ctrlaltdavid :)
Jeremiah Biard
@kzzch
May 07 2014 21:32
oh... would a space in the password cause an issue?
Thijs Wenker
@thoys
May 07 2014 21:32
@kzzch that could be possible
David Rowe
@ctrlaltdavid
May 07 2014 21:32
Thanks!
Thijs Wenker
@thoys
May 07 2014 21:32
try changing your space to %20 ?
i donno
Jeremiah Biard
@kzzch
May 07 2014 21:34
sigh. is there any way to change the password?
Jeremiah Biard
@kzzch
May 07 2014 21:42
@cozza13 I can't seem to log in to the download page either. Could having a space in my password be causing an issue?
Jeremiah Biard
@kzzch
May 07 2014 22:10
Gtk-Message: Failed to load module "overlay-scrollbar"
Creating buckyballs...
Node's local address is 192.168.1.9
Cannot open file '/home/kzzch/Desktop/3_CurrentProjects/hifi/build/resources/images/reload.svg', because: No such file or directory
Cannot open file '/home/kzzch/Desktop/3_CurrentProjects/hifi/build/resources/images/reload.svg', because: No such file or directory
Cannot open file '/home/kzzch/Desktop/3_CurrentProjects/hifi/build/resources/images/stop.svg', because: No such file or directory
Cannot open file '/home/kzzch/Desktop/3_CurrentProjects/hifi/build/resources/images/stop.svg', because: No such file or directory
Cannot open file '/home/kzzch/Desktop/3_CurrentProjects/hifi/build/resources/images/plus.svg', because: No such file or directory
Cannot open file '/home/kzzch/Desktop/3_CurrentProjects/hifi/build/resources/images/plus.svg', because: No such file or directory
[VERSION] Build sequence:
[2014-05-07T18:09:21] First call to Menu::getInstance() - initing menu.
https://gist.github.com/kzzch/da55be536f523c8c38f5
oops
only meant to post the gist
Chris Collins
@cozza13
May 07 2014 22:11
@kzzch you can go in and edit your password https://data-web.highfidelity.io/edit
do not use symbols or space
Jeremiah Biard
@kzzch
May 07 2014 22:11
that's probably why i couldn't log in earlier, i have a space and a ton of symbols in my password
also, i tried recompiling every thing and now i get the error above when i try to run interface, it looks like it's not looking in the interface directory for the resource files
David Rowe
@ctrlaltdavid
May 07 2014 22:16
Is there a default login username and password for localhost, or do you have to login via High Fidelity login?
Jeremiah Biard
@kzzch
May 07 2014 22:17
doh, no linux client release?
Jeremiah Biard
@kzzch
May 07 2014 22:31
wee, submitted my first bug