These are chat archives for highfidelity/hifi

21st
May 2014
Stephen Birarda
@birarda
May 21 2014 00:05
if you brew install highfidelity/formulas/qt5
that’s a patched version without the wifi scanning
I think the problem @LaurentBechir is having is that it complains about corewlan missing
yeah?
LaurentBechir
@LaurentBechir
May 21 2014 00:07
yes
Jason Hawks
@nbq
May 21 2014 00:07
yeah, I just do not like brew, but once I understood why you are using a custom formula with brew it makes sense for others I guess, I like to keep everything under port
LaurentBechir
@LaurentBechir
May 21 2014 00:07
libqcorewlanbearer.dylib
what is this library ?
Jason Hawks
@nbq
May 21 2014 00:09
it has something to do with wlan (wireless)
LaurentBechir
@LaurentBechir
May 21 2014 00:18
so it shouldn't be a problem that it is missing, if the modified qt version removes wireless network scanning
Jason Hawks
@nbq
May 21 2014 00:20
wow I cant even install brew to test it:
From https://github.com/Homebrew/homebrew
  • [new branch] master -> origin/master
    HEAD is now at a361bb2 Remove dead code
    -e:190:in split': invalid byte sequence in UTF-8 (ArgumentError) from -e:190:in<main>'
I cant say for sure as I have not looked over the patches yet but I would think the cmake has to be modded to remove references to those files, if it takes them out completely
Stephen Birarda
@birarda
May 21 2014 00:24
@LaurentBechir corewlan is the OS X wifi library
but libqcorewlanbearer is the Qt plugin for corewlan
is it possible you have two instances of qt on your machine?
LaurentBechir
@LaurentBechir
May 21 2014 00:27
qt5 from howebrew, and I can't see any other one
Stephen Birarda
@birarda
May 21 2014 00:27
did it install qt5 from the bottle?
let me try that same install path on one of our machines at the office and see what happens
ahh, interesting @LaurentBechir that’s using the cmake Qt5NetworkConfig module and not the one created by Qt during build
which version of cmake do you have?
did you set QT_CMAKE_PREFIX_PATH
LaurentBechir
@LaurentBechir
May 21 2014 00:29
2.8-12
Stephen Birarda
@birarda
May 21 2014 00:29
okay, start by making sure you have 2.8.12.2 since we had some problems with that
brew should be able to grab that for you to
too*
LaurentBechir
@LaurentBechir
May 21 2014 00:35
I have the right version now, but the problem remains.
Stephen Birarda
@birarda
May 21 2014 00:36
did you set QT_CMAKE_PREFIX_PATH
LaurentBechir
@LaurentBechir
May 21 2014 00:36
no. to where it should be set ?
anyway, I'll see that tomorrow. It's very late here in France :) Good night
Stephen Birarda
@birarda
May 21 2014 00:42
good night, sorry we couldn’t get it sorted todaay
today*
LaurentBechir
@LaurentBechir
May 21 2014 12:02
Hello. Someone online or is it too still too soon ? :)
LaurentBechir
@LaurentBechir
May 21 2014 15:07
Hello. I've solved the problem with QT, and two other ones. I've been able to compile the project with Xcode, but now I don't know where is the binary. It's like Xcode had generated nothing. I've put my steps on pastebin : http://pastie.org/9196252
Stephen Birarda
@birarda
May 21 2014 16:29
xcode puts its targets in
build/TARGET/Debug
LaurentBechir
@LaurentBechir
May 21 2014 18:16
I must have missed something, since I have nothing in the build folder : ls build/
CMakeCache.txt CMakeScripts assignment-client domain-server hifi.xcodeproj libraries tools
CMakeFiles animation-server cmake_install.cmake hifi.build interface tests voxel-edit
LaurentBechir
@LaurentBechir
May 21 2014 18:31
I've found it. interface.app. Time to test :)
LaurentBechir
@LaurentBechir
May 21 2014 18:53
I don't have a test account for the moment, so I've launched domain-server and assignment-client on my machine, but I have no "Domain server" field in the Preferences of Interface
so I can't change it to localhost :)
Thijs Wenker
@thoys
May 21 2014 18:53
you can
in the File menu go to Go to Domain
or ctrl + D (windows)
LaurentBechir
@LaurentBechir
May 21 2014 20:34
I've tried that. I just ear a hip, and nothing happens. I see no window or field to enter the value
Thijs Wenker
@thoys
May 21 2014 20:39
@LaurentBechir try the goto function and goto hifi://localhost/0,0,0
shortcut "@" (SHIFT+2)
LaurentBechir
@LaurentBechir
May 21 2014 20:54
It's the same. I just hear a bip, and nothing happens. Are you running Interface on a Mac too ?
Ryan Huffman
@huffman
May 21 2014 20:55
maybe you have another window in the background that is blocking input
try cmd-~
Thijs Wenker
@thoys
May 21 2014 21:05
@LaurentBechir did you get rid of the login screen first?
LaurentBechir
@LaurentBechir
May 21 2014 21:11
No. Now I can see the field. Thank you :) Are there some special login/password when running highfidelity localhost
Thijs Wenker
@thoys
May 21 2014 21:15
@LaurentBechir its a global login , you could sign up for the alpha to get in, or just click the X in the right top
LaurentBechir
@LaurentBechir
May 21 2014 21:26
@thoys I've used the goto function as you've mentioned above and I've login immediately. At least I think, I'm in the middle of a white no-where with a red ball in the middle :)
Thijs Wenker
@thoys
May 21 2014 21:27
you can "/" to show your stats, to see your coordinates, and in the window title it says the domain i guess, not sure if that also happens if you're not logged in
Jeremiah Biard
@kzzch
May 21 2014 21:29
anyone know if they've got any more information on that Visage licensing issue?
LaurentBechir
@LaurentBechir
May 21 2014 21:34
My first step in highfidelity : http://www.madonie.org/Snapshots/highfidelity.png :). I have to learn now what I can do with it
jmgrosen
@jmgrosen
May 21 2014 22:53
I keep getting /path/to/hifi/libraries/shared/src/FileUtils.cpp:14:10: fatal error: 'QDesktopServices' file not found -- help?
jmgrosen
@jmgrosen
May 21 2014 22:59
I have set QT_CMAKE_PREFIX_PATH
jmgrosen
@jmgrosen
May 21 2014 23:04
hm, that seems to be the first file that uses Qt, which is awfully suspicious...
does QT_CMAKE_PREFIX_PATH=/usr/local/Cellar/qt5/5.2.1/lib/cmake/ sound right?
jmgrosen
@jmgrosen
May 21 2014 23:14
Hm, uninstalled and reinstalled all the dependencies, and it seems to be working now. ~shrug~
jmgrosen
@jmgrosen
May 21 2014 23:20
oh, is it invite-only at the moment? disappointing :/
Stephen Birarda
@birarda
May 21 2014 23:20
that QT_CMAKE_PREFIX_PATH is right
jmgrosen, what’s your email?
Stephen Birarda
@birarda
May 21 2014 23:21
you’ve built the client, I think that means you deserve an invite
jmgrosen
@jmgrosen
May 21 2014 23:21
cool :P
Stephen Birarda
@birarda
May 21 2014 23:21
should be on its way!
jmgrosen
@jmgrosen
May 21 2014 23:32
...hm, still hasn't showed up
Stephen Birarda
@birarda
May 21 2014 23:32
check your spam
jmgrosen
@jmgrosen
May 21 2014 23:32
yeah, not there either
Stephen Birarda
@birarda
May 21 2014 23:33
right?
jmgrosen
@jmgrosen
May 21 2014 23:33
that looks right
I've previously signed up through your homepage -- is that a problem?
Stephen Birarda
@birarda
May 21 2014 23:33
nope - you should still get the invite email
LaurentBechir
@LaurentBechir
May 21 2014 23:45
I've built, and even launched the client too. Do I deserve an invite :) ?
Stephen Birarda
@birarda
May 21 2014 23:47
sure @LaurentBechir - what’s your email
LaurentBechir
@LaurentBechir
May 21 2014 23:49
thank you :)
Stephen Birarda
@birarda
May 21 2014 23:49
sent
jmgrosen
@jmgrosen
May 21 2014 23:59
getting lots of segfaults, but intriguing