These are chat archives for highfidelity/hifi

22nd
May 2014
LaurentBechir
@LaurentBechir
May 22 2014 00:09 UTC
mail received, thank you :)
jmgrosen
@jmgrosen
May 22 2014 02:50 UTC
I'm getting a bunch of "No element for delete." log messages, and the gui isn't responding -- any ideas?
pulling, cleaning, and rebuilding didn't help
Philip Rosedale
@PhilipRosedale
May 22 2014 04:14 UTC
@jmgrosen - I think that's a message from a script, failing to find an object to delete. I've seen it too, can't remember when, it may be a bug.
Philip Rosedale
@PhilipRosedale
May 22 2014 04:14 UTC
try turning off your running scripts ... yeah.
its one of our bugs
Jeremiah Biard
@kzzch
May 22 2014 15:11 UTC
still can't login with windows build 620, are you guys making any progress on the licensing error?
Philip Rosedale
@PhilipRosedale
May 22 2014 16:28 UTC
@kzzch what error are you seeing? my understanding was that we had added licenses.
Jeremiah Biard
@kzzch
May 22 2014 16:44 UTC
the license is showing up in my registry, but it still throws up the error and stops before creating the Interface.ini
It's still saying "Licensing failed. Date verification failure (1). Please contact support.
Mohammed Nafees
@mnafees
May 22 2014 17:08 UTC
I am trying to build hifi on Ubuntu for the first time I get an error regarding GLUT not found
I have freeglut and all other dependencies installed
Stephen Birarda
@birarda
May 22 2014 17:09 UTC
you may need to point cmake at it
if it’s not in a spot cmake will check
Thijs Wenker
@thoys
May 22 2014 17:18 UTC
@kzzch I think that this is the job related to the bug https://worklist.net/19671 , seems like it's wrapping up
Jeremiah Biard
@kzzch
May 22 2014 17:34 UTC
@binaryking sudo apt-get install freeglut3-dev
Mohammed Nafees
@mnafees
May 22 2014 17:39 UTC
@kzzch yes, figured that out. Thanks :)
Jeremiah Biard
@kzzch
May 22 2014 17:41 UTC
@binaryking let me know if you run into any other issues, there are a few more you might run into
Mohammed Nafees
@mnafees
May 22 2014 17:47 UTC
@kzzch did you face any problem compiling AudioMixer.cpp? something regarding ‘__m64’ ?
Jeremiah Biard
@kzzch
May 22 2014 17:48 UTC
can you make a gist of the error it's giving you?
Mohammed Nafees
@mnafees
May 22 2014 17:49 UTC
Jeremiah Biard
@kzzch
May 22 2014 17:51 UTC
are you following these instructions? https://github.com/highfidelity/hifi/blob/master/BUILD.md
Mohammed Nafees
@mnafees
May 22 2014 17:52 UTC
@kzzch yes
Jeremiah Biard
@kzzch
May 22 2014 17:52 UTC
only think i can think of is you're missing a dependency
are you building in an IDE?
Ryan Huffman
@huffman
May 22 2014 17:58 UTC
@binaryking The error seems to be related to error: #error "MMX instruction set not enabled"
Andrew Meadows
@AndrewMeadows
May 22 2014 21:17 UTC
@birarda ^^^ it seems not everyone has MMX available.
Stephen Birarda
@birarda
May 22 2014 21:17 UTC
uh oh
Andrew Meadows
@AndrewMeadows
May 22 2014 21:18 UTC
Which means... either they're compiling on a strange chip architecture (ARM?) or... MMX was disabled somehow.
Stephen Birarda
@birarda
May 22 2014 21:18 UTC
right
@binaryking what’s your arch?
jmgrosen
@jmgrosen
May 22 2014 23:22 UTC
keeps hanging for me :/
jmgrosen
@jmgrosen
May 22 2014 23:45 UTC
is there any easy way to do a debug build?
Jeremiah Biard
@kzzch
May 22 2014 23:45 UTC
CMAKE_BUILD_TYPE=Debug
jmgrosen
@jmgrosen
May 22 2014 23:46 UTC
thanks