These are chat archives for highfidelity/hifi

23rd
Jul 2014
David Rowe
@ctrlaltdavid
Jul 23 2014 02:32
Debug build no longer runs: "The program can't start before DeviceDLL.dll is missing from your computer". ... Release build runs OK. ... Am building without Faceshift and without Visage.
gfcprogramer
@gfcprogramer
Jul 23 2014 06:16
As visual studio developer, some people, like me, are unfamiliarized with open source/cross plataform c-make tool.
This video introduces the concept, and goes further familiarization into part02, part03, etc.
https://www.youtube.com/ watch?v=wCvv8EVuPo0
Will that help you?
Ryan Huffman
@huffman
Jul 23 2014 18:00
Has anyone run into 4>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.CppCommon.targets(170,5): error MSB6006: "cmd.exe" exited with code -1073741515. while building the metavoxels project in VS 2013 ? I don't see any relevant output/errors either, so it's pretty cryptic. I'm running a fresh install of Win 7 Pro. Oddly, this happens with a Debug build but is fine with Release, but with Release interface crashes pretty quickly after starting.
Nandita D
@bubble8773
Jul 23 2014 18:20
Hello @huffman I think I did had the same error..because I forgot to add Qt to my path
Ryan Huffman
@huffman
Jul 23 2014 18:22
@bubble8773 I hope it's that simple :) I'll check now, thanks!
Nandita D
@bubble8773
Jul 23 2014 18:23
your welcome @huffman
Ryan Huffman
@huffman
Jul 23 2014 18:27
I have that in there - I tried adding a trailing backslash like in the example (BUILD.md) but that didn't help
Nandita D
@bubble8773
Jul 23 2014 18:33
hmm
the error occurs when you don't have the QT bin folder in path
Ryan Huffman
@huffman
Jul 23 2014 19:03
@thoys Hmm, well I do have "C:\Qt\5.2.0\msvc2010_opengl\bin;" in the Path environment variable
Thijs Wenker
@thoys
Jul 23 2014 19:04
@huffman IIRC its batch script that makes calls to mt.exe , it needs to be able to access it