These are chat archives for highfidelity/hifi

26th
Sep 2014
Jeremy
@JeroMiya
Sep 26 2014 03:11
I updated the hifi-typescript declarations to help clean up the generated docs for JavaScript users. Now all the interfaces are under the 'hifi' module, so the summary page just lists the global variables. You can still get at the interfaces by clicking on 'hifi' on the right. http://jeromiya.github.io/hifi-typescript/globals.html
Miles Peyton
@mlsptn
Sep 26 2014 04:01

Hi, I've been trying to build hifi on OSX, and I'm getting the following error:

CMake Error at /usr/local/lib/cmake/Qt5Core/Qt5CoreConfig.cmake:15 (message):
The imported target "Qt5::Core" references the file

 "/usr/local//mkspecs/macx-clang"

but this file does not exist. Possible reasons include:

I suspect the error was my QT_CMAKE_PREFIX_PATH. This is what echo $QT_CMAKE_PREFIX_PATH prints:

/usr/local/qt/5.2.0/clang_64/lib/cmake/

Not sure what to do at this point, possible to get some assistance?

Thanks!

whatSocks
@whatSocks
Sep 26 2014 04:04
aha
i had this issue
it happened to me because i built the thing before putting all my dependencies in
Miles Peyton
@mlsptn
Sep 26 2014 04:07
Hm, the thing is I haven't built it yet. I did install the dependencies using Homebrew..
Jeremy
@JeroMiya
Sep 26 2014 04:30
arg! I deleted my build directory thinking I needed to update the solution file for windows and now cmake won't build anymore. says it can't find ZLIB, but I have the exact same configuration as before
Miles Peyton
@mlsptn
Sep 26 2014 13:36
Still getting the above error after searching this gitter for people who had the same problem and trying their methods..
Ah! Following these instructions worked for me: http://pastebin.com/MTdz2feV
Miles Peyton
@mlsptn
Sep 26 2014 13:45

Ok, now I'm having a problem building in Xcode. I get these errors:

/Users/milespeyton/Desktop/hifi/libraries/shared/src/ShutdownEventListener.h:16:10: 'QAbstractNativeEventFilter' file not found

/Users/milespeyton/Desktop/hifi/libraries/metavoxels/src/AttributeRegistry.h:223: Parse error at "lodThresholdMultiplier"

/Users/milespeyton/Desktop/hifi/libraries/metavoxels/src/MetavoxelData.h:468: Parse error at "rate"

/Users/milespeyton/Desktop/hifi/libraries/metavoxels/src/MetavoxelUtil.h:114: Parse error at "metaObject"

Thijs Wenker
@thoys
Sep 26 2014 14:44
Are you guys all Shellshock proof yet?
Jason Hawks
@nbq
Sep 26 2014 14:47
I updated all my main servers first with applications, last night, the rest I need to finish, since its like 5 actual servers and 8 virtual machines, I need to finally look into puppet lol
Thijs Wenker
@thoys
Sep 26 2014 14:48
hehe
Jason Hawks
@nbq
Sep 26 2014 14:49
on the ones I didnt wanna futz with any other breakable updates I just updated bash
Thijs Wenker
@thoys
Sep 26 2014 14:49
Yeh I know the feeling
Jason Hawks
@nbq
Sep 26 2014 14:51
how many servers you have to update?
Thijs Wenker
@thoys
Sep 26 2014 14:52
around 6, but the most important one is in use right now
Jason Hawks
@nbq
Sep 26 2014 14:52
yeh understandable, its hard to schedule around it, I had to do the other last night when MOST people were asleep and not using it but made sure they knew ahead of time
Jason Hawks
@nbq
Sep 26 2014 14:58
good thing this one is getting patched now: root@machine:~# env x='() { :;}; echo vulnerable' bash -c "echo this is a test"
vulnerable
this is a test
Andrew Meadows
@AndrewMeadows
Sep 26 2014 16:06
I tested my laptop install this morning: was vulnerable. I an apt-get update + upgrade and tested again: fixed!
Thijs Wenker
@thoys
Sep 26 2014 19:33
:+1:
My phone is still vulnerable...
@hacker ^
David Rowe
@ctrlaltdavid
Sep 26 2014 20:16
In the skeleton model are the eye positions at the centre of the avatar's eyeballs as one might expect?
Jason Hawks
@nbq
Sep 26 2014 22:47
LOL Thoys, you crack me up, technically I am running a phone with a posix subsystem, but that would be a iPhone 6 Plus and other than developer functions, it is not jailbroken so I cannot ssh to it to check (kidding around with most of that)