These are chat archives for highfidelity/hifi

23rd
Dec 2014
morrisford
@morrisford
Dec 23 2014 00:00
Apparently a different version of tbb is required. I tried 4.3 but that caused a different error. A little help needed!
Thijs Wenker
@thoys
Dec 23 2014 00:02
cool ty @ctrlaltdavid
Joe Large [Omega Heron]
@OmegaHeron
Dec 23 2014 03:41
For Intel TBB I used binary distro from, https://www.threadingbuildingblocks.org/sites/default/files/software_releases/linux/tbb43_20141204oss_lin.tgz
Extracted that, moved to /opt then set environment to reference properly - export TBB_ROOT_DIR='/opt/tbb43_20141204oss'
you could build from source, install where-ever you like - I've used it built from source and in other locations.. works fine either way.
Alex Tharp
@toastercup
Dec 23 2014 06:12
Would anyone who has recently & successful built on *nix be interested in helping me with a compilation issue? I'd be so very obliged
morrisford
@morrisford
Dec 23 2014 14:45
@OmegaHeron Thanks for your response. I set up tab as you said and I am still getting the same error as when I set up tab 4.3 before.
The error:
[ 11%] Building CXX object libraries/networking/CMakeFiles/networking.dir/src/NodeList.cpp.o
/usr/src/hifi/libraries/networking/src/NodeList.cpp: In member function ‘void NodeList::pingInactiveNodes()’:
/usr/src/hifi/libraries/networking/src/NodeList.cpp:462: error: expected primary-expression before ‘[’ token
/usr/src/hifi/libraries/networking/src/NodeList.cpp:462: error: expected primary-expression before ‘const’
make[3]: [libraries/networking/CMakeFiles/networking.dir/src/NodeList.cpp.o] Error 1
make[2]:
[libraries/networking/CMakeFiles/networking.dir/all] Error 2
make[1]: [interface/CMakeFiles/interface.dir/rule] Error 2
make:
[interface] Error 2
Joe Large [Omega Heron]
@OmegaHeron
Dec 23 2014 19:00
@morrisford I hadn't noticed you're running CentOS 6.5 - Couple months back someone else was trying to get this working with that distro and had nothing but problems. Another who knows CentOS better than I mentioned 6.5 as having a lot of issues compiling code using (current) bleeding edge tech. Quite a few references to 6.5 being problematic via searches as well. It may be you'll need to do some additional hacking to get this going with 6.5
morrisford
@morrisford
Dec 23 2014 23:07
@OmegaHeron Thanks once again. Ok, I'll install an ubuntu 14.04. I installed a 14.10 yesterday but it froze constantly so I switched to Centos.
@OmegaHeron Is there a known good linux system config (cpu, memory, gnu, drivers, os version, etc.) that works readily with hifi? If the 14.04 doesn't work I think I am just going to put together a system that I know will work.
morrisford
@morrisford
Dec 23 2014 23:13
That's gpu not gnu. Stupid spell checker.