These are chat archives for highfidelity/hifi

7th
Feb 2015
Lexx
@Triplelexx
Feb 07 2015 01:19
getting octal recursion crash a lot
seems to be a known issue
Adrianl3d
@Adrianl3d
Feb 07 2015 10:57
latest windows 1906 throws missing file: MSVCR120D.dll
Jason Hawks
@nbq
Feb 07 2015 10:58
yeah its the new system mixing in stuff and compiling as debug sometimes
I can help you, getting on skype, I gotta do the other thing for you anyhow
Adrianl3d
@Adrianl3d
Feb 07 2015 10:59
no probs
Jason Hawks
@nbq
Feb 07 2015 11:00
they need to fix it, its jenkins compiling the tests and the releases and they are still ironing it all out
Jason Hawks
@nbq
Feb 07 2015 11:06
Since this issue has popped up a couple of times now, for anyone who needs the rumetimes I zipped up the ones I used in my builds a while back, so you can just copy the file it says you are missing to the folder in the readme (if its 64bit), I doubt many run 32bit right now: http://coaledge.com/working-runtimes.zip
Jason Hawks
@nbq
Feb 07 2015 11:16
Ok to make it simpler on everyone, I made it into a single file in a zip folder with a better readme - http://coaledge.com/hifi/hifi-msvcr120d.zip - Though they will end up fixing it of course, this is a solution for now
Thijs Wenker
@thoys
Feb 07 2015 11:53
Anyone trying to get the xbox one controller work on OSX? https://github.com/lloeki/xbox_one_controller
Jason Hawks
@nbq
Feb 07 2015 11:54
nah, seems like a cool project though
Lexx
@Triplelexx
Feb 07 2015 15:58
if audio packets are sent at 48khz, why is the Qaudio sample rate 24?
if anyone knows, I thought the sample rate was kept low to affect packets but it appears not, just something I'm wondering about
Ari Kivikangas
@Cybermansow
Feb 07 2015 17:02
my interface cant find the domain server anymore? can somebody help me please?
Ari Kivikangas
@Cybermansow
Feb 07 2015 17:30
how i can start my domain server again, i think that have latest centos domain-server installed in my server?
tx0h
@tx0h
Feb 07 2015 19:59
hi, got it running on debian but get no audio device. here is what i get on stdout: [DEBUG] [02/07 20:58:41] The default audio input device is ""
[DEBUG] [02/07 20:58:41] The default audio output device is ""
[DEBUG] [02/07 20:58:41] Unable to set up audio input because of a problem with input format.
Jason Hawks
@nbq
Feb 07 2015 20:00
well they JUST changed some stuff
im updating the centos guide myself but the location for gverb linking just changed and same with now you need soxr
so it might have sometime to do with it
tx0h
@tx0h
Feb 07 2015 20:01
i have soxr from the debian dep
Jason Hawks
@nbq
Feb 07 2015 20:01
okie, you linked in the new location for gverb?
tx0h
@tx0h
Feb 07 2015 20:02
have you had audio on centos (linux) running with interface?
yes, gverb is in place, i cloned the repo 8 hours ago
Jason Hawks
@nbq
Feb 07 2015 20:02
also make sure you close all running scripts (the x beside the name) then search for defaultscripts
it loads audiochoser.js or something like that
tx0h
@tx0h
Feb 07 2015 20:03
but i still didn't get any password or something, so i can't chat in-world
Jason Hawks
@nbq
Feb 07 2015 20:04
since you did a compile and got it running, you can email chris@highfidelity.io and tell him that you got it compiled and running and ask if you could get an invite to the alpha
tx0h
@tx0h
Feb 07 2015 20:05
k
Jason Hawks
@nbq
Feb 07 2015 20:06
and okie, I just asked about gverb since it used to be under interface/externals/gverb but now its under libraries/audio-client/external/gverb - but it compiled so you are good there
but a lot of audio stuff is changing right now as they work this out and shift around, the fact it detects nothing is interesting though, but I have not done a pure debian setup yet, I will soon though (I am Coal on HiFi so I am working to get the linux docs setup with more in depth walk throughs)
tx0h
@tx0h
Feb 07 2015 20:08
did you got audio with linux before? for me it seems that in QAudioDeviceInfo defaultAudioDeviceForMode(QAudio::Mode mode) there is no linux specific handling. didn't looked it up in details but i just see a mac and a dos handling
ah, coal from hifi://bits.holoshed.com/0,0,0/0,0,0
Jason Hawks
@nbq
Feb 07 2015 20:10
yep, though that is… now offline lol
I am using place names
but you can still access my domain via
hifi://hifi.netbit.me
tx0h
@tx0h
Feb 07 2015 20:11
:-)
i can't interact at this time, no sound, no chat... and everything beside faceshift, hands and 3d vision seems to be far behind
Jason Hawks
@nbq
Feb 07 2015 20:13
well, there is a lot going on if you look on the side for activity
with the pull request
anything from hifi-gustavo is a compile test (though no linux), but it is new stuff going in, being teste
tx0h
@tx0h
Feb 07 2015 20:13
sure, i hope i can walk on ground soon, and sit on objects :-)
Jason Hawks
@nbq
Feb 07 2015 20:15
well bulletsim is adding a bit and they are getting it figured out more day by day, but in terms of sit and walk on the ground, it may not work how it does say in second life but they are doing more and more every day
tx0h
@tx0h
Feb 07 2015 20:16
it's already on the worklist somewhere
i'm from opensim, left sl in 2008
Jason Hawks
@nbq
Feb 07 2015 20:16
right, like I said, more and more every day
and nice, I am still in SL since 2005, I know about OS but I never got what I needed outside the main grid since I actually sell stuff in SL and my market is there, other grids have their purpose though and do well in their own right
tx0h
@tx0h
Feb 07 2015 20:18
i'm unsure if you confirmed a working audio environment with linux
Lexx
@Triplelexx
Feb 07 2015 20:22
I'm looking at the code for walking on ground myself now ;)
seeing how much stuff a character controller needs to touch
tx0h
@tx0h
Feb 07 2015 20:23
there is the hint in the worklist, that it's only needed in all instances of MyAvatar
Lexx
@Triplelexx
Feb 07 2015 20:23
yes
but I think it needs additions to physics code as well
but, yeah shouldn't be long till someone gets that in
tx0h
@tx0h
Feb 07 2015 20:25
yepp, maybe 2 or 3 month
here got it spun up just for you to test
sorry I was afk a little bet getting that
tx0h
@tx0h
Feb 07 2015 20:26
yepp, that list is completely empty for me
and i tried with jackd launched, with pulseaudio and pure alsa with no luck
Jason Hawks
@nbq
Feb 07 2015 20:28
I have not yet got into writing anything for debian or ubuntu for the interface yet so I cant say for those till I get there, but I did confirm for centos, wish I could help you more for now… could be related to the new stuff being put in for audio to match up with android compiles
Thijs Wenker
@thoys
Feb 07 2015 21:02
@TimelessP ^
Jason Hawks
@nbq
Feb 07 2015 21:03
Hiya @thoys
Thijs Wenker
@thoys
Feb 07 2015 21:03
hi @nbq , my friend @TimelessP also had some audio issues on linux
as in no Audio
Jason Hawks
@nbq
Feb 07 2015 21:05
hrm, interesting, see I did not get that when I did my compile, but I will do a new compile with new libs and stuff on my centos when I get a chance and see if it changed
I am busy updating stuff for the gverb moves and soxr addition atm
Thijs Wenker
@thoys
Feb 07 2015 21:12
yum install soxr soxr-devel on fedora did it for me
Jason Hawks
@nbq
Feb 07 2015 21:13
yep, I updated http://docs.highfidelity.io/v1.0/docs/centos-7-interface-compile-guide already, going to do the domain-server one next, just wanted to get the guide in the forums updated which I just did
Thijs Wenker
@thoys
Feb 07 2015 21:13
looks nice
Jason Hawks
@nbq
Feb 07 2015 21:14
thanks! I tried to make it as user friendly yet not “talk down” to the reader at the same time
tx0h
@tx0h
Feb 07 2015 21:17
i installed soxr 0.1.1-1 from repo
Jason Hawks
@nbq
Feb 07 2015 21:18
nice, there you go, that will more than likely help you a lot
tx0h
@tx0h
Feb 07 2015 21:18
nope
i had it installed before the build
Jason Hawks
@nbq
Feb 07 2015 21:18
you did a straight recompile after that after doing an rm -rf on your build folder?
ah okie
tx0h @tx0h sighs
Jason Hawks
@nbq
Feb 07 2015 21:21
Well, if you tell me your setup I can try to replicate it as much as possible when I setup a debian build environment next, like you running anything different other than stock?
tx0h
@tx0h
Feb 07 2015 21:22
it's debian unstable (or testing), and it's more or less recent (last distupgrade is about 3 month ago)
Jason Hawks
@nbq
Feb 07 2015 21:23
okie, then I will try it out in the next couple of days, though I hope maybe someone else has a fix or answer for you before then, if not I will try it out then
tx0h
@tx0h
Feb 07 2015 21:26
here is a strace grep output on open syscall: http://pastebin.com/gKNpwggU
Jason Hawks
@nbq
Feb 07 2015 21:28
thanks for that, let me ask one more thing, mind checking the output from the terminal when you first start the interface, like does it even mention sound devices?
Like I see this [DEBUG] [02/07 15:12:10] The default audio input device is "Built-in Microphone" [DEBUG] [02/07 15:12:10] The audio input device "Built-in Microphone" is available. [DEBUG] [02/07 15:12:10] The format to be used for audio input is QAudioFormat(24000Hz, 16bit, channelCount=1, sampleType=SignedInt, byteOrder=LittleEndian, codec="audio/pcm") [DEBUG] [02/07 15:12:10] No resampling required for audio input to match desired network format. [DEBUG] [02/07 15:12:10] Logging activity "launch" [DEBUG] [02/07 15:12:10] Created Display Window. [DEBUG] [02/07 15:12:10] Initialized Display. [DEBUG] [02/07 15:12:11] The default audio output device is "Built-in Output" [DEBUG] [02/07 15:12:11] The audio output device "Built-in Output" is available. [DEBUG] [02/07 15:12:11] The format to be used for audio output is QAudioFormat(24000Hz, 16bit, channelCount=2, sampleType=SignedInt, byteOrder=LittleEndian, codec="audio/pcm") [DEBUG] [02/07 15:12:11] No resampling required for network output to match actual output format.
well on my mac, but you get the idea
tx0h
@tx0h
Feb 07 2015 21:30
that the first lines on stdout: http://pastebin.com/2wueN09T
lines 14-16
Jason Hawks
@nbq
Feb 07 2015 21:32
You MAY be missing libQt5Multimedia
tx0h
@tx0h
Feb 07 2015 21:32
btw, hifi or high fidelity is one of the worst names for a project in terms of search terms
Jason Hawks
@nbq
Feb 07 2015 21:33
trust me, I know, its why you have to come here or have access to the alpha forums for support
tx0h
@tx0h
Feb 07 2015 21:33
ii libqt5multimedia5:amd64 5.3.2-5 amd64 Qt 5 Multimedia module
ii libqt5multimediaquick-p5:amd64 5.3.2-5 amd64 Qt 5 Multimedia Quick module
ii libqt5multimediawidgets5:amd64 5.3.2-5 amd64 Qt 5 Multimedia Widgets module
Jason Hawks
@nbq
Feb 07 2015 21:36
based on search terms I came to this: http://teksourcery.com/category/linux/ which may help you some in terms of getting it fixed, you can try what he mentioned worked there
its ubuntu but… hey… its a start
tx0h
@tx0h
Feb 07 2015 21:39
what is janusvr?
Jason Hawks
@nbq
Feb 07 2015 21:40
no idea, ignore that part, but its the same thing, its trying to initialize org.qt-project.qt.mediaplayer
tx0h
@tx0h
Feb 07 2015 21:44
but yeah, thats ubuntu. i need to find out what they fixed in the ppa:mc3man/trusty-media
Jason Hawks
@nbq
Feb 07 2015 21:45
its all in how qt5 was compiled, so let me ask, did you compile yours or apt-get install?
tx0h
@tx0h
Feb 07 2015 21:45
from repository
Jason Hawks
@nbq
Feb 07 2015 21:47
just to check, you got both qtmultimedia5-dev and qtmultimedia5
never hurts to do an apt-get install qtmultimedia5 qtmultimedia5-dev
tx0h
@tx0h
Feb 07 2015 21:52
i did installed apt-get install qtmultimedia5-examples and withit some plugins and now i have the audio device list
Jason Hawks
@nbq
Feb 07 2015 21:52
there ya go!
tx0h
@tx0h
Feb 07 2015 21:52
thank you for your help
Jason Hawks
@nbq
Feb 07 2015 21:53
mind sending me exactly what your apt-get install was so I can use the info to help others, since you mentioned some other plugins
welcome! I knew it was tied to qtmultimedia5
tx0h
@tx0h
Feb 07 2015 21:53
i will do when i do it on my notebook
Jason Hawks
@nbq
Feb 07 2015 21:54
okie sweet, thanks! feel free to message me any time here or on skype (holoshed is my name there)
tx0h
@tx0h
Feb 07 2015 21:57
i try to avoid skype
Jason Hawks
@nbq
Feb 07 2015 21:58
works for me, I use others but I give that one out the most as a lot of others use it
tx0h
@tx0h
Feb 07 2015 21:58
it's even hard for me that i'm in here. i prefer stock irc
Jason Hawks
@nbq
Feb 07 2015 21:58
well technically gitter CAN do stock irc
tx0h
@tx0h
Feb 07 2015 21:58
now they already have my credentials
Jason Hawks
@nbq
Feb 07 2015 21:59
well gitter is github
same company so… they already technically had them
tx0h
@tx0h
Feb 07 2015 21:59
ok.
cool, now i need to see if audio really works :-)
Jason Hawks
@nbq
Feb 07 2015 22:00
have fun, feel free to visit and use my domain if you need, or sandbox
tx0h
@tx0h
Feb 07 2015 22:00
i have my own domain to mess with :-) but for some testings in future it's a good offer
Jason Hawks
@nbq
Feb 07 2015 22:01
welcome, okie, well if you want someone to visit and test the audio with you (and its not just a localhost/internal domain) then if you want to even message me your domain hifi://whatever then I can help test with you
tx0h
@tx0h
Feb 07 2015 22:02
in the moment i think hifi needs love for everything beside in-world communication, am i right?
Jason Hawks
@nbq
Feb 07 2015 22:02
well, everything is open to work and “love"
tx0h
@tx0h
Feb 07 2015 22:03
actually it's on my home desktop and i have a daily reconnect with changing ip (dynamic ip)
Jason Hawks
@nbq
Feb 07 2015 22:04
but in world communication, audio is getting new tweaks and love, chat is just their own jabber/xmpp server
tx0h
@tx0h
Feb 07 2015 22:04
yes, but chat also needs an login
Jason Hawks
@nbq
Feb 07 2015 22:04
yep, that it does, I meant overall as what it is
tx0h
@tx0h
Feb 07 2015 22:04
is the jabber server centralized then?
Jason Hawks
@nbq
Feb 07 2015 22:05
what I would love is the functionality for IMs
built into the client
tx0h
@tx0h
Feb 07 2015 22:05
yes, IM's are a must have ;-)
Jason Hawks
@nbq
Feb 07 2015 22:05
you get a different set of credentials for the xmpp server that are passed to you on login
with an actual alpha account that is
tx0h
@tx0h
Feb 07 2015 22:06
i have an own jabber server, but i guess thats not gonna be used, right?
Jason Hawks
@nbq
Feb 07 2015 22:06
no, it all goes through theirs
tx0h
@tx0h
Feb 07 2015 22:07
i got my alpha invite, thanks for the email hint
Jason Hawks
@nbq
Feb 07 2015 22:07
it passes your disquss password and your xmpp password to your client upon login
welcome ;) chris is always the man with the man
man with the plan
tx0h
@tx0h
Feb 07 2015 22:13
nice, and it says 4 users online
Jason Hawks
@nbq
Feb 07 2015 22:15
yep