These are chat archives for highfidelity/hifi

1st
Apr 2015
Joe Large [Omega Heron]
@OmegaHeron
Apr 01 2015 02:40
@birarda - if you're still around - mac stack manager seems to have a bad build setup or something. Posted in alpha forum tagged with your id.
Leonardo Murillo
@murillodigital
Apr 01 2015 02:40
yes, fixing
Joe Large [Omega Heron]
@OmegaHeron
Apr 01 2015 02:41
ty
Leonardo Murillo
@murillodigital
Apr 01 2015 02:48
@OmegaHeron fixed, please restart SM
Joe Large [Omega Heron]
@OmegaHeron
Apr 01 2015 02:48
ty
@murillodigital - confirmed good update. Thanks again.
Victor Kislichenko
@vkislichenko
Apr 01 2015 07:35
Hi. Can some one help with building assigment-client for ubuntu on arm, I'm stuck with re-spawning entity server. https://alphas.highfidelity.io/t/entity-server-restarting-infinitely-on-ubuntu-14-10-armv7l/2939
uJelleh
@uJelleh
Apr 01 2015 12:03
Hmm... when I enter the sandbox, it only loads about this much http://puu.sh/gXz3b/248e48eb45.jpg
i get an error about scene complexity o_O
weird because other scenes fully loaded just fine
oh, LOD Tools :P
Joe Large [Omega Heron]
@OmegaHeron
Apr 01 2015 16:39
@vkislichenko - I, for a short time, had domain-server and assignment-client running on the old Pi B model (Arm V6) not the newer B2 (Arm V7). The TBB library seems to need a lot of work on RaspPI. I have no idea what it's status is on the new B+ other than hearing it has issues, but, to get it running on the old B model I had to do some hacking forcing it to use "generic" hardware support. It could be the Arm V7 support is not exactly right. Also QT 5.3.2 can lead to subtle fails depending upon how it was compiled. In my case if I cross compiled QT from PC nothing worked - it all compiled on RaspPi and ran, but failed in odd ways. Compiling QT5.3.2 from source on the RasPi (several DAYS on the old B model) led to working binaries - mostly. While I can't really help you figure it out (no access to a B+) I can tell you you're going to have to get very familiar with gdb and start digging. It also seems sensitive to which version of GCC you use and how it was compiled as well. Wish I could offer more than good luck.
Victor Kislichenko
@vkislichenko
Apr 01 2015 17:49
@OmegaHeron I'm actually using T-R42 with Linux Deploy
But You are right, I know nothing about GCC and compiling stuff from sources, so it's like a wall I'm banging my head against.
Joe Large [Omega Heron]
@OmegaHeron
Apr 01 2015 17:52
I've worked with "small" hardware in embedded systems realm for near 30 years. I banged my head about 3 months getting it running on raspi B model. I intend to revisit that work once things stabilize more here, but, the work required to get it going on RasPi is high and what works one day can be broken the next - too hard to keep up at this time.