These are chat archives for highfidelity/hifi

12th
Jul 2015
Judas
@judasshuffle
Jul 12 2015 18:56
@kevinmthomas-carpool just did his first push the power may drive him mad he must be stopped
Kevin M. Thomas
@hearkevin
Jul 12 2015 19:23
@FearghusMcMahon have you grabbed all of the necessary librarys? apt-get install git build-essential cmake qt5-default qtscript5-dev libssl-dev qttools5-dev qttools5-dev-tools qtmultimedia5-dev libqt5svg5-dev libqt5webkit5-dev libsdl2-dev libasound2 libxmu-dev libxi-dev freeglut3-dev libasound2-dev libjack-jackd2-dev libxrandr-dev libqt5xmlpatterns5-dev libqt5xmlpatterns5 libqt5xmlpatterns5-private-dev qtquickcontrols qtweb*
Mircea Kitsune
@MirceaKitsune
Jul 12 2015 20:15
Hi. Latest Higi GIT no longer starts up and crashes. Anyone know why? Here is the log: http://pastebin.com/raw.php?i=QvSsrtRb
Mircea Kitsune
@MirceaKitsune
Jul 12 2015 20:22
Ok, fixed that. Apparently the Hifi client was looking for some libraries AFTER having been successfully compiled (I don't get why). Anyway, HIFI now starts and works for a few seconds, then crashes with this: http://pastebin.com/raw.php?i=E9W3k7iL
interface: /home/mircea/Games/SecondLife/HighFidelity_GIT/libraries/physics/src/ObjectActionSpring.cpp:192: virtual void ObjectActionSpring::deserialize(QByteArray): Assertion `type == ACTION_TYPE_SPRING' failed.
Mircea Kitsune
@MirceaKitsune
Jul 12 2015 20:52
Someone helped me fix that for the time being. But now there's ANOTHER issue: Shaders don't seem to work properly, and the screen is diagonally divided into two with 2 separate lighting modes. Any thoughts on this please? http://oi60.tinypic.com/27xl43k.jpg
FearghusMcMahon
@FearghusMcMahon
Jul 12 2015 21:26
@kevinmthomas-carpool Can't get qt5 that easy on ubuntu 14.04 server unfortunately....but after removing the build of qt5.4.1 and rebuilding it from scratch I seem to have fixed the error and now the domain and assignment build and run again
Mircea Kitsune
@MirceaKitsune
Jul 12 2015 21:35
http://i60.tinypic.com/2wn940h.png This is a clearer screenshot of the problem, which shows it with shaders as well. If anyone has any thoughts, I would like to know please.