These are chat archives for highfidelity/hifi

8th
Mar 2017
Abhishek Chawla
@abhishekchawla
Mar 08 2017 00:45
@thoys I'm able to build all the project in release exceptfor the oculus one, due to the following error
LNK2038: mismatch detected for 'RuntimeLibrary': value 'MT_StaticRelease' doesn't match value 'MD_DynamicRelease' in OculusBaseDisplayPlugin.obj D:\HiFi\hifi\build\plugins\oculus\LibOVR.lib(OVR_CAPI_Util.obj) oculus
Ryan Huffman
@huffman
Mar 08 2017 00:50
@abhishekchawla We are having that problem internally as well, stay tuned for a fix...
Abhishek Chawla
@abhishekchawla
Mar 08 2017 00:52
@huffman Sure!
Ryan Huffman
@huffman
Mar 08 2017 00:53
Yep, sorry for the issue, we just updated to the 1.11 SDK.
Thijs Wenker
@thoys
Mar 08 2017 01:02
@abhishekchawl update: to fix it "you can either wipe build or wipe build/etc/vc12/LibOVR and remove all LIBOVR_* lines from cmakecache.txt"
Abhishek Chawla
@abhishekchawla
Mar 08 2017 02:27
@huffman @thoys Thanks guys
Thijs Wenker
@thoys
Mar 08 2017 06:25
Got it working @abhishekchawla ?