These are chat archives for highfidelity/hifi

1st
Apr 2017
Christoph Haag
@ChristophHaag
Apr 01 2017 07:59
hm, I built latest master and it looks like it can't connect at all
is that normal?
Midnight
@MidnightRift
Apr 01 2017 08:04
I have the lastest ,RELEASE-6241, in master on one of my doamins and I can connect fine to it.
Christoph Haag
@ChristophHaag
Apr 01 2017 08:12
it's just that trying to log in, it spins for 30 seconds or so and then says my username or password is incorrect
and in Go To, it says Not Connected and the tabs are empty
but the marketplace works
Midnight
@MidnightRift
Apr 01 2017 08:15
are you talking about having built the interface client ? or the server?
Christoph Haag
@ChristophHaag
Apr 01 2017 08:16
interface
[04/01 10:15:18] [WARNING] [qt.network.ssl] QSslSocket: cannot call unresolved function SSLv23_client_method
[04/01 10:15:18] [WARNING] [qt.network.ssl] QSslSocket: cannot call unresolved function SSL_library_init
Midnight
@MidnightRift
Apr 01 2017 08:16
I am a lot less familiar with interface, what i can recomend is to look at the latest build in the stable branch to compile. it should be RELEASE-6227
Christoph Haag
@ChristophHaag
Apr 01 2017 08:16
hm, it was an incremental build after quite some time since the last build. I'll try a full rebuild
Christoph Haag
@ChristophHaag
Apr 01 2017 08:52
didn't help... and it's the same with RELEASE-6227
maybe some trouble with the Qt5.6.2 binaries from the qt website
high fidelity still doesn't support qt 5.7 or 5.8, right?
Christoph Haag
@ChristophHaag
Apr 01 2017 09:07
hm, tried to compile qt5.6 myself, but multiple build failures in qt's ssl code. I think it's safe to say it can't be built with up to date openssl libraries
Christoph Haag
@ChristophHaag
Apr 01 2017 09:18
yea, needs explicit configuration to compile with openssl 1.0 instead of 1.1...
Christoph Haag
@ChristophHaag
Apr 01 2017 11:06
damn, almost an hour to build qtwebengine
Christoph Haag
@ChristophHaag
Apr 01 2017 11:18

no improvement though. clicking around i see random errors like

[04/01 13:14:05] [DEBUG] [hifi.networking] AddressManager API error - QNetworkReply::NetworkError(UnknownNetworkError) - "Error creating SSL context (error:140A90A1:SSL routines:SSL_CTX_new:library has no ciphers, error:140A90A1:SSL routines:SSL_CTX_new:library has no ciphers)"
[04/01 13:14:05] [DEBUG] [hifi.networking] QNetworkReply::NetworkError(UnknownNetworkError) - "Error creating SSL context (error:140A90A1:SSL routines:SSL_CTX_new:library has no ciphers, error:140A90A1:SSL routines:SSL_CTX_new:library has no ciphers)"

but maybe this isn't really the problem. Login and Go To doesn't work, but Users does show two users. But when I try to teleport to them, nothing happens...

i guess it's just broken on archlinux for currently unknown reasons
Christoph Haag
@ChristophHaag
Apr 01 2017 13:14
almost forgot what i wanted to do in the first place - try steamvr support on linux. but there's no hmd option in the display menu. is it specifically disabled on non windows platforms?
Christoph Haag
@ChristophHaag
Apr 01 2017 13:49
the libopenvr_api.so that is built by hifi doesn't export VR_IsHmdPresent
may be related to my bug report ValveSoftware/openvr#425
Christoph Haag
@ChristophHaag
Apr 01 2017 14:00
oh wait, is interface/plugins/libopenvr.so is not supposed to be the same as libopenvr_api.so. my bad
Christoph Haag
@ChristophHaag
Apr 01 2017 14:07
aww
/usr/bin/ld: warning: libssl.so.1.0.0, needed by /opt/qt5.6/lib/libQt5Network.so.5.6.2, may conflict with libssl.so.1.1
/usr/bin/ld: warning: libcrypto.so.1.0.0, needed by /opt/qt5.6/lib/libQt5Network.so.5.6.2, may conflict with libcrypto.so.1.1
Christoph Haag
@ChristophHaag
Apr 01 2017 14:22
so what I have so far is this ChristophHaag/hifi@f2380d8
it compiles and starts to run, but it crashes interface with [04/01 16:21:52] [FATAL] [default] Cannot make QOpenGLContext current in a different thread
Christoph Haag
@ChristophHaag
Apr 01 2017 14:31
put it in a github issue so I can stop spamming here :) highfidelity/hifi#10098