These are chat archives for highfidelity/hifi

22nd
May 2017
chrishowe1p
@chrishowe1p
May 22 2017 15:25
when I try to access my sandbox I am told I can't connect to the domain. Also, the developer room appears to have vanished? and client-side scripts don't seem to work anymore (neither my own or the tutorial scripts). Any idea what went wrong? is this an issue on my end? I am seeing the same on another PC.
Midnight
@MidnightRift
May 22 2017 15:27
@chrishowe1p is the Hifi Sandbox icon in your tray (bottom right) its a circle with an H
chrishowe1p
@chrishowe1p
May 22 2017 15:30
i use the Home icon in the GoTo menu
Midnight
@MidnightRift
May 22 2017 15:31
sandbox needs to be running on your local machine. that is what i was asking you to check if it was running.
chrishowe1p
@chrishowe1p
May 22 2017 15:31
is that new? i didn't have to do that before
Midnight
@MidnightRift
May 22 2017 15:32
I am unsure I can say its been that way for atleast 8 weeks though.
chrishowe1p
@chrishowe1p
May 22 2017 15:33
umm ok :) well im not sure how it was working for me before but I'll get that running and hopefully that fixes things for me. thanks! Any idea why the developer area no longer appears though? and I can't seem to run scripts in any domain? it would seem strange if the sandbox was required for that.
Midnight
@MidnightRift
May 22 2017 15:35
have you tried to run your scripts in say Welcome ? or any domain that is currently online ?
chrishowe1p
@chrishowe1p
May 22 2017 15:36
I have tried a few
what is the url for the Welcome domain?
Midnight
@MidnightRift
May 22 2017 15:37
okay if there not running, try checking the log in the developer menu.
hifi://Welcome
Midnight
@MidnightRift
May 22 2017 16:00
are Overlays Only viewable by the person who its created for or is there a flag that allowes for it to be viewed by all
Seth Alves
@sethalves
May 22 2017 16:36
overlays are only viewable by the interface that creates them. if others should see it, you want an entity
Midnight
@MidnightRift
May 22 2017 18:57
Thanks @sethalves
Philip Rosedale
@PhilipRosedale
May 22 2017 19:07
@chrishowe1p Are you able to bring up 'Running Scripts' from the Edit menu, and then select 'Load from Defaults' ?
Clément Brisset
@Atlante45
May 22 2017 20:33
@chrishowe1p The developper area is a blank canvas in your sandbox for you to experiment with.
The Sandbox is a separate application that runs the server. It has a tray icon that let's you start/stop it, etc.
We you first install High Fidelity via our website, the installer has a checkbox enabled by default that let's you choose whether you want to start the sandbox when the installation is finished.
What probably happened is that you installed High Fidelity and we started the Sandbox when the install was finished so you were able to connect to your home domain.
But you must have restarted your computer since then and so the Sandbox is no longer running, hence why you can't access it.
You can find more information about the Sandbox in our docs: https://wiki.highfidelity.com/wiki/Sandbox
We are in the process of improving and updating our docs so this page will probably move in the short future.